Have a feature request or suggestion? Post your idea here!


2 abonnés S’abonner

XDJ RX3 - USB-Port1 & Port 2 not working

Both ports of my RX3 suddenly stopped reading my USB-sticks.

error E-8307: DEVICE NO RESPONCE pops up.

due to that Updating on the newest firmare is also not possible any more.

Also powering an iphone via the USB Ports is not working any more.

Do I have to send in my device for repair or is there a workaround to reactivate the ports?


Cette publication n’accepte pas de commentaire.

3 commentaires


Hello BriChi,

i formated a new usb stick FAT 32 with 2 tracks.

-> it worked on usb Port 2 but Usb 1 is still not working at all - same error message.

USB 2 is also still not responsing to my other FAT 32 Sticks which worked before without any probelm and do work properly on my mac

Affe06 0 votes
Actions pour les commentaires Permalien

i would file a ticket or use the working USB stick to try a FW update again but not sure if the FW updates read USB port 2

BriChi 0 votes
Actions pour les commentaires Permalien