Have a feature request or suggestion? Post your idea here!

Publication

5 abonnés S’abonner
1
Avatar

Using DJM-900 Nexus's midi clock / bpm counter for controlling lights

Hi,

I'm wondering if its possible to output the calculated beat bpm from the mixer to input over midi in a lightning controlling software that can input midi

Aka, i want to "tap" in sync with the music

Is this possible?

Thanks!

Marcus_Sweden

Vous devez vous connecter pour laisser un commentaire.

28 commentaires

0
Avatar

I believe this is possible, but I'll have to double check.

Gavin 0 votes
Actions pour les commentaires Permalien
0
Avatar

Yeah it's possible. Download MIDI Yolk, BInd the DJM900 to a YOLK Channel, I use YOLK 3, then in your controller have it receive the midi signal on YOLK 3, This is actually pretty cool since you can actually have multiple systems get the midi clock from one source.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

If you set the DJM900 to auto bpm, it will always be in sync with your music and send a clock change accordingly.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

Cool. I've managed to get the sync in windows but i've not tried to "route" it through Yolk

I'm using Qlight (open source) to controll my DMX lightning

Thanks, i'll try this!

Marcus_Sweden 0 votes
Actions pour les commentaires Permalien
0
Avatar

I suppose you mean Midi Yoke btw, i cant find Midi Yolk?

Marcus_Sweden 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hey Rob,

Maybe I'm not getting the midi clock feature.. it seems to be setup right (meaning things sound sync'ed to traktor as far as routing effects goes) but I would have thought the BPM on the effects display would match the BPM displayed in Traktor's clock.  Am I wrong to assume that?  I've tried a ton of different combinations but I can never get them to match exactly right.  Is this intentional on the DJM900?

For example, if I have traktors master clock selected in top left clock of traktor and set at 130 bpm, my bpm on the djm900 can read 160 bpm.  Shouldnt they read the same on both the traktor clock + djm900 clock if they are talking to each other correctly?  I do have to try pretty hard to find a part of a song where I see a 30 bpm difference.. they usually stay within 5 bpm of each other but its just got me questioning if I am using the midi clock to its full potential.

Are there any walk-throughs out there about syncing traktor to the djm900?

 

Thnx

 

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

Oh man yeah that diffinatly not as intended. I have my DJM900 and Traktor synced with no deviation in tempo. The only time I get them off sync is when I scratch. Other than that they stay synced. I will look into this today when I get home. I will hopefully add a youtube video to help visualization.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

Thnx alot - I appreciate it - funny, I was just loading up your tsi for the 1st time to check out the midi control capability (the htbrkd v1 is yours, right?).  Looks nice so far..

And thnx on the midi clock - its been driving me crazy trying to figure it out..

 

 

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

Yeah. That's my .tsi at traktorfreaks and traktorbible site. Any who setting of my djm in the living room to check it out and hopefully get you going.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

My best guess at the issue is that djm900 wont stop sending its midi clock which i assume means it wont stop using its own midi clock. I used midiox to watch the clock and it is impossible to stop it.

I cant verify that its even receiving traktors midi clock tho.. In fact, i cant even verify that traktor is sending out a midi clock signal as i cant seem to install a virtual midi port that midiox can watch. Im on win7 64bit and tried midiyoke and maple midi but neither seem to work with 64bit. But im pretty sure that traktor sends a midi clock signal. I think i tried midibloop a week or two ago to set up a virtual port to mess around with.

I was going to borrow a friends macbook to see if this solves anything by chance..

Thnx

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

OK so I tried to miss allign the DJM900 to traktors master BPM counter. I couldn't. Even when Scratching it maintained the BPM. You can check out the vid the djm trans effect maintains its timing even with scratching involved. I even turned midi off on traktor just to see if the DJM900 could read the incoming BPM correctly and sure enough it did. The closest I could deviate the BPM was by 1. I used mostly house music at BPMs ranging from 130-177 lol chipmunks. Anywho I will keep trying. With ableton it's easy to check if its receieving a MIDI clock from an external source since it has a lil box labeled [EXT] and blinks yellow. I se it when i use the djm or when i use traktor to send its midi clock to it.

http://www.youtube.com/watch?feature=player_embedded&v=FaMZ9QBcS6g

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

Check this vid out (sorry for shakiness, had to record it with my ipad)..

http://www.youtube.com/watch?v=SfyqSeU9xcU

 

Bear in mind, this is an extreme example - the bpm is typically not off by this much.  It took me a while to find an example that deviates this much.  Usually, its 2-3 bpm and 5-6 bpm would be the average really bad end.  And it DOES match often but I think thats because DJM900 is calculating itself and getting it right.

  • Traktor set to send Midi Clock at 0 ms latency

  • Traktor generic MIDI device setup (tho I dont know that this does anything and I've tried multiple variations of this - some peeps recommended midi2loop or midibloop or to try just setting the IN port or just the OUT port, etc)

  • Song plays for a bit with Traktor set to send MIDI clock (hit the sync a few times for good measure)

  • Traktor master clock = 130 bpm

  • Deck A sync'ed to master clock = 130 bpm

  • Check out the DJM900 readout (I hit the midi start/stop button a few times throughout as it does seem to have some impact)

  • Then check out where I start the 4 beat loop (djm900 starts reading at 170 bpm +)

Are you on Windows 7?  The one thing I have not tried yet is using MIDI Yoke cuz I can't get it installed on Win7-64 bit (you think this would solve the issue perhaps?)

 

Thnx for taking ur time to look into this - I really appreciate it

 

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

Still on this. Sorry it's been awhile. After messing around a bit with the mixer I somehow made the DJM-900 now constatntly send the midi clock wich conflict with Traktor sending its Midi clock since now we have what would be called a collision in the ethernet world. I will jump back on this weekened. There is hopefully two ways to fix this.

1) DJM900NXS hopefully has a feature to turn off the TX MIdi port.

2) Use Midi OX to filter out the TX port. This will allow the DJM900NXS to use the RX port for its clock source.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Robert > Yes; simply press the MIDI ON/OFF button.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Robert - Thnx Robert - appreciate the help..

I tried #1 til I was blue in the face..

I thought about #2 but thought midiox filters just allowed you to filter the midi signal messages from the log view.. I will definitely look further into this option too. 

@Pulse - do you mean the MIDI ON/OFF button is the button that stops the midi clock on the djm900?  I tried alot of ways with the MIDI on/off + MIDI start/stop buttons but it didnt seem to stop the clock according to midiox.  If your answer was in regards to a different question, disregard.

 

Thnx

 

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Pulse. Pressing Midi START/STOP does not work. Using MIDI OX you can still see the DJM900 sending it's clock, If you enable Traktor MIdi Send the music warps to a near grinding halt. On the Good news I just stopped the DJM900 from sendinig it's clock using MIDI OX. Going to attempt to do it again to make sure it's a consistent way to stop it.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

OK this is what i got so far. The MIDI Start/STOP does in fact start the midi clock but as far as stopping it. That does not work. It does send the Stop command but the DJM900 does not follow through with the STOP issue. Something maybe the engineers can maybe look at.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

Ok it works. For fix action follow these steps.

Start up MIDI OX.

Select DJM900 as your input. I will suggest you get LoopBee cause it will allow you to use multiple controllers in one instance.

Open up the MONITOR INPUT. This will show the DJM900 Clock Running.

In MIDI OX select VIEW/GENERATE MIDI SYNC. It's located on top of the program near the help menu. Just under it.

A digital clock will appear. Hit PLAY on it.

On the DJM900 if it's on AUTO switch it to TAP.

Now on the DJM900 hit the TAP button twice. The DJM900 Clock is now STOPED!!

You can actually start it again by selecting AUTO but you will need to use this method to STOP it again.

This in my opinion is a bug in DJM900 might only effect us windows users unless the mac people are having the same issue.

Let me know if you need me to post a video tuturial on how to do this. I can explain it also while I do it..

This was a tough one.

P.S You can stop MIDI OX timer to if you want something else to be the master.

 

 

 

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

hahaha i just read your 1st post here. If you get loopbee you can use it for your light controller scenario. The cool thing about MIDI OX and LoopBee togther is you can essencially share out the midi clock from one source like a splitter. This also works to say combine multiple controllers so each does essencially the same thing. Kinda like a multicast or more like a broadcast in Networking.

Just on a side note. I passed my Cisco Certified Network Proffesional Cert!! (CCNP) going for CCIE next in Routing and Switching!

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

Thnx Robert for taking the time to do this.. Ill try this out soon.. Weird how im the only one whos seen this issue, i wonder if its the tracks im playing.. Ill update my ticket i submitted to pioneers help desk

No need for a video, i think i can manage those steps.. Will report back soon.

Congrats on ur cisco cert.. Those are not easy.

The other thing i noticed that seems screwy about djm900 midi clock is this - i tried to go a different route and have the clock sourced from djm so traktor was slave. This technically works but due to thise fluctuations you saw in the vid i posted, the music would get really fast at times. So i tried to go the TAP route. Again, i cpuld get traktor to act as slave but i noticed that traktor didnt stay steady.. If i tapped in 130 on djm, id see on traktor that my midi clock would stay on the move because my bpm would just keep jumping around by increments of .01 (the range was approx .5 bpm). I would have thought TAP would hold bpm steady as a rock. Hate to say it but i do think the bpm is screwed up on djm900 at the moment (at least on my unit). If i really depended on sync, id have returned the mixer by now.. But luckily, i try to stay away from most sync features As i think things are a little more flexible without it. If i use it, its to get temporary temposync and then i turn it off. I have been dying to see how much different the djm effects sound with proper midi clock tho (i know they have a very noticeable difference with rekordbox quantize on vs off so im hoping to get similar benefit).

Thnx again!!

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

Definitely worked in terms of stopping the midi clock.. but the issue I see is that when I go back to Traktor + start the midi clock send, I believe I pretty much have to hit the Auto BPM on the DJM900 in order to get the DJM900 to work properly (which in essence starts the djm900 clock again).  I am pretty sure that I have to have the DJM900 in Auto for it to pick up Traktor's clock - is that right?  Any ideas for getting around that part?  I tried to use MIDI start/stop button on djm instead of reverting back to Auto.

Did you cut back to Auto BPM on djm after you managed to stop the djm midi clock?

 

Thnx

 

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

woot the challenge begins again. lol. When I get home from work i'll work on this.

So you basicly want the DJM900 as a midi clock slave and Traktor as a Midi clock master. Hmmmm with out trying it. I think the DJM900 once in MIDI mode the button in the left. It should be able to recieve a midi clock and work the way you want it but I don't know. At work at the moment.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

lol - no rush at all man.. i just cant tell u how much I appreciate u even trying to help me with this.  Its not urgent by any means - I can live without it but I'd love to figure out if my unit is just screwed before my warranty expires..

I tried both the MIDI start/stop + the MIDI on/off but to no avail.  Auto just turns the dam clock back on regardless of any of those buttons as soon as you hit the AUTO BPM button on the djm.

And yes, the ideal situation would be that:

  • Traktor midi clock acts as master

  • DJM900 receives and uses that midi clock

  • With the end result being that the BPM readout of traktor + BPM readout of djm are exactly the same

** This is how you basically have yours set up right? 

 

Kevin Savage 0 votes
Actions pour les commentaires Permalien
0
Avatar

I've been trying the way you decribed it, and the mixer send the BPM just fine (checked with MIDIClockDetect.exe)

Problem is, that my Lightning software does not support Midi Clock, but only midi events (press of a button etc)

Is there a way to virtually convert the midi clock to midi key strokes?

 

Marcus_Sweden 0 votes
Actions pour les commentaires Permalien
0
Avatar

Yeah, a MIDI translator would be required for any lighting controller (hardware) that has pre-mapped and unchangeable CC codes, or software that is poorly designed and doesn't allow for proper mapping.  Thanks for the link to that @Robert.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Oh nice a midi timing issue was fixed with new patch. Wow the pioneer gods do read the boards. Hahaha. Jk. Hope this helps solve Kevs issue.

Robert Rodriguez 0 votes
Actions pour les commentaires Permalien
0
Avatar

Unfortunately not :(. That was my first thought when i saw the firmware enhanced midi clock (tho thats a pretty blanket statement). It actually appears to have made the problem worse especially when trying to use TAP bpm just to hold the bpm steady. I didnt try ur workaround tho but i think ill try it today.

Thnx
Kev

Kevin Savage 0 votes
Actions pour les commentaires Permalien