Have a feature request or suggestion? Post your idea here!

Publication

3 abonnés S’abonner
0
Avatar

How do I record directly into my laptop from a DJM 900?

I know, I know, there ARE a lot of topics for this, but I have read them and tried my best and still have no clue where to start. I am UBER noob at all of this. I'm pretty sure my first step is to get past this: http://i.imgur.com/ZfLbf.jpg and this: http://i.imgur.com/1LQlq.jpg

i currently have one cdj 900, djm 900, and 2x cdj 2000s. my laptop has adobe audition and is hooked up to my djm 900 via LAN cable and USB cable... do I need any more cables? what exactly do I do for the djm 900 nexus settings? i just updated all my software as well... thank you in advance...

Andrew Navarro

Vous devez vous connecter pour laisser un commentaire.

22 commentaires

0
Avatar

You need:

  • USB to the laptop

  • drivers for the 900

  • software (Audacity)

Done.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

what exactly are the "drivers for the 900"? I have the USB for the mixer and the software... In the pictures I posted above for the settings, is that correct?

Andrew Navarro 0 votes
Actions pour les commentaires Permalien
0
Avatar

Recently I'm using Cool Record Edit but unfortunetly I cant get a good quality record.When recording via usb in some part of it You are able to hear a silence. Tryed diffrent configuration. I'm a Windows Xp user. Also checked record on Sony Aciid 7 - its like sound breake for a 1-2 sec. And then You can hear sound again. Could You help please.

Zibby 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Andrew > Don't forget you're RCA or Digital cables from your CDJ to your DJM. ;)

@Zibby > Have you gone into the DJM-900 Utility menu  and set your sample rate to the same as you have on your computer and your software? i.e 96000Hz

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

@ Foster > Sample rates are the same 96khz. Chanel 1/2 set up as Rec out.

Zibby 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Zibby > Maybe a bit more info on what is going on might be helpful. But please double check all 3 locations have the same sample rate.

How are you using your DJM-900 and how is it connected to your other gear and computer?

You are using Windows XP on your recording computer correct?

Have you tried a different type of software to record instead of Sony Acid? 

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Foster - Thanks for Your help it was realeted to sample rate. Thanks for advice.

Zibby 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Zibby > No worries, I'm glad I asked you to double check. :)

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi all,

I'm having similar issues to Andrew Navarro with the recording from a DJM 900 on Windows 7. I've got my Nexus set up for a sample rate of 96000Hz. However, I can't activate either the 48000 Hz or 96000 Hz sample rates on the DJM 900 Setting Utility in windows - they're greyed out.

Any ideas on why this would be?

A.Ze 0 votes
Actions pour les commentaires Permalien
0
Avatar

Thought I might also add that I am using the latest driver version (1.303) for Windows 7 and firmware on my DJM 900 Nexus. 

A.Ze 0 votes
Actions pour les commentaires Permalien
0
Avatar

@A.Ze > Are you trying to change the settings once a software application has the DJM assigned as a soundcard?  You need to have it unassigned in order to change it.  I'm not sure if you can change it when the mixer is disconnected, but the other option is to change the hardware setting by holding the utility button while powering-up the mixer.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hey Pulse, the two higher sampling rates still remain greyed out, even with the mixer disconnected. Also, I just tried to change the hardware setting but the DJM Nexus won't let me go lower than 48 kHz.

A.Ze 0 votes
Actions pour les commentaires Permalien
0
Avatar

No, 48k is the lowest you can go.  Don't try changing the rates; they may be changed automatically when the software connects to the device.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

pulse can you help me with my original question? your answer just seem vague. what do you mean "drivers for the 900"???? and look at the pictures i posted. what settings do I adjust for the input / output? (there are two pictures, one for each) if the knobs are on anything but CD/Line, there's no output. is there a simple step by step guide to show how to record internally into a laptop w/ just the USB cable and software? like I mentioned before, I am new at this. thank you in advanced.

Andrew Navarro 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Andrew > Would it be okay if I copy and pasted you a very detailed version for Mac and you could just make the changes to work on windows?

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

yes as long as I have the right stuff to make it work.

Andrew Navarro 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Andrew > I'm going to send you a lot to sift through.

You are going to need the ASIO drivers updated to the latest version when using the sound cards.

You will need the latest DJM-900 firmware and drivers found at this page: http://forums.pioneerdj.com/entries/20230863-djm-900nexus-drivers-firmware

Anything that is underlined is for Mac and will/may be different for Windows.

 

                                                                                                                                                                                                                                                    

DJM-900 Nexus VERSION 1.2.0:

To reach these setting Hold "Utility" on mixer and power up at same time. Hold until "DOUT LV" appears. To change a setting, hit "TAP" button and use < BEAT > to change. Hit "TAP" again to exit. Must power down and back up to use after complete.

DOUT LV "-19 dB", DOUT FS "96kHz", MS ATT "0dB", AUTO STB "ON", MIC BTH "ON", PC UTLY "ON", INITIAL "NO".

 

To reach these settings you must power on first, then press and hold "Utility" button. To exit just hit "Utility" again.

F.S. OFF, MIDI CH 1, MIDI BT TGL, TLK MOD ADV, TLK LVL -18dB, 

 

Open DJM-900 Nexus Utility on Mac VERSION 1.1.0:

MIXER INPUT: All set to "DIGITAL" (because I'm using the digital outputs on the CDJ's to the mixer's digital inputs)

I understand this is where Traktor users will have the channels set to USB 1/2 through to 7/8.

MIXER OUTPUT: USB1/2 "REC OUT", I am not using the other channels and left them as default settings.

 

In "Spotlight" on Mac (the magnifying glass in the top right corner), search for "Audio MIDI" and select the "Audio MIDI Setup" application. OR without using spotlight, navigate from "Finder", "Applications" folder, "Utilities" folder, "Audio MIDI Setup" application.

In Audio MIDI Setup, select the individual "DJM-900nexus" device. Under the "Input" settings, select "96000.0 Hz" and "8ch-24bit". Under "Output" setting, select "96000.0 Hz" and "8ch-24bit" as well. Then "Quit" "Audio MIDI Setup" or press "Apple + Q".

 

Download "Audacity" free from their website. VERSION 1.3.12 is the latest version I have, but there could be a newer version.

 

After installing "Audacity" open the application.

Under the title "Audacity" in the top left corner, navigate to the "Preferences" pane. On the left panel, make sure you are in "Devices"  and under "Recording" set the "Device" as "DJM-900nexus) and "Channels" as "2 (Stereo)". Then, on the left panel select "Quality" and make sure the "Default Sample Rate" is "96000 Hz", and "Default Sample Format" is "24-bit". Click "OK" to accept.

 

 

After all of these steps, it should not be necessary to restart your computer, but it might not be a bad idea.

 

NOTE: Once restarted if you chose to, double check the settings in "Audacity" when you open it.  

 

Prepare "Audacity" to record. You can click the big brown circle thats a button to start the recording, or simply press "R" and the recording will begin. Then play your CDJ and make sure all the levels are set on your mixer. You should actually see "Audacity" creating the Waveform as it records! If you do not see the waveform, you set something up incorrectly and should recheck your settings. If "Audacity" is recording properly and you see the waveform.

                                                                                                                                                                                                                                                    

 

For Windows, you're probably going to need to access a screen such as the picture I added to this post below.

 

This should hopefully work if you're able to select all the settings correctly. If not, try a different sample rate such as 48000 Hz across your entire setup and computer.

 

Please let me know if this is detailed enough or if you would like more informations or more catered towards Windows for you. I can get this Windows side for you, but I don't have or use Windows and you could probably do the digging yourself if you're up for it. ;)

 

Let everyone know how it goes and good luck. :)

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

It's almost the same as what's in this video:

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

my djm 900 have all the correct settings, and my 3 cdjs and djm are updated to the newest software. i'm stuck at this part

"INPUT: All set to "DIGITAL" (because I'm using the digital outputs on the CDJ's to the mixer's digital inputs)"

the problem is there is no audio output whatsoever when my channels are set to digital. there will only be an output if they are on "CD / Line". and I also have no clue as to what to adjust for the DJM 900 settings here

Andrew Navarro 0 votes
Actions pour les commentaires Permalien
0
Avatar

@pulse the djm 2000 settings, how you have to select the configure options for the 1 input, i can't find that anywhere for the 900 settings. can you help me?

Andrew Navarro 0 votes
Actions pour les commentaires Permalien
0
Avatar

i finally got it. thank you so much for all of your help, really. with the free channel i have (2) i set it to digital. 1 3 and 4 are still under cd / line.  on the settings menu, 1 3 and 4 are under REC OUT, and 2 is TIMECODE DIGITAL. i am recording right now and haven't heard the quality yet tho... all my settings are set right, should work perfect

Andrew Navarro 0 votes
Actions pour les commentaires Permalien