Have a feature request or suggestion? Post your idea here!

Publication

2 abonnés S’abonner
0
Avatar

No "LINK" icon when connecting CDJ2000s to DJM2000

Can someone please advise why I do not have the "Link" icon appearing on my HP laptop when I link the CDJs to the mixer, which is then connected via LAN cable to the laptop? The two CDJs are going into channel two and three of the mixer and have their LAN cables connected to the mixer.

I have uploaded the new firmware (from 4.01 to 4.10) to the CDJs, disabled all other internet connections and firewalls. All external hard drives have been removed as have bluetooth connections.

Having spent £4500 on two CDJ2000s and a DJM2000 it's got to be easier than this Pioneer... there are too many problems setting everything up.

I have read through the Q&A section also, before posting.

Is there a UK hotline available for rekordbox problems, as there ought to be when spending this kind of money?

If anyone out there can speak to me on the telephone about this, if they could let me know please, that would be appreciated and I would be massively grateful.

David Matthews

Coventry

UK

07878 959 524

 

0) Have you read the "READ ME FIRST" thread in its entirety before posting: Yes, I swear it

1) Operating System: Windows 7

2) OS Type: Don’t know if it is 32bit or 64bit

3) Rekordbox version: 1.5.3.6

4) Using LINK: Trying to!!! It is not coming up on the laptop screen

4a) LINK Connection method: DJM2000

4b) Using with CDJs: Yes – two CDJ2000s

5) Hard drive / Flash drive / SD card file system: Wanting to use in tandem with a portable WD hard drive

5a) Does the device have multiple partitions: Unsure

5b) If it's a flash drive, is it a U3 device: N/A

5c) With what utility did you format the device: The drive is not “formatted”

6) Have you scanned your files for errors: No

7) Have you scanned your drive for errors: No

8) Is Rekordbox crashing at all: No

8a) If crashing, is it resulting in: N/A

8b) If not crashing, are there any error messages: No

9) Are you able to repeat / reproduce the problem: No

9a) If yes, can you do it consistently: N/A

10) Any other notes regarding your setup only:

Provide as much detail of the issue here:

David Matthews

Vous devez vous connecter pour laisser un commentaire.

20 commentaires

0
Avatar

Couple of basics that you've probably covered already but I'll ask to be sure:

Make sure the LAN cables from the CDJs are in the correct ports on the DJM-2000 (in your case, ports 2 and 3).  Make sure the laptop LAN cable is in one of the two PC ports on the DJM-2000.

Most importantly, I know you've stated you've disabled all other internet connections, but a good thing to do is to disable the wireless connection itself on your laptop.  If you have a function key to do this, then great, else go into Network and Sharing Center, Adapters, and right click -> Disable the wireless connection.

On my laptop, if I have both wired and wireless enabled and run RekordBox, I will have no Link icon.  If I simply disable my wireless with a function key, withouth even restarting RekordBox, the Link icon will appear.

Mark90 0 votes
Actions pour les commentaires Permalien
0
Avatar

OK. Thanks Mark. I'll try it when I get home tonight and let you know how I get on.

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi Mark,

I disabled all internet connections and wirelsss connection (via Network and Sharing) on the laptop.

All LAN cables are in the correct place.

There is still no LINK connection.

What's the next course of action?

Thank you,

David

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

If you disabled the wired network, then there will be no link regardless of what else is going on.

Try connecting one CDJ directly to the computer and be sure you don't have any security software running as well.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Err, yea, you need to have ONE network connection enabled (ie. the one that you're plugging the LAN cable into)...

Mark90 0 votes
Actions pour les commentaires Permalien
0
Avatar

OK gents. Wireless networks have been turned off, with the network connection (Local Area Connection, Unidentified Network, Realtek PCIe FE Family Controller) still turned on.

Still no link facility.

Can you suggest something else for me to try?

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

Are you using a dynamic or static IP address on the LAN?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

When I link the left hand CDJ LAN cable to the laptop the "Player 2" icon on the CDJ flashes for about 20 seconds and then stops flashing. I take it that this means that the CDJ link facility is working but the Rekordbox LINK facility is not.

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

How do I tell whether the IP address is dynamic or static?

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

It sounds to me like it's unable to communicate thanks to a networking issue.  As you're online, I'm going to email you.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Guys - I am getting lost here. Why is this so difficult to set up? I have tried swapping my three ethernet cables between the machines (the CDJ2000s and the DJM 2000) with still no result.

Are you essentially telling me in this thread that I cannot use Rekordbox with the wireless facility turned on? If not why not?

If you are saying that I have to be hooked up to a network connection - i.e. my router, which is downstairs and is not where my equipment is, I cannot do that.

What I want to be able to do is set Rekordbox up for my own use outside as a mobile DJ. I want to be able to have access to Spotify if I need it (for songs that I do not have on my own offline version of Spotify), using my  I-Phone as a dongle. If I have to have the wireless network turned off I cannot access Spotify and have to mess around with settings whilst in the middle of a set, which is as I am sure you understand, not practical.

I feel like "doing a Sasha" where he threw the decks Vestax had given to him, in his pond, but where I turn up to Pioneer UK and throw them through the front door.

Thoughts?

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

Thanks Pulse - I'll await your email.

It's 12.30am in the morning here and I'm up early to get to work later this morning so I'll contact you when I get home later today.

Grateful for your (and Mark 90's) prompt replies!

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

Already sent it -- if you're not around now, would have to be next week due to my schedule.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

@David, if you haven't already, I would definitely try three completely different ethernet cables (other than those supplied by Pioneer). I've had link issues with the ethernet cables that were supplied with my 2000 setup and these issues have now disappeared with the use of other ethernet cables.

From what you describe with the "Player 2" flashing and then disappearing, it sounds as though you might have a momentary link between the DJM and the CDJ, only to be lost again. This is what was happening with my units, particularly player 3 for me. With the link from your PC to the DJM and DJM to player 3, there appears to be no connection at all.

Good luck!

hatrik 0 votes
Actions pour les commentaires Permalien
0
Avatar

*where "momentary link between the DJM and the CDJ" = "momentary link between the laptop and CDJ".

Also, even with your PC completely out of the picture, you should still get a link when you plug your players into the DJM (i.e. the "Player 2" and "Player 3" icons should come up on the CDJs. Are you getting this?

hatrik 0 votes
Actions pour les commentaires Permalien
0
Avatar

Thanks hatrik for your comments.

I'll try a new set of cables now. The CDJs ARE both showing their respective number in the bottom left hand corner of the display screen, so they are connecting to the DJM2000 fine. The CDJs also show as "connected" on the Utilities menu when this is pressed and held, when plugged into the laptop, even though they do not show up on the network connections diagram when I go to my control panel on the laptop, which makes me think it's my laptop settings - but other than that I don't know what to try next!

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

Just wanted to say a big thank you to Pulse for putting some of his valuable time aside last week to sort out my problem with rekordbox not appearing to link to the CDJs and the DJM 2000. After a lot of time searching he finally found out that both public AND private firewalls need to be checked in order for rekordbox to work.

Thanks Pulse for your time, patience and experitise last week - it's appreciated.

David

David Matthews 0 votes
Actions pour les commentaires Permalien
0
Avatar

@David > More than welcome, thanks for your patience in solving the issue!  Glad I was able to learn something from it to help other users moving forward.  :)

Pulse 0 votes
Actions pour les commentaires Permalien