Have a feature request or suggestion? Post your idea here!

Publication

5 abonnés S’abonner
0
Avatar

[SOLVED] DDJ ERGO pitch bend accuracy

I am using the latest version of Traktor . I am trying to determine the pitch bend accuracy of the ERGO. Being used to cdj players i cannot conclude if this is a hardware problem of ERGO or just a "side effect of a cheap pioneer dj player". When you rotate the outer jog of ergo slowly (even for a quarter of a circle) there is no pitch bend at all. If you do it more quickly the pitch is rapidly increased so the whole issue is you cannot accurately make small pitch corrections. In a cdj player any kind of rotation even a slight one, is able to do small pitch adjustment.The inner jog (when pussed and rotated) makes a massive increasment . Traktor jog options include:

jog sensitivity: small value set results in an unresponsive jog rather than fine adjustment, higher values set results in massive increase of tempo.

Tempo progressive bend : does not correct the problem.

This is a software non-related issue as i have tested serato and vdj as well. Is this just wrong settings, hardware problem or just a result of a budget dj player

Famelis Nikos

Cette publication n’accepte pas de commentaire.

23 commentaires

0
Avatar

The DDJ-T1 has the same issue... and it's kind of annoying.

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

I have no problems with Serato DJ Intro. Running smoothly... with the Mac.

Rex 0 votes
Actions pour les commentaires Permalien
0
Avatar

Do all the jogs of the ddj controllers so loose?In T1 model it looks more solid,is it? especially the new cdjs have a really solid feel jog with great accuracy

Famelis Nikos 0 votes
Actions pour les commentaires Permalien
0
Avatar

I have ddj-t1 and it's like you said... "When you rotate the outer jog of ergo slowly (even for a quarter of a circle) there is no pitch bend at all. If you do it more quickly the pitch is rapidly increased so the whole issue is you cannot accurately make small pitch corrections".

@Rex - I don't think it's about the software.

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

You can adjust the sensitivity within the mappings of Traktor.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

well.... that I didn't know. Can you be more specific... which "line" (parameter) ?

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

Actually traktor has many adjustably parameters for the jog.. At preferences -transport tab there are generic parameters:

1)tempo bend sensitivity 2)tempo bend progressive sensitivity option

More specific parameters can be found under the controller manager but it is tricky and confusing because you have to adjust the midi mapping settings. One thing i just noticed is that serato is much more responsive to jog really small adjustments even the outer ring of the jog!!!! which points that it must be a matter of software configuration! Unfortunately by just increase tempo bend sensitivity at tractor i could not achieve this jog's response as in serato. I hope someone could find out something more

Famelis Nikos 0 votes
Actions pour les commentaires Permalien
0
Avatar

It just takes tinkering around with those settings to find the results you prefer.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

After searching in forums and tested lots of combinations in jog settings in Traktor pro 2  i ended up with some settings which give an actual feel of cdj jog!! These settings merged with settings from official *.tsi files of cdj players, with the same jog diameter, are the following and i would like to share with everyone interested:

1)preferences>transport>tempo bend sensitivity set 100%

2)preferences>controller manager> search in the assignment table for the "jog turn" :

you have to set up inner as well as outer ring of the jog seperately ,per deck .The settings upon click on jog turn are:  2% for rotary sensitivity and 100% for rotary acceleration. These settings apply to all 8 "jog turn" parameters.

I also want to mention that lattency settings should be set at the lower time value in order to have a real feeling of mixing! Anything above it seems like "a game" rather than dj'ing. Since everything when mixing depends on ms scale of time i believe that is vital for any ddj owner to read the native instrument's guide:

http://www.native-instruments.com/knowledge/questions/847/Windows+7+Tuning+Tips+for+Audio+Processing

With a middle range laptop tuned up as referred , i have no cpu usage problems any more.

Besides all, investing in pioneer gear means great expectations which for a controller ,require some further setup rather than plug and play of a pair of cdj2000 :)

 

Famelis Nikos 0 votes
Actions pour les commentaires Permalien
0
Avatar

thanks a lot. will try to "tune it up" and see how that modifies the way it feels right now.

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Paul > I just looked and on initial scan I didn't see it, but then I realized my device (top of that window) wasn't the ERGO.  Be sure to change it and you'll see there are a bunch listed.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

perhaps it sounds "stupid" or somethin'... but can you post a printscreen?

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

Traktor-ERGO-1.jpg

1) Click the Controller Manager

2) Select the PIONEER DDJ-ERGO from the list

Traktor-ERGO-2.jpg

3) Click on the "Control" column header to sort alphabetically

4) Find the Jog Turn entries

5) Make adjustments as noted in @Famelis' post 

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

ok, thank you. I do not have any "jog turn" statement in the mappings (it's a list (2)). I will investigate it further tomorow. maybe i'm not using the right mapping.

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Paul > Have you run the hardware setup wizard to have Traktor configure the controller for you?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

yes i did, and the controller works fine. i'm complaining about the sensitivity of the jog wheel and nothing else. i'm trying to get it to work just like a real jog wheel of a cdj.

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Paul > I understand that, and the reason I asked was you said:

I do not have any "jog turn" statement in the mappings

I wanted to ensure that you had everything working properly and that it listed out the multiple mappings as shown and described so you could apply the changes as noted by @Famelis.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Everything I have in the "Controller manager" section is AFTER running the wizard... selected the controller and the mapping was added by the wizard (traktor).  I will try running the wizard again and see what happens.

As info: I tried adding the Jog turn statement by pressing Add in... than "Learn" and turned the jog wheel >> the result was a red message saying: Cannot be mapped (or something related... I cannot say for sure at the moment).

Paul R 0 votes
Actions pour les commentaires Permalien
0
Avatar

As shown in the images I posted, that's what I had after running the wizard, I'm not sure why you're seeing something different.  What version of Traktor are you running?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Okay Pulse , I would like to continue where Famelis left off.

 

Can you please tell me this , i followed his settings - running Traktor Pro 2 also.

 

When i pitch bend with the side of the jogwheel why does it snap back to the original BPM so fast can i slow it down like how it would be on the CDJs? 

Eric Goh 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Eric > Likely a mappings issue, and you may need to adjust your settings accordingly. Please be aware that an update for Traktor is currently available.

Gavin 0 votes
Actions pour les commentaires Permalien