Have a feature request or suggestion? Post your idea here!

Publication

6 abonnés S’abonner
0
Avatar

DDJ RB Headphones

Hello,

I got the new DDJ-RB Controller and all worked fine but since yesterday i can't use my Headphones anymore (didn't update the Program or others). The Controller is connected to the PC. The Sound system, too. The Headphone is connected to the DDJ-RB. But i can't hear anything. Now is my Question how i will have to configure it. For now it is so: (Picture). "Lautsprecher" means Speaker. 

 

Thanks,

Dominik

Wurstwasser-Peter Avec réponse

Commentaire officiel

Avatar

That's because you need to set the Audio device as the DDJ-RB ASIO for the audio to be sent to the RB in order to assign the headphone output.

If you want to have the audio come out of your PC speakers (or speakers connected to your main computer audio device), simply enable the PC Master Output up at the top-right of your rekordbox window:

It will illuminate blue when it's enabled.

Pulse
Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

22 commentaires

0
Avatar

Hello,

I have the same problem as Dominik and your solution does work. However, when i activate the asio driver and i click on the PC master output button there still is no sound coming out of the speakers. When i had the pc audio driver enabled it worked

johannes zanon 0 votes
Actions pour les commentaires Permalien
0
Avatar

@johannes > You still need to ensure that your computer's audio output is configured properly by clicking the DRIVER button within the preferences.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

i changed the audio from "DDJ-RB ASIO" to Line (PIONEER DJ DDJ-RB) and it worked. then when i started the program again after a few hours it didn't work anymore. when i click on the DRIVER button it opens the a window where i can see all the drivers that are zipped. when i click on the driver that is necessary for the ddj rb it installs it but nothing changes within the software (probably because the driver is already installed). so what am i supposed to do after i clicked on DRIVER.

Thanks in advance

jo

johannes zanon 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hello. I have the same problem as in the first entry. I connected my speakers to the laptop, and can't use my headphones on the RB. I think in this version of rekordbox now there is no possibility to enable the PC Master Output. Or I just can't find it :D. I installed the driver for the RB.

Thanks,
Angi

Angelika Pfuner 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Andelika > You need to select the DDJ-RB ASIO as the main audio driver in the preferences, then you can enable the PC MASTER OUTPUT.

Your headphone outputs should then be DDJ-RB ASIO HEADPHONES.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

i have the same problem ddj rb asio is not working .
any solution???

anuj maurya 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hello I have more or less the same issue, here are the settings, i have turned of the master button and selected the cue 2 to listen to it with the headphones, it doesn't work, I updated the drivers but still doesn't work. I read something about the PC MASTER OUT button (on the upper right corner) but doesn't appear on mine. 
Thanks for your help ! :) 

Oscar Biessy 0 votes
Actions pour les commentaires Permalien
0
Avatar

Good evening. Sorry to bother again. 
I change computer and now have Mac os Mojave 10.14, so same pb as for sierra which you helped me solved. 
I read the update about it and did  the exact same thing, but still no headphones. 
First time i reinstalled the driver I clicked on allowed and thought it would work, i plug in my DDJ-Rb and launched rekordbox, but the headphones still don't work and i dont have the little computer symbol on the top right. 

I tried the 2nd step and uninstalled the driver, restarted my macbook and reinstalled the driver :
- No "allow" button in "security and privacy", nothing in "system information" to unblock the driver, and still doesn't work in rekordbox. 

Thank you in advance for your help, and again sorry to bother with this issue.
Oscar



Oscar Biessy 0 votes
Actions pour les commentaires Permalien
0
Avatar

At the top left of your screen shot, see where it says "USB"? Click that and see that the DDJ-RB is detected as a hardware device. If it is not, please try using a different USB port / USB cable.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Good evening, i've checked and i've got this, also i went to the sound parameters on rekordbox and it doesn't give the possibilty to select the ddj-RB pilote (so i guess it's still blocked), and still no "Pc Master out" button.
Do you think it would be able to allow the driver by using the terminal from mac ? or could i ask apple for help or anybody ? 


Oscar Biessy 0 votes
Actions pour les commentaires Permalien
0
Avatar

So, when i opened rekordbox on my new computer with Modjav, i coudn't use the headphones so i did the steps to download the driver and disable the Mac Security. 
I had the "Allow" button the first time, so i allowed did, but it didn't change anything... So i read the update on what to do.
- I restarted my computer.
- I reinstalled the driver and did the step 1 and the step 2, maybe 4-5 times with uninstalling the driver and reinstalling it. But still, it doesn't work. 

Here, i tried lots of time to reinstall the driver and see if the "allow" button appears again, and see if it was blocked in utilitaries. But nothing. 

Oscar Biessy 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Oscar > The idea is that you install the drivers, disable the security warning, and then install the drivers a second time.

You may want to try running the uninstaller included in the driver package, then reboot your computer before installing the drivers the first time.

 

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

By rebooting the computer you mean to format the computer or just restart it ?

Oscar Biessy 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hello, it's working again, thank you for your time ! 
Restarting it wasn't changing anything so i did a time machine and formated the computer then followed the steps you gave me and it worked perfectly ! thank you very much for your patience and for answering my questions
Oscar 

Oscar Biessy 0 votes
Actions pour les commentaires Permalien