Have a feature request or suggestion? Post your idea here!

Publication

9 abonnés S’abonner
0
Avatar

DDJ-1000 Magvel-fader off-centre position FW1.04 bug??

I noticed after flashing firmware 1.04 on my DDJ-1000  the crossfader  cannot be positioned in the exact middle any more. it's way off

 

when i put the hardware crossefader in the middle precisely.  the software fader inside rekordbox is way off to the left.  there is no way to get it exact in the middle which is very annoying.  i recorded a shot video to show what's wrong but i can't seem to post video's in this forum.

 

DJCannonball Avec réponse

Commentaire officiel

Avatar

Hello all,

Sorry for the very late reply.
Thanks to your report, DDJ-1000 engineers finally created a beta firmware to improve the linearity of the cross fader.
Will you please download and install the both DDJ-1000 firmware and rekordbox beta from the link below. You need to update the both at the same time. Otherwise, the update may not be effective.
https://forums.pioneerdj.com/hc/en-us/community/posts/360010735543-Public-beta-version-of-rekordbox-5-3-0-beta3-released-on-May-25-

Please provide your honest feedback to us.
Sorry for the lingering inconvenience and thank you for your kind cooperation.

Best regards,
CRM, Pioneer DJ

Keiko
Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

31 commentaires

0
Avatar

I posted this on youtube to show what's wrong

https://youtu.be/BhH6476ZGSY 

 

please note that this same issue is both on OSX and Windows.  turning it off, putting the crossfader in the exact center and then turning it on again  doesn't help.

on fw 1.03 this was no problem at all

DJCannonball 0 votes
Actions pour les commentaires Permalien
1
Avatar

I can see how that would be a minor irritation when you're expecting it to be aligned, and I'll pass this to our product team to investigate, but to be perfectly honest - that won't affect your DJing. I can't honestly say that I've ever looked at the crossfader and thought "Dang, it's aligned with the lines on the silkscreen, but the mix is slightly off to one side by a couple of decibels." Don't sweat it, we'll get it fixed. ;)

Pulse 1 vote
Actions pour les commentaires Permalien
0
Avatar

I saw some others who have the same issue, like Xavier   was able to fix it by clicking RESET DEFAULT at the bottom right.  

I clicked all the RESET DEFAULT buttons I could find in all tabs but it didn't fix the problem.   the hardware crossfader still doesn't match the software crossfader in rekordbox.

 

I noticed there is an update rekordbox 5.2.2   installed it,  still no fix

SO annoying :((

DJCannonball 0 votes
Actions pour les commentaires Permalien
0
Avatar

Another week has passed.. still no fix :(

DJCannonball 0 votes
Actions pour les commentaires Permalien
0
Avatar

As I posted above, our DDJ and rekordbox teams are working on this -- but the position of the crossfader in the software vs. the hardware doesn't affect the audio itself.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

I noticed this as well. Good to know it's a cosmetical issue. Still hope to see it get fixed for those with an OCD.

Ves 0 votes
Actions pour les commentaires Permalien
0
Avatar

it has been almost a month that I reported this issue.  Together with the other issues  like audio glitches     and  no FX-tail on master channel. still NONE of them fixed  come one guys.

I need this to be fixed!  I can't use this on stage

DJCannonball 0 votes
Actions pour les commentaires Permalien
0
Avatar

As noted above, the position of the fader on screen does not currently match the position of the hardware, but it does not have any bearing on the curve of the audio.

The FX is something they're considering (I've made the same recommendation myself), but we don't have a timeline for the fix as they're currently working to improve the delay when engaging the effects as well.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

will try this fix out right now, this has been so annoying and it did totally effect the audio.

andyfoz 0 votes
Actions pour les commentaires Permalien
0
Avatar

i have downloaded and installed Rekorbox 5 3 0 beta3  and i flashed beta firmware 905 for ddj-1000.    i dropped a tear of joy.  all of my issues resolved at once.

crossfader position of the magvel fader is now the same position as in rekordbox.
no more sudden time-line jumps when exiting loops,  no more glitches.

And..!  i get a nice effect-tail  when turning off reverb/delay effects applied on the master-channel.    well done   dev-team!     you made my day

DJCannonball 0 votes
Actions pour les commentaires Permalien
0
Avatar

Glad you guys are having a good experience with the beta! We're working hard to address all concerns, so if there's anything else, please let us know.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar
 

Rekorbox 5 3 0 beta3

beta firmware 905 for ddj-1000

I was happy to see this implemented, but did not go ahead and install it through fear of a possible system crash while out live (obviously dont use beta software in the club)

im currently running the latest software and firmware and wondered when this beta3 will become part of an official stable release.

i currently have to have the crossfader on screen to make sure that i have it centerd and the sound balanced. I find it very annoying to get it centerd and sometimes have to use the mouse.

really been annoying me week in week out i cant tell you, suprised theres not be way more complaints about this.

andyfoz 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Andy > If you didn't have the fader onscreen, with the hardware fader at the exact centre of the travel, could you honestly tell me (by listening only) that the mix of the two channels was not perfectly balanced?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

I hace the same problem, where can i find that firmware update 905?

I have already update my firmware to 1.05

Gerardo Gomez 0 votes
Actions pour les commentaires Permalien
0
Avatar

i can honestly tell the difference through a big rig.

i am up to date with rekordbox but the issue still remains at present, when will the fix thaty the pioneer tech guy above identied be part of an official release?

andyfoz 0 votes
Actions pour les commentaires Permalien
0
Avatar

i think beta firmware 905 won't be available anymore since 1.05 stable is released.
besides those 2 firmwares could be very much the same except with another name.
so you have flashed  firmware 1.05  and still have off-centre issue on the magvel fader? weird..
it fixed my issue at least.

DJCannonball 0 votes
Actions pour les commentaires Permalien
0
Avatar

well that was a waste of an hour, niether combos of software and firmwares effect the crossfader in any way.

if the software is centered the hardware fader can be almost 10mm off centre.

i hope more can be done.

 

andyfoz 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi, I have the same issue but the crossfader center in rekordbox is very left position on the controller
. The crossfader dont work fine and it affects my work. I have 1.05 FW and 5.30 rekordbox.

diego chacon 0 votes
Actions pour les commentaires Permalien
1
Avatar

same issue here. what's the deal?

I've mapped the crossfader to an effect dial and a channel slider in rekordbox but it's glitchy as hell. seems to be a dead spot around 1cm from the centre of the cross fader and jumps in notches.

ive even tried other 3rd party software with same results.

I've got the latest firmware and most recent rekordbox to date.

I'm assuming this is a firmware/hardware issue and for now im using my volume sliders to mix because if I use my crossfader the volume spikes and ruins a smooth transition!

bit annoying that I can remove or replace the fader if it's hardware!

Ravinstomper 1 vote
Actions pour les commentaires Permalien
0
Avatar

also forgot to mention that the crossfader can't be disabled even tho I delete the midi map. I guess it's because of hid compliance.

is their a way to set the software from internal to external mode using the ddj1000?

Ravinstomper 0 votes
Actions pour les commentaires Permalien
0
Avatar

I, too have this problem. I tried everything... firmware updates, etc...

Support does not answer..

Wurlitzer 0 votes
Actions pour les commentaires Permalien
0
Avatar

Ahg, same here. Big problem for scratching. The lag is different on each side, meaning I have to do totally different cross fader action between the my left and right hand. Anyone found a fix yet? I'm on latest firmware and software.

Higher Vibe 0 votes
Actions pour les commentaires Permalien
0
Avatar

I've asked our engineering team to take another look, they may have additional questions, but thanks for your feedback

@Ravinstomper > If you remove the crossfader assignments from each side of the crossfader itself, it's effectively disabled.

 

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi Pulse glad to see you my friend.

I'm aware of disabling the cross fader on the hardware. I have spoken about this in other posts.

I was referring to the software side. when I delete the crossfaders midi map... its still activating the cross fader on screen even tho the function is deleted. is this HID over writing functions?
I'm asking if we can we set the cross fader to work as an independent one and not via the software.

I used to have an AA vms4 many moons ago and that mixer was able to be used with or without software involvement. ie internal or external control whilst using only software to mix if you catch my meaning.

Ravinstomper 0 votes
Actions pour les commentaires Permalien
0
Avatar

Unfortunately not -- even if you remove the MIDI assignment, the fader itself will still move, but it would have no function once unassigned from the channels themselves.

The fader itself is software-based when the input channels are from software, and hardware when using analog inputs.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

I guessed it was the case.

I have commented in other posts regarding this subject. please would you mind taking a look and getting back to those whom need your advice.

Ravinstomper 0 votes
Actions pour les commentaires Permalien
0
Avatar

So the engineering team has informed me that the reason there are some differences in the accuracy of the position of the hardware to software because the resolution of the magvel pro crossfader in the DDJ-1000 is optimized for the extremities of the fader; in other words, it's much more accurate at the ends of the fader for scratching.

Don't worry 100% about the markings on the hardware mixer, simply move the crossfader to a position where the on-screen crossfader is at the mid-point and the audio will be balanced.

As for the issue @Higher Vibe describes, they believe it's a calibration issue with the crossfader and recommend you please contact Pioneer DJ technical support in your region to have the crossfader recalibrated. Anyone else having a similar issue with the cut-in lag not functioning as expected should do the same.

Pulse 0 votes
Actions pour les commentaires Permalien