Have a feature request or suggestion? Post your idea here!

Publication

4 abonnés S’abonner
0
Avatar

Compressed audio output when recording a mix in Rekordbox

When recording a mix in Rekordbox, some songs would a be much louder than others, even with auto gain enabled. I recorded a short mix twice and compared wave forms to find out that certain songs appeared to be compressed heavily. I attached a picture to help explain what is going on. Both tracks were recorded right after one another without changing any settings or options. I am using a DDJ-1000 with Rekordbox 5.4.0.

Nick Arbogast

Vous devez vous connecter pour laisser un commentaire.

10 commentaires

0
Avatar

Tried it again and unselected "Automatically optimize volume of recording" under the recording settings. Same result. Any ideas?

Nick Arbogast 0 votes
Actions pour les commentaires Permalien
0
Avatar

Yes I do, I'll try again with it disabled.

Nick Arbogast 0 votes
Actions pour les commentaires Permalien
0
Avatar

I tried making a mix with auto gain disabled, and it seemed to make the issue less common, but it still occurs. I even tried keeping my channel volumes, master volume, and recording volumes in the green to be safe with the same results

Nick Arbogast 0 votes
Actions pour les commentaires Permalien
0
Avatar

Where are you at with the levels in terms of the channel gain? Because that's where the recording levels are taken; the fader itself only cuts the levels below that point.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

By channel gain do you mean trim? I've set the trims so the LED indicators never leave the green into the yellow. I've done the same with the master output. In settings, I have disabled "automatically optimize volume of recording" option in the recording tab, I have set the headroom to -18 dB in the Mixer tab, and I unchecked the internal limiter option under the DDJ-1000 tab. Still getting the same results.

Nick Arbogast 0 votes
Actions pour les commentaires Permalien
0
Avatar

Also for my recording volume, I've set it so the volume never goes past halfway

Nick Arbogast 0 votes
Actions pour les commentaires Permalien
0
Avatar

If that can help here is my setup :
- no autogain
- headroom : none (this is where you have compression if activated)
- trim : 2 to 3 yellow bar on each channel (dynamic is better that at full green imo)
- volume faders 100% open
- record knob at 9 o'clock into the software
(Rekordbox don't remember record level between session)

When I check the recorded wave file into an audio editor I'm mostly between -10 and -5dB and IF I red ligth once on the mixer it will be a peak arround -3 to -2 dB.

If have tested this with 2 tracks and no samples.
If you need to stack more audio material/tracks, I would suggest to lower the record knob far left to the lowest possible value.

Spark972 0 votes
Actions pour les commentaires Permalien
0
Avatar

I agree and suggest that the current system for recording mixes is not intuitive at all, as evidenced by Nick's struggles above and others, including my own. 

I've come here wondering what I've done wrong after spending another 2 hours on a mix only to have it sound flat and lifeless on the other side, despite auto-gain being off and levels at normal.

I've just followed the bouncing ball and hit the record button as any regular user would do. If poor audio return is the default outcome for every recording, why is it even there at all? Why are users having to tweak the system after searching far and wide online to get a feature to work at it's most basic level?

Could there be some recording setup wizard/click-through initiated on pressing the record button so that the system can prepare itself to record in optimal conditions, and the user can be informed of any input they will need to make?

There's no answer that can solve this in the short term, just passing on the feedback.

Adam Arena 0 votes
Actions pour les commentaires Permalien
0
Avatar

I tried recording several different ways with several different controllers and mixers, tweaking the headroom, the output recording levels, the trim levels, and I was never able to replicate what @Nick shows in the original post. No amount of setting tweaking was able to reduce the dynamic range I had in my recordings in comparison to the original files I used to mix.

My goal was peaking at the first LED above the 0dB mark on the hardware I was using, with the master peaking the same. I was setting the input to the first level below zero (eg. -6dB) and then the recording level was around the 12 o'clock position. All other software gains were disabled or at 12, and my recordings were exactly what I expected them to be.

Not sure what else to tell you -- I find it hard to forcefully screw these things up, so I'm wondering if there was another change that was made somewhere?

Pulse 0 votes
Actions pour les commentaires Permalien