Have a feature request or suggestion? Post your idea here!

Publication

3 abonnés S’abonner
0
Avatar

Do NOT use HFS+ USB file formatting for Rekordbox

So I had an experience recently where a USB would simply not read playlists on an XDJ-RX when I was attempting to take over from another DJ during a live performance. It said "Rekordbox database not found" etc, despite the USB being formatted using the HFS+ file system, and properly synced up with Rekordbox and tested. The macOS is up to date, Rekordbox is up to date, etc. The other DJ would have had to stop their music for me to troubleshoot this software glitch in front of a live audience - no bueno. 
 
The SanDisk USB which was HFS+ file formatted and recently purchased at the Apple store was tested on a brand new XDJ-RX2 prior to heading over to the venue to play on the XDJ-RX. After this experience where the USB couldn’t be read, I additionally went back home after to test the SanDisk USB yet again on the XDJ-RX2 a few hours later and it worked just fine on that controller again. The USB was exclusively used for Recordbox and nothing else. I have never had issues on that XDJ-RX2 controller or the prior XDJ-RX2 I owned with this SanDisk USB or other USBs.
 
Did some further digging into what might have caused this simple but critical problem and did a bunch of testing and reformatting with trusted brand-name USB's on different controllers like CDJ-2000NXS2's, the XDJ-RX and the XDJ-RX2 to find out what was going on and try to replicate the issue. Most notably in my testing, I was able to successfully replicate this read issue of the USB not being recognized on my XDJ-RX2. This issue occurred with a totally different USB. Keep in mind, this XDJ-RX2 has never had issues reading any USB. When formatted using HFS+ the USB began to sporadically throw an error of not being able to read the USB. Furthermore, the USB would work in one port on the controller but not the other port on the same controller. Once a port started throwing the error, it would also continue to throw the error. This was with a completely different brand new Corsair USB that was HFS+ file formatted attempting to be read in a completely different controller (the XDJ-RX2). When I reformatted the Corsair USB to FAT (MS-DOS) in Disk Utility on macOS - it then made the USB into a FAT32 formatted drive. From that point on, it seemed to be solved and I could not replicate the problem of not being able to read the USB.
 
It turns out that although Pioneer officially claims that HFS+ works and is compatible, isn't really NOT a supported by Pioneer or recommended or reliable file system. HFS+ works only sort of, most of the time but this format has major problems if you plan to use it professionally. If you use a HFS+ file formatted USB, just be aware that occasionally the USB simply won't be read at all in one of the USB ports. This issue seemingly has nothing to do with hardware (the physical USB memory stick itself) at all and it’s isolated solely to a bug in the Rekordbox code running on the actual controller (CDJ, XDJ, etc) you're using. If you're taking over from another DJ, that will be a problem because there is often only slot available to transition unless you stop the music entirely. Once a controller throws this read error that it can’t properly load the contents of the USB (despite them being there), it won’t matter how many times you properly eject the USB and try and have that USB port recognize it - it simply won’t work.
 
Highly recommend anyone to use FAT32 (called "FAT (MS-DOS)" on Disk Utility if you're using macOS). It's super confusing because FAT32 is “supposed” to be capped at a 32GB capacity. Why Pioneer is still using a file system originally introduced in the 1970’s that literally was a part of Windows 95 is a bit beyond me. These seem like the kind of compatibility issues that were experienced back when Gateway and Netscape were a thing so hopefully they get addressed soon now that it’s 2020. Although FAT32 is highly antiquated and it’s counterintuitive to select as an option, it might be the only choice for pros who need the best chance of relying on Pioneer gear.
 
Hopefully this PSA saves others the frustration of equipment not working for mysterious reasons. Pioneer says an HFS+ file formatted USB should be fine and claims to be supported but it’s really not stable in use. Keep it old school and use FAT32 formatting to avoid USB problems and spend your time enjoying putting on a performance versus doing stressful tech troubleshooting.
SFO 2935

Commentaire officiel

Avatar

I'll have to respectfully disagree -- I've used a variety of USB drives, both flash drives and SSDs, formatted in HFS+ and they've not had problems. I rarely use the FAT32 file system because I'm seldom on a Windows machine.

Pulse
Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

4 commentaires

0
Avatar

I respect that and can only speak from my own personal experience

I've used Rekordbox and Pioneer gear for several years now and it's never been a problem using HFS+ until it suddenly was. I also share this because I was able to replicate the problem with HFS+ and do so on a different USB device and totally different Pioneer controller but unable to replicate it or produce an error at all doing the same tests with FAT32 formatting.

I upgraded to the latest version of Rekordbox so it could be something in the code on this newest release which created this HFS+ read bug - not sure. From now on, I'm going to just carry around 3 unique USBs from different manufacturers - with two having FAT32 formatting and one using HFS+ formatting as a backup so I guess time will tell as I have more data points if the issue comes up in real time again. Seems like overkill to have to do that but I also didn't think HFS+ would be problematic. It was surprisingly easy to replicate the issue I had during the live show on a different device at home and with a different USB which was HFS+ formatted.

If it helps you to know - I'm a dedicated macOS user and always want to stay within the Apple family. I don't use anything on PC and that's the main reason I chose to use Mac OS Journaled originally. The last thing I wanted is to have to do, is use an outdated system that's associated with Microsoft Windows to format a USB for DJing. As mentioned, HFS+ does in fact work most of the time until it doesn't seem to work on one specific USB port. This is a major concern if that's the only USB port available to you and you're the one transitioning in from another DJ. I was able to replicate the problem of that specific USB port not being able to properly load the USB again and again, even when properly ejected. Every single time, when I tried the other port right next to it on the very same controller, the USB worked flawlessly and just as it should. This is all happening within the same Pioneer device and it only happened when the USB was formatted using HFS+ so I'm just sharing my experience and the tests.

HFS+ was cool and stable for me for years. That was until the USB didn't work properly on the XDJ-RX that I attempted to jump on which albeit wasn't my machine but other DJ's were using it just fine throughout the night, before and after this USB wouldn't load so the controller worked. When I came back, the HFS+ formatted USB that supposedly couldn't load on that RX loaded just fine on both of the USB ports in the RX2. I was also able to replicate the read issue using all different equipment (including a different computer with Rekordbox) and could only do so using HFS+ 

If HFS+ is continuing to work for you I say go for it. Maybe someone on here has insights that I'm not aware of or a box or setting to check off on macOS in Disk Utility outside of the norm that prevents this arbitrary read error. Open to any suggestions!

SFO 2935 0 votes
Actions pour les commentaires Permalien
1
Avatar

I've had the same experience with RX-units, also posted about the issue here on the forums. My experience is that the USB slowly becomes unreadable, first sign is that the cover art doesn't load, next the songs takes longer and longer to load and then the unit locks up. Restart is the only way to get it back up again.

In my experience the RX-unit is the only Pioneer product to behave like this. Last time it happened to me, 3 years ago, I made sure to check the firmware, and yes it was up to date.

I do use HFS+ on my sticks, it's faster on my Mac and on the CDJ players, but always carry a FAT formatted copy incase I have to play on a RX unit.

The Henrik Maneuver 1 vote
Actions pour les commentaires Permalien
0
Avatar
Could totally be an RX issue. I'm going to continue to keep tracking this and carrying around 3 different types of USBs to see what works as I use different gear at different venues.
 
This was actually a fresh USB that had problems only when formatted as HFS+ and they immediately went away when reformatted as FAT32 and the same exact info was re-synced in Rekordbox on that USB. The error happened even before anything might be able to load such as album artwork, playlists, songs, etc. I guess the point is that it wasn’t a slow degradation of the memory or being able to access information. It was that the Pioneer controller simply wouldn’t read this USB drive at all in one USB port on the same controller. Some Pioneers controllers might be able to read it and some USB ports on those controllers would be able to read it but others arbitrarily would not.
 
A few observations that I found regarding speed as it relates to USB formatting if it helps anyone. I'm using an iMac Pro which was setup not too long ago with only a few programs running on it. I went to sync up a test playlist of 397 songs in Rekordbox which were all in .aiff format to see what the speed difference might be between the two identical USB drives (aside from the different file systems selected when formatting the USB). One drive was set to FAT32 and the other HFS+  Here are the timed results of syncing within Rekordbox with all things kept the same only with different USB formatting.
 
FAT32 Rekordbox syncing - 4 minutes and 38 seconds
HFS+ Rekordbox syncing - 2 minutes and 36 seconds
 
The HFS+ is clearly faster to write to which is why I was trying to use it and thought it was a better solution, especially given I’m a dedicated macOS user. In an ideal world HFS+ could be the way to go but from my experience and being able to replicate bugs on the Pioneer controller, it’s not worth the risk to rely on HFS+.
 
On the Pioneer XDJ-RX2 controller itself…
 
The FAT32 USB drive loaded about 4-5 seconds FASTER when docked in the USB port on the device. This is compared with the exact same material as the duplicate USB using the HFS+ formatted USB. This tells me that the Pioneer controller might not be optimized to read HFS+ as well as it handles FAT32. Maybe the Pioneer dev team didn’t give Apple as much love - not sure what the issue is here since Rekordbox handles HFS+ really well and almost twice as fast when syncing.
 
These photos are all from the same Pioneer controller - the XDJ-RX2 which was purchased new in the past few months. It's up to date as well as the Rekordbox software on the iMac Pro. I was shocked at how easily I was able to replicate the problem experienced with a totally different HFS+ formatted USB stick and separate Pioneer controller. The XDJ-RX that I tried to use at the live performance with a completely different HFS+ formatted USB had this exact same issue seen here. I do not know if switching the USB port or shutting down the entire machine and restarting would have worked on the RX since the other DJ was using that port. We chose not to stop the music to troubleshoot but it might have helped to use that USB port she was working off of. Regardless, that’s not an acceptable fix anyways for a device and system that’s supposed to be used for live performances and claims to be reliable.
 
I took these photos because this error is being experienced with literally the same USB being tested on the very same machine. One of the USB ports would consistently not properly load the USB (and once it didn't recognize it in that port, it wouldn't matter if you kept properly ejecting it and trying to read it again, the read issue would persist). The USB port in the same exact machine would read the HFS+ formatted USB just fine. Once again, for the test the USB memory stick used was brand new and I got two of the same USB memory sticks to test this problem. I formatted one USB with HFS+ and the other was formatted with FAT32.
 
I have been unable to replicate this problem with improper reading on one USB port when using the FAT32 formatted USB, out of the two otherwise identical USB memory sticks. When I was using the HFS+ formatted USB, the read issue would occur about 30% of the time. I would restart the XDJ-RX2 and sometimes it would work but sometimes it would not be able to read the HFS+ formatted USB in one of the USB ports.
 

SFO 2935 0 votes
Actions pour les commentaires Permalien