Have a feature request or suggestion? Post your idea here!


3 abonnés S’abonner

Rekordbox 6.01 crashes when cancelling beatport link library load

I am new to Rekordbox and made the jump mainly due to Beatport Link integration not being there in Traktor. However last night I tried to use it and have discovered that it crashes when trying to use the search feature in beatport from within rekordbox. To reproduce, just search for a track. It works the first time, but what seems to happen is that, as I scroll the tracks, it then attempts to reload the beatport library and when that happens, it will crash. I tried restarting, rebooting, logging out and back into Beatport. Makes the feature pretty much unusable, as I cant risk a complete crash during a mix.

Update - I have tested some more and can reproduce this reliably. It's actually when you try to cancel the library load that it crashes. To reproduce it, use the search function under beatport library. I searched for "Plump DJs".. It will load the first time. Then scroll down. The software will then try to reload the beatport library (it seems to load 100 tracks at a time). If you wait for it to load them (which takes longer than the first 100 for some reason), then it seems to recover. However if you cancel the load, then try to click in the software, you get the spinning wheel of doom and then a crash. This is Macos. The good news is there is a workaround, which is to not try and cancel the library load! Just have to wait for it to do its thing. 

As an aside, the search is pretty terrible and seems very "fuzzy". Is this a feature that you control or is it limited by Beatport's API and search?

Colin Redbond Répondu

Commentaire officiel


Try logging out of your Beatport account from within rekordbox, reboot your computer, then login again. If you still encounter and error, please file an inquiry ticket here and attach a copy of the Beatport log, found at:

Windows - C:\Users\username\AppData\Roaming\Pioneer\rekordbox\Beatport.log
macOS - /Users/username/Library/Logs/Pioneer/rekordbox/Beatport.log

...and our support team will gather some additional information to assist you in resolving this issue.

Actions pour les commentaires Permalien

Cette publication n’accepte pas de commentaire.

2 commentaires


i have the same. but with one mackbook late 2011 15'' I7 8Gb and 10.13.6 and latest security patch from last week. It crashes the same way. i tried 6.0.1, 6.0.0 and now 6.0.1 beta. and if you wait and be relaxed with search it is ok. but it crashed several times last weekend and would not dare to use it in public. 

The other mackbook pro is 2012 with 16Gb 6.0.1 and 10.15.6 beta and no problems



AlexanderDS 0 votes
Actions pour les commentaires Permalien