Have a feature request or suggestion? Post your idea here!

Publication

2 abonnés S’abonner
0
Avatar

SX2 Error with Serato and Rekordbox

Hi,

For an unknown reason my DDJ SX2 has stopped connecting correctly to my Mac.
When Rekordbox or Serato is open, the apps think they are on External Input mode. The waveforms are also greyed out or darkened.

I also can't get sound out of the headphone jack in Serato. When I switch the outputs, it work but then the master doesn't.

Many thanks

 

Mark Pieman Répondu

Commentaire officiel

Avatar

Switch your channel input selectors over to PC.

Pulse
Actions pour les commentaires Permalien

Cette publication n’accepte pas de commentaire.

9 commentaires

0
Avatar

Thanks for your quick response. I should've mentioned I tried all the obvious things, and the switch is already set to PC mode.

And any help about sound not coming out of one of the outputs?? 

 

Mark Pieman 0 votes
Actions pour les commentaires Permalien
0
Avatar

And does it still say "External Input"? Because that's what is shown when the input selector is set to LINE or PHONO.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

As mentioned in my previous post, it is set to PC mode.

Mark Pieman 0 votes
Actions pour les commentaires Permalien
0
Avatar

I'm a bit disappointed here. I have a serious issue with one of your products and have had hardly any help or follow up. Luckily, I'm fortunate enough to have back up options but if this was someone trying to make a living and was their only option, this would be awful for them.

I still need help fixing the problem, please.

Mark Pieman 0 votes
Actions pour les commentaires Permalien
0
Avatar

Here's a question -- does it work as expected with Serato?

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

As mentioned in my original post, no, it does not work properly with serato or rekordbox. It seems to think it's in some type of DVS mode or something. All the controls work but no sound.

And again, just to stop confusion, the controller is set to PC mode on all channels.

Mark Pieman 0 votes
Actions pour les commentaires Permalien