Have a feature request or suggestion? Post your idea here!

Post

9 follower Segui
0
Avatar

DJM-T1 / Traktor 2 Audio Input Issue

Mac OS X 10.7 Lion

DJM-T1 Setting Utility v1.00

Traktor Pro 2 v2.03

In the audio input & output prefs in Traktor there's a massive spike appearing every 5 secs or so (see attached). It shows no input except the spike, but you can hear the audio coming through the mixer as normal. It does add the spike to the recording channels 5/6 too.

The DJM-T1 Setting utility looks fine except the "About" page which says "There is a problem with the driver configurations. Please reinstall the drivers". I've reinstalled 3 times & used the uninstall utility, but this prevails.

None of these problems when running Traktor S4 or Denon DN X-600, so wonder if this is a "Lion" v "Setting Utility" issue.

Cheers

Keith

Keith Varney

Il post è chiuso ai commenti.

66 commenti

0
Avatar

Hi Keith,

I too am running Lion and having issues with my DJM-T1 drivers. I am seeing the same error over and over again when I click on the Setting Utility, even after FIVE re-installs. I actually can't even get sound to play out through Traktor. I don't know what to do now. Hoping Pioneer has a speedy resolution to our problems or I am about to return this overpriced mixer. :-/

 

Regards,

Brandon

Brandon 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Brandon, i've emailed product improvement at Pioneer as there doesn't seem to be a support email address. I suspect we need an updated driver for lion. Yes it is overpriced, but i guess, like me, you wanted an all in one solution. Let's see what they come back with.
Keith

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Spot on Keith, really hoping they can resolve this as migrating back (ie: reformat) or other workarounds (GUID external boot disk) are not what I would like to have to implement in order to use a brand new mixer. Hope they can update the drivers quickly so we can get back to playing asap!

 

Happy Mixing,

Brandon

Brandon 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Brandon, looks like the DJM-900 is suffering from Lion issues too, so I'm sure we'll see an update in the not too distant.....I hope...scared to gig this T1 just now...

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

I'm not too sure if the issue is hardware or software related, however, Pioneer has not guaranteed Lion compatibility at this time and anyone considering upgrading is advised to wait for Pioneer to test compatibility or release updated drivers.  Others may upgrade but it's at your own risk.  You may also seek support with NI.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Hopefully it will just be a T1 driver fix as the Lion / Traktor2 combo works fine with NI S4 & Denon DN X600. But we'll see what happens.

Cheers

Keith

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Well, downgraded to snow leopard, clean install & the problems persists. Still spiking on the inputs & won't allow you to record your Also forgot to mention T1 randomises the effects selected every time you start traktor. If you start traktor with the T1 off, all is good. So, not a lion issue or snow leopard. Seems to be the way the T1 & traktor speak to each other....you live and learn ;)

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Ok, sussed out why the effects change. When you start Traktor, the T1 changes the effect selected to whatever the knob position is. I just disabled this in the midi mapping and all is good.

Still think it's crap that you can't record your set internally...

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

hello, when will the driver DJM T1 lion osx, 10.6.8 or

fabienc73 0 voti
Azioni per commenti Permalink
0
Avatar

bonjour, quand sortira le pilote DJM T1 pour lion osx, ou 10.6.8

fabienc73 0 voti
Azioni per commenti Permalink
0
Avatar

hello, when will the driver DJM T1 lion osx, 10.6.8 or

fabienc73 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Fabien, there is  just the DJM-T1 Setting Utility v1.01 which hasn't made any difference to the issues I'm having. Also firmware updated to v2.00, no change to the problems either. Have reinstalled snow leopard, then Lion. Still no change.

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

I have the same problems on my mac.  When you record, those spikes are static.  I couldn't figure out how to get rid of static.  I looked in the forums at tractor and nothing.  I am not sure if it's software or mixer.  

 

As for the utility, I'd hope the driver program will be fixed for us MAC users, since Macs are the standard when using DJ Tools.

Half 0 voti
Azioni per commenti Permalink
0
Avatar

@Keith > You should still be able to record your set internally.  Have you configured it to do so?

Anyone else with the spike error - what OS are you using (10.6.8 / 10.7.x / other) and are you using the most recent firmware (2.0) and drivers (1.0.1 for Mac)?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Pulse, I've set it up through the wizard as internal & external. unfortunately, the same "cannot start recording" appears in both situations. Not sure if anyone else is getting this? (Occurs in snow Leopard & Lion).

Keith

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Pulse, wee update. The internal recording wasn't working because the recorded file directory needed reset, so my apologies on that one. Think we just need to address the spiking in the i/o meters now in the audio preferences pane.

Cheers

Keith

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Ok, so now we're recording, the spikes are now audible as distortion on the recording. settings as attached. Internal record will only allow channel A through, not the mix output.

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Hi,

I'm also having the same issue with the spikes in my external recording.

I'm using Leopard Mac OS X Version 10.6.8 and my firmware is updated to version 2.0.

When tried recording internally the next song that I have in Cue also records while the volume is down.

I also tried recording through Ableton and Audacity, still the spike remains.

Need to record badly, please help....

Denis Z. 0 voti
Azioni per commenti Permalink
0
Avatar

I think there's a new driver scheduled for the end of this month? Also Traktor 2.1.2 due this month too I think. Hopefully one of these will allow us to record internally with no audio spikes...

I've tried it on both firmwares, both OS X Snow Leopard & Lion. Might be something between Traktor & the T1 not communicating properly.

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

10.6.8 fw2.0 and I get spikes recording into live. Have changed buffer size and it doesn't change. this doesn't seem to be a traktor problem, it's a problem with the driver I believe. using latest Mac Driver 1.0.1

Andrew 0 voti
Azioni per commenti Permalink
0
Avatar

Just reinstalled drivers twice and same problem after restarts. I'm gonna have to return this if I can't record!

 

Andrew 0 voti
Azioni per commenti Permalink
0
Avatar

I record my audio via the analogue outs into a desk then into Propellerhead Record. Can't you use something like that in the meantime? There's a new driver scheduled to come out soon.

Keith Varney 0 voti
Azioni per commenti Permalink
0
Avatar

Yes, there is a new driver estimated to be released at the end of November. The issue is most likely with Mac OS X 10.6.8 as there is also an issue when using the DJM-900 built in sound card with Mac OS X 10.6.8 and Traktor. There could also be an issue with Traktor, but I hope things are completely fixed after the updates. The engineers are working hard on the new drivers and had to contact Apple about the issue because it is not only Pioneer that was effected by the OS X 10.6.8 update. However, OS X 10.6.7 still works for DJM-900 users, can anyone check with their T1 if they have the same result on OS X 10.6.7?

Thanks,

Foster

Foster 0 voti
Azioni per commenti Permalink
0
Avatar

It is indeed a Hardware issue... I just spent 1.5 hrs trying to figure out if I was doing anything wrong while trying to record... lol...

Even made the latency 50ms and nothing worked! Set the headroom to all possible Db settings and nothing...

Oh well... at least I know I have to wait for a new firmware and that I am not alone in this... 

Marco Peral 0 voti
Azioni per commenti Permalink
0
Avatar

For anyone still riding this, the problem has to do with the changes made by Apple to the CoreAudio system in 10.6.8 / 10.7.x.  Pioneer is aware of the problem and is working with Apple to resolve it as soon as possible.  Pioneer isn't the only manufacturer to have this problem.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

So it's almost the end of November and I still can't record without disgusting static and generally low quality audio being output by Traktor. I am using 'first gen vinyl' on a set of 1200's with the DJM-T1 connected to a 2.3 GHz Intel Core i7 17" MBP running Traktor Scratch (Standalone Version) Pro 2 v 2.1.1.11533. I've downgraded back to Snow Leopard (10.6.8) and yet the problem persists. Anyone out there able to successfully record a mix without horrible audio quality?

Thanks in advance for any help!

Brandon 0 voti
Azioni per commenti Permalink
0
Avatar

10.6.8 and 10.7.x both have the same problem.  I'm told that the drivers should be out this week!

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Thanks for the heads up Pulse! That's great news!  Where should we be checking for these drivers? Through NI's 'Service Center'? Or Pioneer's page?

Brandon 0 voti
Azioni per commenti Permalink