Have a feature request or suggestion? Post your idea here!

Post

1 follower Segui
1
Avatar

[CLOSED] After adding a lots of HotQue, RB getting slow/lag

My Collection only 350 mp3s and 6 playlist. Running intel imac on snow leopard. Using latest 1.5.1 version of RB

After adding a lots of HotQue and Memory que on each songs, Almost 80% of my music. Now RB start getting slow. Lagging .. Its getting annoying, everytime i wanna jump on each playlist, theres a delay like 3-5 seconds.. and sometimes spacebar (play) not working after all the lagging moment..  Is it normal ?

I try to clean un-install. install again and re-load the datafile.edb, but still not help at all. :(

Henrico Timbara Putra

Il post è chiuso ai commenti.

15 commenti

0
Avatar

How much RAM do you have on your iMac?

Rekordbox uses your RAM and when you open over 300 tracks, load the waveforms, make changes, add new Hot Cues and Memory Points, it can really take up your RAM quick.

You can view how much memory you use by going to Finder > Applications > Utilities > open Activity Monitor and select "System Memory" near the bottom options. This will help you keep an eye on your memory usage, and when you notice it starts to fill up, it would probably be a good idea to stop there, shut down Rekordbox, and free up some of your RAM. It would also be a good idea to look into a RAM cleaning utility that can free up memory without actually shutting down the software. You will get the best results if you shutdown the application and do the clean, but it's not completely necessary unless it fills up and things start to lag and slow down.

This happens with all applications out there, but Rekordbox has to use a lot of data when loading and saving waveforms, Hot Cues and Memory Points.

I hope this helps, but let me know if you're still having troubles. :) 

Foster 0 voti
Azioni per commenti Permalink
0
Avatar

thank for the tips .. I have 4gig of ram.. is it not enough ?.. from the Activity Monitor, i have free 1,7gb.. this is without RecordBox running.. Will try later with memory cleaning application, do you have any suggest for the apps?  :)

Henrico Timbara Putra 0 voti
Azioni per commenti Permalink
0
Avatar

4GB of RAM is decent to have, but only having 1.7GB free isn't much at all! Rekordbox could use majority of that up within 50 tracks possibly, if you're adding enough Hot Cues and running other apps at the same time.

I would recommend looking around as I know there are a couple. I use iFreeMem myself, as it keeps an update in my top right corner, and I can easily access it and clear up the RAM. When clearing the RAM, it's usually best to quit majority of the apps running at the time if possible, and try to leave your computer alone while it does the cycle.

Well... I shouldn't say 1.7GB isn't much at all. It's not horrible, but it could be better. I just normally clear my 4GB before starting up a whole new project and like to have around 3GB free on my notebook. It's just the more you have free, the more work you can do before it starts to slow down.

Foster 0 voti
Azioni per commenti Permalink
0
Avatar

i already free up some memory like u said..  i got 3,7 free memory.. but still, i experience the lag/delay slowing moment while switching playlist, next or previous track, or play n pause a song..

i assume this is the disadvantage of recordbox, while using almost all hotque/memoryque in every song :(

Henrico Timbara Putra 0 voti
Azioni per commenti Permalink
0
Avatar

I'm unsure why it would still be having lag.

What type and model of computer do you have, and could you please add some of it's specs?

Also, what filetype are the tracks in that you have loaded into Rekordbox?

I'm not entirely sure, but there may be something wrong with the database. I would say at least it's not crashing, but lag is no fun either. lol

Foster 0 voti
Azioni per commenti Permalink
0
Avatar

@Henrico > Yeah, I'm with Foster on this too - I can see its an Intel iMac but more about the specs please.

Did you install any other software at a similar time / update an anti-virus etc?

Gavin 0 voti
Azioni per commenti Permalink
0
Avatar

yess u got my point foster, its not crashing, but lag is super not fun haha.. its ruin my mood while arranging playlist ..

Okay here's my specs. 24" iMac runing Mac os X ver 10.6.8, procesor 2.66ghz, intel core 2 duo, ram 4gb ddr3, hdd 600gb and 200gb free space. i dont have anti virus.. already free up some memory to 3,7gb free like foster said, but still with the same issue.

I always use MP3 format.. 320kbps as usual.

i dont have any big major problem like crashing, everything is running fine for DJing, still can use Usb stick as usual.. it just the LAG issue ruin the fun moment while i arrange playlist, set hotque, transfer to USB and everything.. no fast response like the very first time.. theres a lag like 3 or 5 second everytime, event selecting next track or play n pause :(

i experience this lagging issue since i put a lot of hotques on every songs.. i hope the next updates will fix it :)

Henrico Timbara Putra 0 voti
Azioni per commenti Permalink
0
Avatar

also, i already close all application.. only RB running..

i'm afraid its database issue.. but its pain in the ass if i have to put another hotques on 500 songs again. i dont want to re do all over again.. its my worse nightmare hahaha :(

Henrico Timbara Putra 0 voti
Azioni per commenti Permalink
0
Avatar

@Henrico > I'm going to open a ticket for this issue. Should be back to you shortly.

Gavin 0 voti
Azioni per commenti Permalink
0
Avatar

i think i found my problem.. yess a lot of HOTQUE/QUE POINT issue on the playlist

after installing the latest version.. when its open straight to the main database, everythings are fine.. no lag issue.. then i click my Playlist with lots of QUE, the LAG moment is coming..

So its like the FIRST playlist contains 500 songs with mostly only 10 hot que on 10 songs.. no problem at all, everything its normally fast..

then i switch to the SECOND playlist which is contains only 30 songs and 28 hot que on 28 songs, the damn LAG is coming.. but if i switch back to the FIRST/non-hotque playlist everything back to normal-fast again...

so i think i will remove some of unnecessary hotque in the playlist to avoid the LAG issue ... thanks everyone who respond this issue :)

Henrico Timbara Putra 0 voti
Azioni per commenti Permalink
0
Avatar

@Henrico > I'm waiting to hear back from the assigned engineer on this. I'll pass along the updated information.

Gavin 0 voti
Azioni per commenti Permalink
0
Avatar

@Henrico > I'm after emailing you, requesting some information for the engineers. I'd very much appreciate your assistance.

Gavin 0 voti
Azioni per commenti Permalink
0
Avatar

@gavin > thank you, i already replied with data file attachment.. please note, i already remove like 50% hotques/quepoints .. theres still lag issue, but less than like the first time i post this issue

Henrico Timbara Putra 0 voti
Azioni per commenti Permalink
0
Avatar

@Henrico > Are you still experiencing the same problem when using the latest version of rekordbox?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

This topic has been closed due to inactivity. Should you require future assistance with this issue, please create a new topic describing the problem and provide the URL of this topic as reference.

Pulse 0 voti
Azioni per commenti Permalink