Have a feature request or suggestion? Post your idea here!

Post

4 follower Segui
1
Avatar

[SOLVED] CDJ-350s with Traktor Pro2

Hi, 

I want to buy Traktor Pro, but I first wanted to make sure that I can get my CDJs working with it, so downloaded the Demo version (latest, v2.5.0). Well, after installing everything and updating the firmware on CDJs I could get the audio out from the mixer correctly but the CDJs don't do (control) anything.

Is this due to the "Demo version" of Traktor? If that should work fine (which I think should, since it says nowhere that I cannot use controllers with Demo version), what can it be? any ideas?

(P.S. I followed all instructions on Pioneer website. i.e. firmware update, import .tsi file to Traktor, install aggregate file, etc.)

Thanks!

Berkay

Il post è chiuso ai commenti.

30 commenti

0
Avatar

Hey Berkay,

It's a compatibility issue from what I understand. CDJ-400 are the lowest form of Pioneer CDJs that is recognized by the Traktor program. Use this PDF file, follow the instructions, and you'll be able to make your CDJ-350 compatible with Traktor. I myself run with Traktor Pro 2.0 and I followed the PDF file and am now using software and hardware smoothly.

http://pioneer.jp/support/download/dj-e/pdf/CDJ-350-TRAKTOR-PRO_En.pdf

Willem Osuch 0 voti
Azioni per commenti Permalink
0
Avatar

@ Trancer of 1988

Thanks a lot for your comment. Actually I have followed this document exactly step-by-step. Maybe I was not clear enough, sorry for that. But, after following all the points mentioned on Pioneer website in the above linked pdf manual, I could only hear the sound and manipulate the output through the mixer. But the CDJs do not control the Decks on Traktor PRO (I have also selected Channels on the Decks as mentioned in the PDF). As most confirms that it works, I will just purchase the activation code today, maybe than it will work - maybe it is a limitation of the Demo version. 

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

So, I have deleted the Demo version and all setting files. Then I have purchased the full version and installed it. Followed all the steps again on the CDJ-350 - Traktor Pro Connection guide to no avail :(

What am I doing wrong, or what might be the problem? Anybody with the same experience? Any guesses? 

BTW, I have a MacBook Pro, OS X 10.7.4. Using the latest version of Traktor Pro 2. As explained above, performed all actions on the connection guide in Pioneer support site. I can get the audio output from the mixer, but cannot control the decks from my CDJs.

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

Hey Berkay,

Very odd indeed. I am no professional, I just got the same issue resolved not a week ago or so, but allow me to tell you my setup and what I did, and maybe that'll lead to the resolution of your issue. 

Again, got two CDJ-350, one DJM-250 and I use an Alienware M17x with Windows 7 Ultimate and Traktor Pro 2.0. 

Deck A CDJ-350 is on MIDI Channel 1 and Deck B is on MIDI Channel 2.

In Preferences, under Controller Manager, my device is set at 'Generic MIDI' and both my In- and Out-Ports are set at 'All Ports', with the Device Target being 'Focus'. I imported the Pioneer CDJ-350 TSI file (I found out that you can use the one that the aformentioned manuel provides a link to, the MIDI Mapping TSI File or another TSI file that I received from one of the Pioneer Admins here on the forum. In short, as long as you've deleted any old configurations and have a TSI file for the 350, then it should work), and by importing the TSI file, my Controller Manager changed to the settings that enables compatibility. 

As for Output Routing in the Preferences, I have it set on EXTERNAL and I have:

Output Deck A: 1. CDJ-350 1

                            2. CDJ-350 1

Output Deck B: 1. CDJ-350 2

                            2. CDJ-350 2

 

And that's all I got for you as that is all that I've really messed around with concretely for it to work. I hope this helped and I hope you get your issue resolved.

 

Trancer

 

Willem Osuch 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Trancer,

Thanks a lot for taking the time to help. 

" Deck A CDJ-350 is on MIDI Channel 1 and Deck B is on MIDI Channel 2."  --> OK

In Preferences, under Controller Manager, my device is set at 'Generic MIDI' and both my In- and Out-Ports are set at 'All Ports', with the Device Target being 'Focus'. --> OK. I have re-deleted everything and redownloaded the .tsi file and re-imported. No help..

My output routing is a bit different, but the one you mention also works (audio comes from the right channel), but does not change the fact the CDJ's don't control it. 

Here is my config (also attached files)

Output Deck A: 1. CDJ-350 Out 0

                            2. CDJ-350 Out 1

Output Deck B: 1. CDJ-350 Out 2

                            2. CDJ-350 Out 3

There is one possibility left behind: USB 3.0 (since both USB ports of my MAC are USB 3.0)

Latest firmware of CDJ-350 should be USB 3 capable (and I have the latest firmware 1.06 on both decks); but somehow does not work...

I don't even know what to do now? Call pioneer or NI?

Anyways, thanks a lot for your help!

Berkay

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

Berkay,

I'll get screenshots of my setup tomorrow and maybe you can compare and draw conclusions from that. 

Your output routing is different than mine, but if you say that has no bearing, then okay. 

The USB theory might be correct, I think my Alienware runs on USB 2.0 ports.  

Yeah, do try to get in touch with NI. I do think that eventually some of the Pioneer DJs and crew will see this thread and join the convo and offer a lot more help than I can. I have been coming here for aid, so it'll probably come your way.

Willem Osuch 0 voti
Azioni per commenti Permalink
0
Avatar

@Berkay > I don't have mine setup in front of me, but I don't think the decks typically come up as "Generic MIDI"... Can you go to Applications > Utilities > Audio MIDI Setup and see if the two CDJ350's are showing up in there?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

@Pulse,

Checked that: both Pioneer CDJs and the aggregate Pioneer CDJ (with two sub devices) show up in the  MIDI setup. 

Actually, according to the "Setup guide" it should show up as "Generic MIDI"  - added that screenshot from the guide as well. It actually says:

" Check the selection under [Device Setup]. Confirm that [Generic MIDI] is selected for [Device]. " 

But anyways thanks for the thought..

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

I have similar issues, NOTHING works - i have tried everything detailed in the instructions on the PDFs but i cannot get traktor to work with my cdj/djm 350 set up. Extreeeeeemly annoyed because this is why I bought the gear in the first place but after a year of struggling, no joy at all. Got the new firmware, got up-to-date midi map, got midi channels set up, got identical usb leads, etc....

What is it that I am NOT doing ???? What is there to do that is NOT in the pdfs - i note a mention of aggregating sound cards - WTF - and configuring in/out routings - WTF again -o lve usb facility though, and being able to record the mix is ideal. But getting bored with trying to "plug and play" the things when there are obviously issues that are not being identified or addressed properly.

Would it be possible to have a FULL and COMPLETE list of settings published/posted ????

 

 

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Excellent, looking forward to that. Must repeat, cracking piece of kit, even with the Traktor issues !!!!

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Excellent, looking forward to that. Must repeat, cracking piece of kit, even with the Traktor issues !!!!

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

The above workaround are only for the people running a MBP with OS X Lion of course... And not guaranteed to solve all NI compatibility problems...

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

Hey Berkay,

Here's a pic of my Controller Manager window in Traktor. I just took it after opening Traktor and this is what it's on and both my CDJs are working and so forth. Don't know if it'll help.

Willem Osuch 0 voti
Azioni per commenti Permalink
0
Avatar

Is this a silly question - why dont the 350s just plug in and work like the others in the range ???? Simple enough to arrange I would have thought....

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Right, nicked a pc from work, got everything working apart form the jog wheel wont respond - what next dudes......

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Arrggh. This is so annoying :(

So I have basically installed this previous version of USB drivers that bring back to USB 2.0 performance.. And there it goes, the CDJs actually controls the Decks.. However this time the midi/audio output is not recognized so audio only internal..

So apparently this is something to do with USB 2.0 - USB 3.0 incompatibility issues. The question is who will make the software upgrade?

I think it should be Pioneer, since Traktor works fine. It is the OS X that does not recognize either the audio or the control signals..

Pioneer pls help.  

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

Btw, before anyone asks, yes I controlled the aggregate driver etc. Did basically all the steps again just to be sure... It just tells connect your devices (while the CDJs are already connected and are in COMPUTER / CONNECT mode) when I try to use CDJ aggregator..

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

Finally getting somewhere... OK for the ones who will read this forum later, this is how I solved my problem:

As I thought I had USB compatibility problems, and I am very impatient to wait for NI or Pioneer (or Apple for that matter) to take some action; went to shop and bought a Belkin powered USB hub. And that's it, connected the CDJs to Traktor via the USB hub and both the audio works and CDJs control the decks on Traktor..

There are some issues (like the jog wheels are not working great, one works better in Vinyl mode and the other is in normal mode; so it does not even make sense.. Apparently the software team needs to do some work on these drivers.

Thanks for everyone for the suggestions..

 

 

Berkay 0 voti
Azioni per commenti Permalink
0
Avatar

Hazaaa! Good job mate, glad everything is working and that you'll begin playing with you mixer and Traktor.

Willem Osuch 0 voti
Azioni per commenti Permalink
0
Avatar

Can someone post info on aggregating the sound cards please !!!

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Great thanks. Also, been told to right click the program icon and check "run in XP compatibility mode" if having issues on W7 set up, so will try that...watch this space!!!!

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Er, my Taktor was set to run in XP mode duh...so have set it to run in Win7 now...!

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

No, still cant get amy joy from my W7 set up. plus couldnt find any info from the aggregator link...cheesed off with it now, but gonna keep plugging away amd watching the forums, you never know, NI and Pioneer might actually come up with a proper solution, but thanks for all your efforts guys !!!!

steven j shorter 0 voti
Azioni per commenti Permalink
0
Avatar

Greeting from me guys...i just bought a brand new macbook pro 13 retina with ssd disk and the latest mac osx 10.8.3....i had no problems using my cdjs 350 with my old macbook...with this one i just aggregate the cdjs importing the mapping file...and no control at all...i can get sound comin out only when i hit play on traktor with my mouse...when i touch the cdjs no control...i used cdj aggregator though but no point...so whats the prob???i am tired of all this incompatibility with those silly cdjs...i think sometime it would be just plug and play and people must not have an mba on mapping and pluggin these cdjs...any help accepted!!!

Themis Polyzoidis 0 voti
Azioni per commenti Permalink
0
Avatar

@Themis > Did you run the Setup Wizard / choose the correct settings when prompted on the CDJ?

Gavin 0 voti
Azioni per commenti Permalink