Have a feature request or suggestion? Post your idea here!

Post

8 follower Segui
0
Avatar

[SOLVED] Problem setting up Traktor Pro 2.5 with CDJ / DJM 350 via Macbook Pro OS x 10.7.4

I've just recently upgraded my laptop from a PC to a Macbook Pro and I'm setting up Traktor Pro 2.5 to work with my Pioneer CDJ / DJM 350s, but I'm having trouble getting the CDJs to work as controllers.

 

I've followed a bunch of steps from various websites and tutorials and now I'm at a point where I can get tracks to play through the mixer, but the CDJ's have no control of anything. So far this is what I have done:

 

  • Installed Traktor Pro onto my Mac

  • Upgraded to Pro 2, then again to Pro 2.5

  • Downloaded "PIONEER_CDJ-350.tsi" file

  • In Traktor, went to Preferences > Controller Manager and under Device Setup, I deleted the original device and imported the new .tsi file

  • Under Preferences, clicked on Audio Setup and changed Audio Device from Built-In to Pioneer CDJ (CoreAudio)

  • Also clicked on Output Routing, changed the mixing mode to external and changed Output Decks to -

 

Output Deck A

L - 1: Pioneer CDJ Out 0

R - 2: Pioneer CDJ Out 1

Output Deck B

L - 3: Pioneer CDJ Out 2

R - 4: Pioneer CDJ Out 3

 

Hopefully I'm only a few clicks away from getting it all up and running properly and it would be awesome if anyone could help me out.

 

Cheers,

James.

James Allan

Il post è chiuso ai commenti.

29 commenti

0
Avatar

Hi James,

 

I am having exactly the same issue.. except I'm using a CDJ 850.

I had no issues using this on my last MBPro running Traktor 2.5, however now I have just bought new Retina MB Pro, I can get the 850 to output sound as a sound card but the CDJ's have no control at all.. 

I've spent hours on it!!! 

Hopefully someone can provide a solution? Have also emailed N.I. and am awaiting a response.. 

Ben Kahan 0 voti
Azioni per commenti Permalink
0
Avatar

It would be nice if the Traktor setup wizard included 350s and 850s in the controller selection part. I know they should work, but I'm a bit 'lost at sea' with the preference settings.

 

Almost thinking about upgrading to the Traktor S4 to make life a bit easier, but it's a last resort at the moment.

James Allan 0 voti
Azioni per commenti Permalink
0
Avatar

Yep.. Created an aggregate device in audio/midi and also used the Pioneer utility.. The aggregate device is set up correctly and I can get output through each CDJ.. Just can't get the Cdj's to control the track decks in Traktor. The CTRL light doesn't even blink. Very frustrating! Am using the same settings that are working on my older MBPro. Any suggestions? Maybe a new TSI midi mapping file is required?

Ben Kahan 0 voti
Azioni per commenti Permalink
0
Avatar

Hey Ben, I am having the exact same problem. I think there is a problem with the new MBP. I have tried different software (cross dj, serato) and cant seem to get it to work. I think it may be the operating system? Its very frustrating and I would love to know what to do to fix it.

Brett Lee Aitken 0 voti
Azioni per commenti Permalink
0
Avatar

Hi Brett, I found a work around for the time being.. I got the CDJ850 to respond to traktor by plugging the USB cable from the CDJ into an unpowered USB hub, then into the MBP. It must be an issue with USB 3.0 I'm assuming and by plugging in the USB hub must be converting down to USB 2.0? I don't know, at least its working for the time being. Just make sure that you have the CDJ plugged into the hub BEFORE setting up the aggregate device. 

Hopefully this will be fixed soon!? And somewhere down the track, maybe, just maybe, there will be HID support for the CDJ850, rather than having to stuff around dealing with frustrating issues instead of mixing! Someday... 

Ben Kahan 0 voti
Azioni per commenti Permalink
0
Avatar

Thanks for the response Ben, I will need to go and buy a Usb hub. Must I buy a usb 2.0 hub? how dos the usb change from 3.0 - 2.0 but just using a hub? I will give this a try tomorrow, hopefully it will work. 

Brett Lee Aitken 0 voti
Azioni per commenti Permalink
0
Avatar

HI Ben, Just got my USB hub and all is working perfect. I am using crossdj (mixvibes) software, I personally think it is better than traktor. Its very user friendly and I am going to link my ipad together with it. anyways thanks for the help, you saved me alot more frustration.

Brett Lee Aitken 0 voti
Azioni per commenti Permalink
0
Avatar

No problem.. I'm not sure on the technical reasons for why this works, but my assumption is that the MBPro can't output USB 3 to all ports in a hub if it's unpowered and splits the power over the 4 ports with UBB 2 instead. I think I'll download crossdj and have a play with it, thanks for the tip :) less time on frustrating setup and more time on mixing sounds like a win!

Ben Kahan 0 voti
Azioni per commenti Permalink
0
Avatar

I made the usb 3.0 ports on my new mac backwards compatible by following this guys advice on a native instruments forum. Hope this can save you guys the drama of using an external usb hub.

 

 

|
feedserotonin wrote:

It's not too difficult really, once you get the file. I was lucky enough that my brother's MacBook Pro was running 10.7.3 so I got the file. 

Here's a link to the Kext File

Here's where to download the Kext Wizard

1) Launch Kext Wizard

2) Select the Installation tab

3) Click Browse and select the Kext file from the folder it was downloaded to

4) Check mark "backup kexts that will be replaced" This option will place a folder on your desktop of the USB 3.0 compatible Kext

5) Be sure the System/Library/Extentions folder is selected as the destination

6) Click Install and wait for the message saying it has completed

7) reboot your system

I hope this helps and let me know if you have questions.
|

 

 

Once I followed these instructions, all was sweet :D

James Allan 0 voti
Azioni per commenti Permalink
0
Avatar

Hey guys,

Do all of you who experience this problem have the latest release of MBP's? I have the late 2011 modell and I'm supposed to DJ tomorrow at a club with CDJ-850's and now I got stressed out it might not work! Do you know if it will work?

 

Cheer/Gustav

Gustav Eén 0 voti
Azioni per commenti Permalink
0
Avatar

@All > Remember, if you do decide to go altering any settings for ports on your computer, from the advice of others, it is at your own risk.

@Gustav > I can't see why you would have any issues.

Gavin 0 voti
Azioni per commenti Permalink
0
Avatar

Hi, i do what our friend James Allan says and the CDJ's are controlling the traktor, but de CDJ Agregattor does not found my CDJ's anymore. So i can't set the audio system. So my problem change the side. What do ido?

Fabio Campos 0 voti
Azioni per commenti Permalink
0
Avatar

after i tried the thing with the kext file which was unsuccesfull, i simply plugged a usb hub between cdjs and macbook pro ( mid 12) and everything worked... My maybook couldnt recognize them after i switch the kext file so i had to switch back to the original one

dreamseller 0 voti
Azioni per commenti Permalink
0
Avatar

@Fabio > Please start again. Connect your CDJs, turn them on. Download and run the CDJ Aggregator. Then when both CDJs are recognised as soundcard devices launch Traktor and run the setup wizard.

Please remember kernel extensions (.kext files) aren't protected by Mac OSX's memory extension so making any changes is at your own risk and not supported by Pioneer.

Gavin 0 voti
Azioni per commenti Permalink
0
Avatar

someone should mentione that even if you do get your problem solved, as far as I know, the CDJ-350 does not currently work properly with Traktor in midi/HID mode. If you want to use the jogwheels you will be very displeased. I have no idea why this isn't being addressed and fixed.

lewes 0 voti
Azioni per commenti Permalink
0
Avatar

Hello! Already tried all ways to make the CDJ350 control the TRAKTOR but had no success. I think the problem may actually be in USB 3.0. Is there a special cable for use with CDJs?

Serginho Greca 0 voti
Azioni per commenti Permalink
0
Avatar

just a small tip, have you tried to plug a usb hub inbetween? should work

dreamseller 0 voti
Azioni per commenti Permalink
0
Avatar

USB3 on the new MacBooks is a bit problematic -- there are several forum discussions around the net outlining the issues users are having with various hardware and software configurations for both DJing and non-DJing use.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Dreamseller, I'll try using the HUB. After I put the test result here in the forum. Tnks!

Serginho Greca 0 voti
Azioni per commenti Permalink
0
Avatar

looking forward to hear any news if it worked ;)

dreamseller 0 voti
Azioni per commenti Permalink
0
Avatar

Dreamseller Tnks!

I'm very happy it worked! I appreciate the commitment of all those who have sought a solution to the problem and helped many others who were also anxious not to be alright. Total disappointment with Pioneer and Native Instruments who did not give much attention to this case. I'll be releasing a solution on other forums I attended, where people should still be eager to find the solution. Tnks!

Serginho Greca 0 voti
Azioni per commenti Permalink
0
Avatar

thats nice to hear, i just realized that you have to setup a new aggregate device after you plugged in the usb hub although you have created one before.Kind of strange but as long as it works, im happy that i could help you :)

dreamseller 0 voti
Azioni per commenti Permalink
0
Avatar

Hey guys, first of all thank you Dreamseller, but i have another problem, i put the Hub and it works very well, but some "genius" here make the update of the CDJ 350 firmware from the 1.06 to 1.08, now one of the decks play 1 second of music and the sound stops, but the track keeps running. Any tips?

Thanks.

Fabio Campos 0 voti
Azioni per commenti Permalink
0
Avatar

no clue sorry, i just wanted to inform you that i use fw 1.08 aswell without any problems. maybe there are some problems with some of your cables? thats the only thing i can imagine if the track is still running but there is no output

 

greets!

dreamseller 0 voti
Azioni per commenti Permalink
0
Avatar

Hey Dreamseller, thank you again, you were right, the usb hub wasn't working, o bought another one and now all is working fine.

Greets.

Fabio Campos 0 voti
Azioni per commenti Permalink