Have a feature request or suggestion? Post your idea here!

Post

9 follower Segui
0
Avatar

Traktor 2.7x with DDJ-SX2 - Headphones/Master Output are the same

I just picked up the DDJ-SX2. It's a great controller, but I've been a Traktor user for nearly a decade and prefer much of the workflow over Serato. I was happy to see how easy it was to get the SX2 up and running in Traktor from the provided .tsi file, however I've got one MAJOR issue right now.

I can't cue up tracks in the headphones. No matter what settings I have in Traktor, I can't get it to route anything but the Master Output to my headphone jack. I've tried the 3/4 + 1/2 setup and flipped it around. Neither seem to work. Any advice?

This is on a MacBook Pro i7 (2011) with all current updates on Firmware (1.05), OS X Yosemite, and Traktor 2.7.

Jason Spencer

Accedi per aggiungere un commento.

30 commenti

0
Avatar

Within the Traktor settings, do you have it set to internal or external mixer mode and what is the audio configuration for the outputs?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

I'm assuming that if you followed the guide, you have things set properly, but just to be sure, can you post a screenshot of the Traktor audio and mixer settings pages?

And just checking that your channel input selector switches on the SX2 are set to PC?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Switches are set to PC. I should point out that I don't even need to push the CUE button on the channels. The Headphone Out is operating 100% like a Booth/Master output.

 

Jason Spencer 0 voti
Azioni per commenti Permalink
0
Avatar

You do know when using the software in INTERNAL mode that you have NO control over the individual channels? It is strictly a master-send scenario.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

The more I deal with this, the more that it seems I'm going to be returning the unit. That's not going to be fun...

I didn't realize I'd essentially lose the ability to operate as a standalone mixer, too. I noticed today that all MIDI commands are sent regardless of where the input switch is set (PC/Phono/Line). There are many great things about Traktor that I love over Serato, their difficulty in using controllers not made by NI isn't one of them.

Thanks for trying. Despite some great response and functionality, the inability to cue in the headphones is an absolute deal break though.

Jason Spencer 0 voti
Azioni per commenti Permalink
0
Avatar

@Jason > Why not set the software to EXTERNAL mixer mode and configure your audio outputs for individual sends to each channel?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Umm..  Because I followed the instructions from the .tsi file setup provided by Pioneer -- Which clearly states Internal mode.

Jason Spencer 0 voti
Azioni per commenti Permalink
0
Avatar

And unless I did it wrong, the soundcard on the SX2 doesn't work that way. It's only Master and Headphone outputs. I tried it, and I still only got 2x2 out.

Jason Spencer 0 voti
Azioni per commenti Permalink
0
Avatar

Hrm, entirely possible, my apologies, I haven't had much hands-on time with it, I'd assumed it was configured for 4x stereo out use as well.

Either way... you CAN still configure the hardware (if it wasn't already done) so that each of the headphone cue buttons enables / disables the headphone cueing for those individual channels within Traktor, the same way it would work as if the hardware were configured as a standard mixer.

You'd need to check that the headphone mix is turned all the way left (so you get none of the master cued in the headphones) and then select a channel cue. You should see the channel headphone icon illuminate within Traktor.

If you need further help configuring it, please let me know.

Pulse 0 voti
Azioni per commenti Permalink
1
Avatar

I had exactly the same problem with my new DDJ-SX2. It took my hours to solve it :-( but I've found :-) I use internal mixing mode.

The problem is the mixing level of the rotary between cue and master. On the DDJ-SX1 it is done by hardware in the controller and not controlled by midi commands to Traktor to the similar software rotary. I guess the same software button in Traktor is turned to right, that is the master. See screenshot. The solution is to turn the software button on the screen in Traktor to left, to Cue and never change it again!!!

If you want to use that function, use only the rotary on your DDJ-SX2, not in Traktor

Yves V 1 voto
Azioni per commenti Permalink
0
Avatar

I'm having this problem as well. Is the SX2 unable to do hardware headphone outs?

Martín Wilson 0 voti
Azioni per commenti Permalink
1
Avatar

I ultimately gave up and went back to my NI controllers. The output routing is NOT friendly to the SX2 at all/ :-/

Jason Spencer 1 voto
Azioni per commenti Permalink
0
Avatar

I finally got it sorted, but yeah, the routing is wacko. It's a bummer too, because otherwise the SX2 is boss.

Martín Wilson 0 voti
Azioni per commenti Permalink
2
Avatar

There is another way to configure the hardware, but it's not something we encourage the public to do. If you're interested, just say so and I'll pull your email from the system and send you a message with instructions. You'll have to agree to a stipulation of non-disclosure and no guarantee of performance.

Pulse 2 voti
Azioni per commenti Permalink
0
Avatar

I am absolutely on board with trying this other config out. Please send me the agreement and instructions / whatnot.

Thanks,
Martin

Martín Wilson 0 voti
Azioni per commenti Permalink
0
Avatar

Hello I have the same issues ... I would appreciate if you would'nt mind to tell me how to fix it please it is very disturbing!!!
Thank you very much

Stephen Haag 0 voti
Azioni per commenti Permalink
0
Avatar

See my answer at the top. I've posted with a screenshot. Unfortunetaly with the new layout of this forum all pictures are deleted and we are not able to post a picture anymore.

Select the layout "Extended" on the right top of Traktor. So you see at the right between Deck B and the browser 3 rotary buttons: MIX, VOL and Aux. Set the MIX rotary complete to the left. Not necessary, but the best is to turn the VOL complete to the right. Once set don't change these rotary on the software but only on your DDJ-SX(2).

Yves V 0 voti
Azioni per commenti Permalink
0
Avatar

Heelo thank you for the fast answer! So i tried that option and it didn't work I still have that problem. Do you think it has anything to do with the fact that I'm using Windows? I have all drivers Installed and there were no problmes with serato.

Stephen Haag 0 voti
Azioni per commenti Permalink
0
Avatar

I guess you have an other problem. How is your Audio setup, output routing en Mixing mode? Did you try "Master Cue" button and "headphone Mix" rotary on your DDJ-SX(2)

Yves V 0 voti
Azioni per commenti Permalink
0
Avatar

My output routing in traktor is

Internal

Output Monitor
L 3: speaker out 2
R 4: speaker out 3

Output Master
L 1: speaker out 0
R 2: speaker out 1

And yes I tryed almost everything... but it still doesen't work
in my Audio setup I have the option of: PioneerDDJ SX2 (WASAPI (shared mode))
and when I change it to ASIO for all I have only 2 ouput channels as selection

Stephen Haag 0 voti
Azioni per commenti Permalink
0
Avatar

Internal mixing mode is ok. But you need the "Audio Device" "Pioneer DDJ_SX2 ASIO", and not wasapi and not asio4all.
With the Asio driver "Pioneer DDJ_SX2 ASIO" you are able to config the output routing:
Output monitor L 3: DDJ-SX2 PHONES L
Output monitor R 4: DDJ-SX2 PHONES R
Output master L 1: DDJ-SX2 MASTER L
Output master R 2: DDJ-SX2 MASTER R

BUT Traktor is by default a 64-bit application and Pioneer still don't have 64 bit Asio drivers for their devices. So, you don't see the Pioneer asio driver you need in the list with audio devices.
After half a year we are still waiting for 64 bit asio drivers from Pioneer. See https://forums.pioneerdj.com/hc/communities/public/questions/203083209-DDJ-SZ-64-bit-ASIO-drivers-

Luckily Native Instruments, or Traktor offers a workaround.
You can apply https://www.native-instruments.com/en/support/knowledge-base/show/3886/my-audio-interface-is-not-recognized-after-installing-traktor-2.8.0-windows/
Meanwhile it's an old description for version 2.8.0 but you can still use it for later versions. At the momen I use 2.10.0

Yves V 0 voti
Azioni per commenti Permalink
0
Avatar

You are my Hero :D :D thank you very very much it works now!!!!! Really I appreciate your Help a lot, and for your fast answers! :)

The Best wishes from me :)

Stephen Haag 0 voti
Azioni per commenti Permalink
0
Avatar

Hello pulse. I've got the same issue routing audio in traktor on external way to my ddj sx2.

Could you send me please the

instructions per email too?

Greetz

Patrick Spallek 0 voti
Azioni per commenti Permalink
0
Avatar

@Patrick > Is there a specific reason you need to configure it different from the default master / phono outputs?

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

I Want to use the hardware eq and filter, not traktors software intern eq. I've tried it with my saffire 6USB interface to rout two decks external into the ddj sx2 but the software's internal eq still moves, when I turn the eq on the ddj sx2 

Patrick Spallek 0 voti
Azioni per commenti Permalink
0
Avatar

@Patrick, if you want to avoid that Traktor changes the EQ, then you have to modifiy your DDJ-SX(2) midi mapping in Traktor.

That nice flexibility to be able to change the midi mapping is exactly why I like and prefer Traktor above Serato.

@Pulse: does Rekordbox also have the flexibility to modify or improve the midi mapping of each controller?

Yves V 0 voti
Azioni per commenti Permalink
0
Avatar

@Patrick > As @Yves V states, that's a matter of changing the configuration within Traktor to alter the MIDI mapping. Unfortunately the SX2 doesn't offer an individual-channel output or mixed-mode operation to allow the audio to pass to channels without there being MIDI control simultaneously.

@Yves > Yes; connect a controller then click the MIDI button. Edit to your heart's content.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

@ Pulse: could you please send me the email instructions you mentioned above.

Also, does rekordbox already features MIDI mapping with shift layers and variables, like traktor?
Thanks

pedro estrela 0 voti
Azioni per commenti Permalink
0
Avatar

@pulse, I know this is an old thread but could you still tell me how to do this 

 

There is another way to configure the hardware, but it's not something we encourage the public to do. If you're interested, just say so and I'll pull your email from the system and send you a message with instructions. You'll have to agree to a stipulation of non-disclosure and no guarantee of performance.

 

Many thanks, 

Aristotle 0 voti
Azioni per commenti Permalink