Have a feature request or suggestion? Post your idea here!


2 follower Segui

Serato DJ Pioneer DDJ-SX Unique Problem

So I have not seen an issue like mine after 2 weeks of scouring through the internet for a solution. I will attach an etre check log at the bottom of this post My problem is best described in a youtube video which can be seen with this link: https://www.youtube.com/watch?v=r5d9Vjw3oTg

My ddj sx doesnt function, at all with serato dj, I have a macbook pro (late 2011) and it is running Yosemite 10.10.3. I have had the controller for about a year and everything has been fine until now. At first I thought the issue was with the controller as i recently moved country (from England to Sweden), i thought maybe it got damaged in transit or the power cable voltage is wrong or it is not grounded correctly. All that was dispelled when i took it to a repair shop and it worked fine on their windows computer. So it was something to do with my mac.

At this point i had yosemite 10.10.2 so i thought an update to this as well as the recently updated serato dj 1.7.4. No avail, the problem was still there. Going more specifically into the problem, serato dj will work fine offline but as soon as i connect the ddj sx it recognises it, sometimes it works for 2 or 3 seconds then it stops. The platters dont work, play or cue doesnt work, the track select knob and load deck functions work but not much else. 

For the past month or so I have been using a usb soundcard (ua-25ex) so i thought maybe that was causing some sort of conflict so i deleted the driver for it, resterted the mac, still same problem. My ddj sx is running the latest firmware (1.7) but again i dont think that is the issue. I am hoping the etre check log can shed some light on what the problem is. 

As a side note i run logic pro 9 and x on this mac too and before this problem i could connect the ddj sx and logic would recognise it and ask if i wanted to use the device and i could press pads and it would work as a midi controller. However since this problem has risen, logic pro no longer likes my ddj sx and is throwing out error code 25974, and then causes the internal input and output (speakers and mic) to not function either. This leads me to believe the problem is an issue with the core audio but i know nothing about that and I am lost with a very big gig coming soon so im hoping to get this sorted asap.

Any replies are greatly appreciated!

EtreCheck version: 2.1.8 (121)

Report generated 16 April 2015 15:23:34 CEST

*Download EtreCheck from * http://etresoft.com/etrecheck


Click the [Click for support] links for help with non-Apple products.

Click the [Click for details] links for more information about that line.


Hardware Information: ℹ️

    MacBook Pro (13-inch, Late 2011) (Technical Specifications)

    MacBook Pro - model: MacBookPro8,1

    1 2.4 GHz Intel Core i5 CPU: 2-core

    4 GB RAM Upgradeable

        BANK 0/DIMM0

            2 GB DDR3 1333 MHz ok

        BANK 1/DIMM0

            2 GB DDR3 1333 MHz ok

    Bluetooth: Old - Handoff/Airdrop2 not supported

    Wireless:  en1: 802.11 a/b/g/n

    Battery Health: Check Battery - Cycle count 513


Video Information: ℹ️

    Intel HD Graphics 3000

        Color LCD 1280 x 800


System Software: ℹ️

    OS X 10.10.3 (14D131) - Time since boot: 1:21:23


Disk Information: ℹ️

    APPLE HDD HTS545050A7E362 disk0 : (500.11 GB)

        EFI (disk0s1) <not mounted> : 210 MB 

        Recovery HD (disk0s3) <not mounted>  [Recovery]: 650 MB 

        Macintosh HD (disk1) / : 498.88 GB (49.97 GB free)

            Core Storage: disk0s2 499.25 GB Online




USB Information: ℹ️

    Apple Computer, Inc. IR Receiver 

    Apple Inc. FaceTime HD Camera (Built-in) 

    Pioneer PIONEER DDJ-SX 

    Apple Inc. BRCM2070 Hub 

        Apple Inc. Bluetooth USB Host Controller 

    Apple Inc. Apple Internal Keyboard / Trackpad 


Thunderbolt Information: ℹ️

    Apple Inc. thunderbolt_bus


Gatekeeper: ℹ️



Kernel Extensions: ℹ️


    [not loaded]    com.akai.mpc.usb (3.0.2 - SDK 10.7) [Click for support]



    [not loaded]    au.com.glassechidna.heimdall_usb_shield (6.0) [Click for support]

    [not loaded]    com.devguru.driver.SamsungComposite (1.4.28 - SDK 10.6) [Click for support]

    [not loaded]    com.paceap.kext.pacesupport.master (5.9.1 - SDK 10.6) [Click for support]



    [not loaded]    com.paceap.kext.pacesupport.leopard (5.9.1 - SDK 10.4) [Click for support]

    [not loaded]    com.paceap.kext.pacesupport.panther (5.9.1 - SDK 10.-1) [Click for support]

    [loaded]    com.paceap.kext.pacesupport.snowleopard (5.9.1 - SDK 10.6) [Click for support]

    [not loaded]    com.paceap.kext.pacesupport.tiger (5.9.1 - SDK 10.4) [Click for support]



    [not loaded]    com.devguru.driver.SamsungACMControl (1.4.28 - SDK 10.6) [Click for support]

    [not loaded]    com.devguru.driver.SamsungACMData (1.4.28 - SDK 10.6) [Click for support]

    [not loaded]    com.devguru.driver.SamsungMTP (1.4.28 - SDK 10.5) [Click for support]

    [not loaded]    com.devguru.driver.SamsungSerial (1.4.28 - SDK 10.6) [Click for support]


Launch Agents: ℹ️

    [loaded]    com.oracle.java.Java-Updater.plist [Click for support]

    [failed]    com.pianomarvel.plugin.plist [Click for support] [Click for details]

    [loaded]    org.macosforge.xquartz.startx.plist [Click for support]


Launch Daemons: ℹ️

    [loaded]    com.microsoft.office.licensing.helper.plist [Click for support]

    [loaded]    com.oracle.java.Helper-Tool.plist [Click for support]

    [running]    com.paceap.eden.licensed.plist [Click for support]

    [loaded]    org.macosforge.xquartz.privileged_startx.plist [Click for support]

    [loaded]    PACESupport.plist [Click for support]


User Launch Agents: ℹ️

    [loaded]    com.google.keystone.agent.plist [Click for support]

    [running]    com.spotify.webhelper.plist [Click for support]


User Login Items: ℹ️

    iTunesHelper    Application  (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

    Google Chrome    Application Hidden (/Applications/Google Chrome.app)

    Dropbox    Application  (/Applications/Dropbox.app)

    Android File Transfer Agent    Application  (/Users/[redacted]/Library/Application Support/Google/Android File Transfer/Android File Transfer Agent.app)

    KiesAgent    UNKNOWN Hidden (missing value)

    Spotify    Application Hidden (/Applications/Spotify.app)

    fuspredownloader    Application Hidden (/Users/[redacted]/Library/Application Support/.FUS/fuspredownloader.app)


Internet Plug-ins: ℹ️

    SharePointBrowserPlugin: Version: 14.0.0 [Click for support]

    QuickTime Plugin: Version: 7.7.3

    JavaAppletPlugin: Version: Java 8 Update 31 Check version

    Default Browser: Version: 600 - SDK 10.10


Audio Plug-ins: ℹ️

    AKAI_MPC: Version: Unknown - SDK 10.7 [Click for support]


3rd Party Preference Panes: ℹ️

    Java  [Click for support]


Time Machine: ℹ️

    Skip System Files: NO

    Auto backup: YES

    Volumes being backed up:

        Macintosh HD: Disk size: 498.88 GB Disk used: 448.91 GB


        Seagate Backup Plus Drive [Local] 

        Total size: 999.86 GB 

        Total number of backups: 15 

        Oldest backup: 2014-12-12 21:39:40 +0000 

        Last backup: 2015-04-16 10:29:55 +0000 

        Size of backup disk: Too small

            Backup size 999.86 GB < (Disk used 448.91 GB X 3)


Top Processes by CPU: ℹ️

         5%    Logic Pro

         4%    WindowServer

         2%    Google Chrome

         0%    fontd

         0%    AppleSpell


Top Processes by Memory: ℹ️

    198 MB    Google Chrome

    107 MB    Logic Pro

    94 MB    Finder

    73 MB    Dropbox

    64 MB    mds_stores


Virtual Memory Information: ℹ️

    313 MB    Free RAM

    1.75 GB    Active RAM

    1.07 GB    Inactive RAM

    1.09 GB    Wired RAM

    2.71 GB    Page-ins

    22 MB    Page-outs


Diagnostics Information: ℹ️

    Apr 16, 2015, 03:01:15 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150115_[redacted].crash

    Apr 16, 2015, 03:01:05 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150105_[redacted].crash

    Apr 16, 2015, 03:00:54 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150054_[redacted].crash

    Apr 16, 2015, 03:00:44 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150044_[redacted].crash

    Apr 16, 2015, 03:00:33 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150033_[redacted].crash

    Apr 16, 2015, 03:00:23 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150023_[redacted].crash

    Apr 16, 2015, 03:00:12 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150012_[redacted].crash

    Apr 16, 2015, 03:00:02 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-150002_[redacted].crash

    Apr 16, 2015, 02:59:51 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145951_[redacted].crash

    Apr 16, 2015, 02:59:41 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145941_[redacted].crash

    Apr 16, 2015, 02:59:30 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145930_[redacted].crash

    Apr 16, 2015, 02:59:20 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145920_[redacted].crash

    Apr 16, 2015, 02:59:10 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145910_[redacted].crash

    Apr 16, 2015, 02:58:59 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145859_[redacted].crash

    Apr 16, 2015, 02:58:48 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145848_[redacted].crash

    Apr 16, 2015, 02:58:38 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145838_[redacted].crash

    Apr 16, 2015, 02:58:27 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145827_[redacted].crash

    Apr 16, 2015, 02:58:16 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145816_[redacted].crash

    Apr 16, 2015, 02:58:06 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145806_[redacted].crash

    Apr 16, 2015, 02:57:55 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-16-145755_[redacted].crash

    Apr 16, 2015, 01:57:25 PM    Self test - passed

    Apr 16, 2015, 01:35:42 AM    /Library/Logs/DiagnosticReports/Serato DJ_2015-04-16-013542_[redacted].hang

    Apr 16, 2015, 01:26:01 AM    /Users/[redacted]/Library/Logs/DiagnosticReports/Logic Pro_2015-04-16-012601_[redacted].crash

    Apr 15, 2015, 08:24:02 PM    /Library/Logs/DiagnosticReports/Serato DJ_2015-04-15-202402_[redacted].hang

    Apr 15, 2015, 06:44:17 PM    /Library/Logs/DiagnosticReports/Serato DJ_2015-04-15-184417_[redacted].hang

    Apr 15, 2015, 05:01:25 PM    /Library/Logs/DiagnosticReports/Serato DJ_2015-04-15-170125_[redacted].hang

    Apr 15, 2015, 04:59:27 PM    /Library/Logs/DiagnosticReports/discoveryd_2015-04-15-165927_[redacted].crash

    Apr 14, 2015, 07:51:58 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-195158_[redacted].crash

    Apr 14, 2015, 07:51:45 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-195145_[redacted].crash

    Apr 14, 2015, 07:51:20 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-195120_[redacted].crash

    Apr 14, 2015, 07:37:00 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-193700_[redacted].crash

    Apr 14, 2015, 07:21:27 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-192127_[redacted].crash

    Apr 14, 2015, 07:20:52 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-192052_[redacted].crash

    Apr 14, 2015, 07:20:08 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-192008_[redacted].crash

    Apr 14, 2015, 07:12:11 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-191211_[redacted].crash

    Apr 14, 2015, 07:06:55 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-190655_[redacted].crash

    Apr 14, 2015, 07:03:20 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-190320_[redacted].crash

    Apr 14, 2015, 07:02:38 PM    /Library/Logs/DiagnosticReports/coreaudiod_2015-04-14-190238_[redacted].crash

    Apr 13, 2015, 04:59:58 PM    /Library/Logs/DiagnosticReports/deleted_2015-04-13-165958_[redacted].crash

    Apr 16, 2015, 01:29:05 AM    /Library/Logs/DiagnosticReports/Spotify_2015-04-16-012905_[redacted].hang


Ivan Lupaka

Accedi per aggiungere un commento.

1 commento



I've recently purchased a pioneer ddj-sx.

Yesterday when i switched on the controller it was sending a high frequency sound continuously at the speakers and the headphones.

I'm sure it's not the speakers/cables/plugs/headphones fault.

When I switch the controller off and on again everything is fine but if i shut it down and switch it on again the problem comes back.

Could you please help me understand what the problem might be?

Thanks in advance.

Loukas Papachristoforou 0 voti
Azioni per commenti Permalink