Have a feature request or suggestion? Post your idea here!


3 follower Segui

CDJ2000 NXS Doesn't appear in RekordBox

Hi everybody,

I can't have my CDJ2000 NXS appear in Rekordbox. I spent a lot of time on Internet, forums, etc ... but I tried everything and I don't understand ...

The "LINK" button appear on the bottom of RB but when I click on it, I just have "LINK1" with the bpm, master button (screenshot), but not my CDJs.

But ! My DJM900 NXS appear !!

There is no network problem, I can make a ping to CDJs, it's ok.

Also, I allowed the 4 .exe in the windows firewall (edb_streamd.exe/psvnfsd.exe/psvlinksysmgr.exe/rekordbox.exe) in private and public network and each time in TCP and UDP.

I tried to desactivate Windows firewall and Avira antivirus firewall.

I have check properties of my network card and don't share the connection.

I also try to desactivate wifi card.

On the side of CDJs, when I check in "Link info", the display message is "NO CONNECTION".

I try to connect my RB on 2 other CDJs and it's the same problem. So the pb seems to come from a parameter of my computer..

- PC with Windows 10 (64bits).

- Version of Rekordbox: 4.1.1.


=> Is anyone have an idea ? What can I try ?


Thanks in advance for your help !! :)

Clement Con risposta

Commento ufficiale


Hello @Pulse,

I finally found what the problem was ..

My laptop is an ASUS ROG and the utility "Asus Live Update" offered me an update. I did it and my antivirus alerted me that a trojan was in the Asus update:

So I deleted it and it works !!! I have my CDJ's in Rekordbox !!!!! :D

I suppose that an ASUS utility was using the same ports as those for Pro DJ Link ?!

In all cases, thank you for your help ! :)

Azioni per commenti Permalink

Accedi per aggiungere un commento.

15 commenti


Hi @Pulse,

Thanks for your return :)


Bellow my answer:


- Are you using the latest version? => Yes,version 4.1.1 (I had the same problem before this version).

- If you're using rekordbox with CDJs, do they have the latest firmware? => Yes I have update the firmware of CDJs: v1.30 (09/Mar/2016) and of my DJM900NXS: v1.31 (27/Feb/2014).

I use Windows 10 64bits.

- You get an error message "MFReadWrite.dll not found" (Windows only) => No

- rekordbox won't start / crashes on startup / rekordbox has troubles starting / => No, Rekordbox runs properly.

- rekordbox rejects your serial number => No, all is right.

- You get an error message "Check Internet Connection" and can't log-in to authorize rekordbox => No.

- rekordbox doesn't show the waveform properly or crashes after a few minutes => No, all is right.

- The fonts all look weird within rekordbox (Windows 10) => No

- You can't get your players to link => Yes this is my pb.

My players are well connected to a gigabit switch and my computer too. There is no router with firewall between, just a swith (model: TP-LINK TL-SG1008D)

I already allowed this .exe in windows firewall (See the screenshot):

C:\program files\yourusername\rekordbox version-number\edb_streamd.exe - TCP
C:\program files\yourusername\rekordbox version-number\psvnfsd.exe - UDP
C:\program files\yourusername\rekordbox version-number\psvlinksysmgr.exe - TCP
C:\program files\yourusername\rekordbox version-number\rekordbox.exe - TCP

Each exe is allowed in Private and Public network and in TCP and UDP (4 rules for each .exe).

- Try disabling your firewall => I have try this and disable also my antivirus in the same time but my CDJ's doen't appear in Rekordbox.

Also I am already in Privat network.

The Connection with my CDJ's are OK. I can make a ping from my PC to CDJ's:

Microsoft Windows [version 10.0.10586]
(c) 2015 Microsoft Corporation. Tous droits réservés.


Envoi d’une requête 'Ping' avec 32 octets de données :
Réponse de : octets=32 temps<1ms TTL=64
Réponse de : octets=32 temps=1 ms TTL=64
Réponse de : octets=32 temps=2 ms TTL=64
Réponse de : octets=32 temps=1 ms TTL=64

Statistiques Ping pour
Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
Minimum = 0ms, Maximum = 2ms, Moyenne = 1ms

I do the same test with a continues ping ("ping -t") and disconect the ethernet port of CDJ and the ping stop. So it's the good IP address, and the link work properly.

- The firewall isn't the problem but it still won't link properly => In the properties of my ethernet card, in the tab "Share", the box is not checked. I don't share the connection. Also I disable my wireless card during all tests. 

Alternatively, you may be running security software which may also act as a firewall; be sure to check any 3rd party security software and configure or disable it.=> The only security software use is "Avira Antivir". I have do tests with windows firewall disable and avira firewall and real time protection disable, wifi card disable too

- Try connecting a player DIRECTLY to your computer with the network cable. => I try to connect directly PC <> CDJ and my computer can't obtain an IP address. So the logo "LINK" in RekordBox doesn't appear.

Have you scanned your computer for malware and/or viruses? I recommend maintaining your computer's security with Malwarebytes Anti-Malware, ADWCleaner, HitMan Pro and CCleaner. => I use all this software, and I have already scan my PC etc. No malware, trojan, virus, etc.. +CCleaner for clean all residual files.. All is right. My system is not infected.

- You can see the players in the link section, but dragging and dropping tracks there doesn't load them to the players => I just see the LINK button. When I click on it, I have just this, but not CDJ's (so the connection is OK):

- If you've followed the instructions above re: the firewall, try power-cycling your players and press the blue LINK button to see if rekordbox shows in the list of link items, or on a CDJ-2000nexus or CDJ-900nexus model, press the rekordbox button on the player, then rotate the selector knob and accept the connection onscreen. => Nothing ..

- Your wireless internet doesn't work while linked to the players / mixer =>No, it's Ok.

- Your music isn't importing properly =>No, it's Ok.

- Your M4A file won't import/play =>No, it's Ok.

- Your playlists (M3U, PLS) aren't importing properly =>No, it's Ok.

- Importing and analyzing is slow, is it multi-core optimized? => No, it's Ok.

- Your album artwork is missing => No, it's Ok.

- Your music is missing => No, it's Ok.

- You made changes to the song's tags in some other software but rekordbox isn't reflecting those changes => No, it's Ok.

- You set a cue point for a song, but the next time you load the song, the cue point you had set is missing => No, it's Ok.

- You imported your music but nothing is showing up when you connect your hard drive to the CDJ => No, it's Ok.

- You can't export your music => No, it's Ok.

- You've exported files to your device but the CDJ won't recognize it =>No, it's Ok.

- You've exported files to your device but the XRJ-R1 won't recognize it =>No, it's Ok.

Your rekordbox exported library isn't working with your player =>No, it's Ok.

- You want to export to a CD/DVD instead of a USB device =>No, it's Ok.

- You can't find the BPM or KEY or ... field =>No, it's Ok.

- You got an 830x error message =>No, it's Ok.

- You click the play button but no audio is heard, the audio doesn't play back =>No, it's Ok.

Information Required for Support

So you've read this post and couldn't find your problem? Did you read it all and try everything that was relevant to your problem? If not, please go back up and read! Done it? Good, then it's time for you to post a new question. Copy these lines and paste them into a new question in the user forums and we'll try to do our best to help you out. 

For any lines which have multiple answers pre-filled, please erase those which do not apply.


0) Have you read the "READ ME FIRST" thread in its entirety AND TRIED THE SOLUTIONS THERE before posting: Yes.

1) Operating System: Windows 10.

2) OS Type: 64bit

3) rekordbox version: 4.4.1

4) Using LINK: Yes

4b) LINK Connection method: DJM2000nexus + DJM900nexus with ethernet cable Cat5e connected to gigabit switch:

4c) Using with CDJs: Yes, version 1.30 for my two CDJ2000nxs and v1.31 for my djm900nxs.

5) Source and Export Hard drive / Flash drive / SD card file system: For the moment, I use a SD card in FAT32 because I can't use directly Rekordbox from CDJ's by the network.
5b) Connection type: Ethernet network
5c) Does the device have multiple partitions: On my SD card, No.
5e) With what utility did you format the device: Windows directly.

7) Have you scanned your files for errors: Yes, no problem.

7b) Have you scanned your drive for errors: Yes, the same, all is right.

8) Is rekordbox crashing at all: No, RB runs well.
8b) If not crashing, are there any error messages: No error message.

9) Are you able to repeat / reproduce the problem: Yes.
9a) If yes, can you do it consistently: Yes.

10) Does the problem occur with one specific song: No.

11) Any other notes regarding your setup only: I have a "normal" setup. 2 cdj2000nxs with last firmware, 1 switch gigabit and 1 computer windows 64bits.

12) Provide as much detail of the issue here:

As you can read in my first post, I have the "LINK" button in RB when I switch on CDJ's, so connection is good but when I click on it, I can't see players. From players it's the same, I don't see playlists, etc.. in the CDJ's rekordbox button.

I don't know what can I test because I already try without firewall, antivirus, wifi card, etc.. as explain before.

Tell me if you need more details.

Thank you again for your help !!

Clement 0 voti
Azioni per commenti Permalink

@Clement > lol - wow, you didn't really need to answer all of those questions, just the bit from the bottom, but thanks! :)

When you connect your equipment, it seems your DJM is appearing but not the CDJs. If you connect the DJM directly to the computer, does it appear under the link?

Could you try connecting a CDJ to that same ethernet cable (if the DJM connects)?

Do you happen to have any USB cables connected from the CDJs / DJM at the same time? If so, they need to be unplugged.

Pulse 0 voti
Azioni per commenti Permalink

@Pulse, yes, I started to answer and in the end I saw that we just should respond as last questions ... So I left everything, but at least you see that I really tried before posting loll


So, when I connect directly my DJM to my computer with just an Ethernet cable, I can see it in Rekordbox it's good.

Now when I connect directly CDJs to my computer with the same cable, the LINK button appear, but when I click on it, I just have this: (No CDJ logo)

And no, I don't use any USB cable from my CDJ's. Just power, RCA and Ethernet.

PS: To remember, I have the same issue with a XDJ1000 set.

Clement 0 voti
Azioni per commenti Permalink

@Clement > It seems to me there's a problem with your networking. I'm willing to bet that connecting these same players to another computer would work without issue.

Have you checked that your Windows file sharing is disabled, as well as the Home Group sharing, and that there are no other NFS server services running? (This starts to get a bit more technical but is necessary to ensure there's nothing interfering with the ProDJ Link communication).

Does that computer have any other network adapters configured (bridges, PTP, ethernet, or wireless)?

Have you ensured that the power-saving features are disabled for that network device?

Pulse 0 voti
Azioni per commenti Permalink

@Pulse > Yes you're right, before using my laptop, I had an other computer with Windows 7 and it was working normaly without issue.

Your answer give me an idea. I have just try to reboot in Safe mode with network support and ... it works !! :D

So yes I have a service or protocol "blocking" communication with CDJs..

I have check file sharing is already disable (home group too). I don't have any NFS server installed or running in "services.msc". The only other network adapter is the wifi card and it's disable.

Maybe do you know exactly what protocols, ports, etc.. are used for the ProDJ Link ? I mean, other than IP layer ?

Clement 0 voti
Azioni per commenti Permalink

I'd recommend going through your computer's services and background applications to find anything that may be disrupting or blocking the traffic. You should try disabling them one at a time. If you need further help with this, just let me know.

Pulse 0 voti
Azioni per commenti Permalink

Yeah, we always suggest running virus/malware scans, chances are that Dropper was redirecting network traffic.

I'm glad you were able to get it resolved!

Pulse 0 voti
Azioni per commenti Permalink

Hey guys, i recently bought the new rekordbox 6 subscription and I can't connect my cdj2000 nexus 2 to rekordbox even though the firmware is 1.85. I tried everything and I can't get rekordbox 6 to connect. The cdjs sync easily with Traktor an Serato. I'm connected via USB and it shows that the computer is connected but I'm not able to connect. Please help, there must be a lot of people experiencing the same thing on mac mojave.

Dersu Rhodes 0 voti
Azioni per commenti Permalink

@Dersu > Please open the rekordbox MyPage and click the Plan tab to see if it has been activated. You may need to close / re-open rekordbox for this to update.

If you just recently installed the drivers, you may not have installed them properly - follow the guide here and uninstall / reboot / reinstall / allow through security.

Pulse 0 voti
Azioni per commenti Permalink

Hey there! thank you so much! I can't believe I spent so much time trying to sync and that was the issue! It's solved and I was able to connect simply by turning on my plan with the button!!! 

I have one last question in regards to syncing Rekordbox with the CDJ2000 Nexus2's. I noticed that when I'm tethered via USB to my laptop, I noticed that on my NXS2 touchscreens that I can't use the sort button and can't sort the tracks on the screen by BPM or Key so I'm having to constantly go back to my laptop screen to see those sort fields.

Is there something that I'm missing in the settings or are we simply not able to see the sorting of the tracks on the screen when tethered to Rekordbox on my MacBook?

Thank you so much!



Dersu Rhodes 0 voti
Azioni per commenti Permalink

@Dersu > Those functions aren't available when linking in performance mode, only in EXPORT mode. The logic is that rekordbox is running so you can access those functions within the software.

Pulse 0 voti
Azioni per commenti Permalink

Thank you! totally makes sense! We're so close, I was able to connect only one CDJ2000 deck using "export - Link" mode. One deck shows up perfectly, sorting fields and all, however, the other deck won't pull up anything in "rekordbox" mode.

The decks are connected with the ethernet cable together and usbs to a hub coming from the Nexus2's and the DJM900 mixer but when I try to "link" the way I would with USB's, it won't connect either. Any idea or literature on how to get the rekordbox link export mode to show up on both decks and to record?

Thank you Pulse for helping me sort this out, I know this will be helpful for other people as well! I really appreciate your time and quick helpful responses!


Dersu Rhodes 0 voti
Azioni per commenti Permalink