Have a feature request or suggestion? Post your idea here!

Post

4 follower Segui
0
Avatar

Pioneer DJM 750 mk2 Traktor Issue

Does anyone else have this or know how to fix it?

So I just got my 750 mk2 and I did all the usual steps, made sure the firmware was the latest, I upgraded to traktor pro 3, and I downloaded the latest driver. The mixer connects just fine except I have this weird issue on a few of the knobs, some knobs seem to be also mapped in traktor to change the pitch/tempo, the knobs still work, like I have the issue on one of the eq's, it works, but it adjusts the master tempo by a few bpm, which kills mixes. Let me know if you know how to fix this, I'm completely lost. Cheers!

bguzi23 Con risposta

Commento ufficiale

Avatar

I typically don't recommend mapping a DJM to any DJ software unless it's channels you won't be using for any audio (eg. you only ever mix on CH1 and CH2, so you can then map the controls for CH3 and CH4 to other functions), because the controls on the mixer are always audio first. That means even if it were mapped to something in software, the audio passing through would be affected by it regardless.

If you don't want to have those controls mapped, just go into the Traktor MIDI editor and remove those items from the list.

Pulse
Azioni per commenti Permalink

Accedi per aggiungere un commento.

9 commenti

0
Avatar

The controls are not mapped though. Literally the only thing I did when I received the mixer is download the driver, which I left all the settings as they were, the firmware on the mixer was already up to date, and I already own Traktor pro 3. On the controller manager in Traktor it does not show a mapping for the mixer. which is why I am confused. what could it possibly be?

bguzi23 0 voti
Azioni per commenti Permalink
0
Avatar

If the mixer is transmitting the same signal as another device was, it could be entirely unintentional. Just disable the DJM as an input source.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Hi, 

I am having a similar issue connecting the DJM 750 Mk2 and Vestax VCI-100 to Traktor Pro 3. For some reason the channel volume faders are action Midi controls of the VCI.
I have looked everywhere and cant find the option to disable the DJM as an input source.

Any help would be appreciated

Dhar Sonecha 0 voti
Azioni per commenti Permalink
0
Avatar

@Dhar > Check within the Traktor MIDI settings for the DJM, chances are you have entries you can remove.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

The problem is that in the Midi settings there are the mapping for the VCI-100.

For some reason even though the DJM750 isn't mapped and they are 2 separate devices, 3 of the channel faders on the DJM750 action the mappings for the VCI-100.

If cancel them I lose the functions of the VCI-100.

Rather annoyingly it is the jogwheel pitch bend or search function, so it throws the mix out! 

Any help highly appreciated.

Dhar Sonecha 0 voti
Azioni per commenti Permalink
0
Avatar

It could simply be that the DJM is sending signal on the same channel as the VCI-100; you can change the output channel on the DJM in the utility menu (see page 22 of the owner's manual), and make sure Traktor isn't listening on all channels for the VCI-100.

Pulse 0 voti
Azioni per commenti Permalink
0
Avatar

Thanks a lot!

I changed the Midi channel on the DJM750 to Channel 2 and it solved all the conflicts!

Dhar Sonecha 0 voti
Azioni per commenti Permalink