Have a feature request or suggestion? Post your idea here!


2フォロワー フォローする

XDJ-RX3 Firmware Update Error Message

Just tried to update my firmware as prompted (new / fresh out of the box) from version 1.00 to 1.13 and it's giving me a failure message and now I can't use the device... super frustrating.

I'm using a FAT32 formatted USB with only the firmware .UPD file on it. Now I'm seeing warnings from other users experiencing the same issues but with no solid answers. I even tried to update to older firmware versions (1.1 and 1.12) and still got the same failure error. 

Is there a way to factory reset the unit? Now when I turn it on I'm getting a message asking to insert my USB and I can't access anything else.

I got a support reply back from Pioneer telling me to ship the unit to one of their service hubs for repair or back to my authorized dealer. All that for a firmware update?

Brandon Patrick 回答済み



If you're certain the drive is formatted properly (FAT32 with Master Boot Record), and it still doesn't update, yes - send it for service.

コメントアクション Permalink