Have a feature request or suggestion? Post your idea here!

投稿

6フォロワー フォローする
2
Avatar

Rekordbox 1.5.0 crashing

*TL;DR: *Rekordbox 1.4.1 worked, but1.5.0 crashes repeatedly after trying to analyze the same music that analyzed fine in 1.4. It appears that 1.5 is corrupting its database. Please help.

0) Have you read the "READ ME FIRST" thread in its entirety before posting: Yes I did

1) Operating System: Windows 7

2) OS Type: 64bit 

3) Rekordbox version: 1.5.0 and 1.4.1

4) Using LINK: Yes

4a) LINK Connection method: Netgear - GS105 Gigabit Switch

4b) Using with CDJs: 2 CDJ 900's

5) Hard drive / Flash drive / SD card file system: 1TB NTFS

5a) Does the device have multiple partitions: No

5b) If it's a flash drive, is it a U3 device: NA

5c) With what utility did you format the device: Windows

6) Have you scanned your files for errors: Doing that now

7) Have you scanned your drive for errors:Yes

8) Is Rekordbox crashing at all: Yes

8a) If crashing, is it resulting in: error message

8b) If not crashing, are there any error messages: N/A

9) Are you able to repeat / reproduce the problem: Yes

9a) If yes, can you do it consistently: Yes

10) Any other notes regarding your setup only: Lenovo T400 4gb ram

Provide as much detail of the issue here:

I recently re-purposed a laptop to be used purely for dj'ing, and moved my music library onto an external HDD.  I installed a fresh copy of Win 7x64 and procided to install the new version of rekord box.  First I attempted to take my rekordbox library from my desktop (initially by using the export feature) but then by copying over /APPDATA/pioneer etc.  and while that imported all of the songs along with their tags (bpm key etc) i couldnt figure out how to get the wav display to show up.  Finally I gave up and decided to just let my computer analyze the files overnight. This is where my problems started.

When I woke up the next day rekordbox was about 3500ish track's into analyzing and had crashed.  I restarted the application and it crashed within 10 seconds of being launched.  After re-starting the computer and trying this a couple more times I decided to try the backup database file.  This didnt help.  

I un-installed rekordbox, cleared out the APPDATA folder, and re-installed and let it run over night again.  This time it only got to about 900 tracks before it crashed.  Repeating this whole un-install re-install re-analyze feature 2 more times got me to the point where i only had 90 tracks left to analyze.  At that point i had been waiting for about a week to spin some music and got impatient.  I turned on the link feature and spun for about an hour and a half with everything working completely fine.  When clicked the LINK button after i was done playing (to disconnect the link) rekordbox crashed, and afterwards wouldn't launch (doing the same crash as soon as you try to launch it deal).

Ive read through the forums and it sounds like a couple other people are having the same problem, hopefully Pioneer is working on it :)  In the mean time i downloaded mp3val and am scanning all of my tracks right now.  I also spent a couple hours an finally found a copy of Rekordbox 1.4.0 online. so i am going to try to get rid of any bad tracks and re-analyze with 1.4

I have three questions:

  • Does anybody know of a fix for what's going on? / Is it a known problem that's being worked on?
  • I have a working copy of my database and all of the files have the wav display data attached to them, how can i move this to another computer?

Thanks in advance for the help!

(if you need crash logs or want me to run any tests or do anything to help solve this, just let me know)

Mortfrog

ログインしてコメントを残してください。

24件のコメント

0
Avatar

UPDATE: So i decided to try syncing rekordbox's data files over dropbox to see if i could use the full library. I followed all of the instructions and the library appears to have moved over (rekordbox said my licence data was invalid etc) and all of my tracks appear, however the waveform display's still arent there...  If someone could help me figure out how to get thoes displays back that would be amazing.  I believe all of the files requried to display the waveform copied over as the sync was 300ish MB and just over 10,000 files. 

Also, I scanned my library for errors (there were a bunch), fixed them, and am going to try to just re-analyze all of the tracks now.

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

UPDATE 2: So I tried to import 380 of my tracks (that had been scanned and verified as error free) into rekordbox 1.5.0 and it crashed after only analyzing <100 of them.

I'm going to try to start fresh with rekordbox 1.4

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

UPDATE 2: So I tried to import 380 of my tracks (that had been scanned and verified as error free) into rekordbox 1.5.0 and it crashed after only analyzing <100 of them.

I'm going to try to start fresh with rekordbox 1.4

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

I wish you could delete comments or at least edit them lol.  (or maybe i'm just and idiot and couldn't figure out how). Anyways, I ran 1.4 overnight to analyze tracks (i just told it to do my whole library),  When i woke up it had gone through about 4000ish but had crashed some time during the night. When I restarted the program it continued chugging along with no problems, we'll see if it finishes.

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

In your post I nitoced this bit :

5) Hard drive / Flash drive / SD card file system: 1TB NTFS

A device used should be FAT/FAT32 formatted for the CDJ to use it. As source drive on a Windows machine it would be fine.

Lead 0 票
コメントアクション Permalink
0
Avatar

@Lead - I'm only using the drive to store the music on.  It never plugs into the CDJ's it's just for use with rekordbox. If I ever want to plug something into the cdj's I use flash drives and they are formatted FAT32.

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

Ok, I'm really at a loss for what to do, and so tired of dealing with rekordbox. I just want to play music... Rekordbox still isn't working does anyone have a suggestion about what i can do?

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

Well traktor analyzed all of the tracks fine, and works. It would be awesome if there was something i could do to get rekordbox working again :/

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

Have you tried right-click and Run as Administrator?

Pulse 0 票
コメントアクション Permalink
0
Avatar

Yes I have, more than once. Any other suggestions?

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

Sorry to keep bumping this but it's still not working, and its been a week and a half.  Clearly a bunch of other people are having the same problems, Pioneer, whats going on? I just want rekordbox to work...

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

@Mortfrog > can you please download and run the SIW tool (it's a stand-alone diagnostic utility, no installation required).  Run SIW and then go to File > Create Report File > HTML and then EMAIL me the file (don't post it as an attachment here).

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse, Thanks so much! I will do that tonight when I get home.

Mortfrog 0 票
コメントアクション Permalink
0
Avatar

pulse, did you get my email? just seeing if i can do anymore cos i still cant use rekordbox and am getting seriously frustrated now as in essence i cant use £4,500 worth of gear like i want to. Cheers i know you're doing all you can i just wish pioneer could update us on whats going on...

robert moth 0 票
コメントアクション Permalink
0
Avatar

I'm sure all these guys are in A.C. at the DJ Expo so we may not hear from anyone this week

BriChi 0 票
コメントアクション Permalink
0
Avatar

@Robert > Yes, got it, but still waiting on info from engineering and as @BriChi says, Jay and I are in Atlantic City at the DJ Expo and aren't spending as much time here on the forums as usual.  Thanks for your patience.

Pulse 0 票
コメントアクション Permalink
0
Avatar

I had same problem. Seems to be windows 7 issue with rekordbox. Windows 7 32 bit. ibm t400. updated everything what i could from windows 7 side and FW updates on laptop. still crashes on pbm scannings. I reinstalled recordbox in "windows vista sp2" compatibility mode and "run as administrator". seems to be working for now. least with tracklist scanning has not crashed yet.

hope it helps all you.

T M 0 票
コメントアクション Permalink
0
Avatar

does anybody have an answer to this update problem yet? does anyone have a copy of 1.4 cos that seemed to work fine. i have a dell inspiron 1545 if that at all helps? cheers guys, desparate to get this working, its detroying all the hype i had over this software...

robert moth 0 票
コメントアクション Permalink
0
Avatar

@ robert. if you are using windows 7, see my previous post for solution (worked for me)

T M 0 票
コメントアクション Permalink
0
Avatar

If you're not Mortfrog, please start your own thread.  Piggybacking will only confuse this thread and result in less direct support for all involved.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@ Pulse, sorry.. my intention was not "biggybacking".. But i actually do think, my feedback would help also development with this software... As i explained.. Rekordbox 1.5 crashes with my laptop as well, when i try use it in windows 7 as native. When i install it under windows 7 ""windows vista sp2" compatibility" mode, works fine... i mean no crashing.. I also own two CDJ-2000 and this software issue almost ruined my entire "gig"... Usually i dont use any software.. My intention was on one gig, test it... as recorded.. and so on... My final thinking is... On software download section should be "notice" with explaining, this software has issues running under windows 7 OS... Lot more saves times and less confusing.. People here wait for solution and "right" answer way too long.. This my personal option and not as insult... 

 cheers

t.m 

T M 0 票
コメントアクション Permalink
0
Avatar

But those who have the problem are stuck, and even though we are being patient it's still not very comforting to be in this sittuaton after most of us have paid close to £5000 for gear we now can't use until rekordbox is stable again !!!

Darren D 0 票
コメントアクション Permalink