Have a feature request or suggestion? Post your idea here!

投稿

14フォロワー フォローする
0
Avatar

Rekordbox not reading iTunes playlist sub-folders

0) Have you read the "READ ME FIRST" thread in its entirety AND TRIED THE SOLUTIONS THERE before posting: Yes

1) Operating System: OSX 10.8.5

2) OS Type: 64bit

3) rekordbox version: 3.0.3

4) Using LINK: N/A

4a) LINK Connection method: N/A

4b) Using with CDJs: N/A

5) Hard drive / Flash drive / SD card file system: N/A

5a) Does the device have multiple partitions: N/A

5b) If it's a flash drive, is it a U3 device: N/A

5c) With what utility did you format the device: N/A

6) Have you scanned your files for errors: Yes

7) Have you scanned your drive for errors: Yes

8) Is rekordbox crashing at all: No

8a) If crashing, is it resulting in: N/A

8b) If not crashing, are there any error messages: N/A

9) Are you able to repeat / reproduce the problem: Yes

9a) If yes, can you do it consistently: Yes

10) Does the problem occur with one specific song: No

10a) If yes, please post a link to it: N/A

11) Any other notes regarding your setup only: N/A

12) Provide as much detail of the issue here:

I create a multi-level hierarchy of playlists folders within iTunes.  Prior to the iTunes 12 and Rekordbox 3.0.3 upgrades, I was able to view files within these child folders.  I updated both iTunes and Rekordbox at the same time, so this issue is related to one or both updates.

Image of nested layout within iTunes:

http://i.imgur.com/KEg9v3T.jpg

Image of Rekordbox view:

http://i.imgur.com/TOC7q18.jpg

Now, Rekordbox is having a difficult time viewing files within the Playlists folder.  This can be fixed initially by clicking the Refresh icon.  Once that is done, tracks within the main folder will display, but sub-folders still display no contents.  Choosing to Import these playlists results in 0 files imported to my Rekordbox collection.  If I drag these sub-folders into the main playlist area within iTunes, the files are immediately visible within Rekordbox.

Image of iTunes after moving iTunes playlist outside of parent folder:

http://i.imgur.com/huOAIv7.jpg

Image of Rekordbox now showing files:

http://i.imgur.com/0d21ci0.jpg

 

Not game-breaking, but a step backwards.  Thoughts on this issue?  Thanks for any responses.

-J

 

Josh Routin

サインインしてコメントを残してください。

47件のコメント

0
Avatar

I have this very same issue! None of my playlist in iTunes is showing.  This is a huge disappointment for me coming from the flawless iTunes integration of Serato. :(

Jim DA Vo 0 票
コメントアクション Permalink
0
Avatar

I'm having this issue as well. None of the playlists inside of a playlist folder in iTunes are appearing in Rekordbox.

Joe Moore 0 票
コメントアクション Permalink
0
Avatar

What version of rekordbox are you all running? I see @Josh is running 3.0.3 and I would first recommend updating to 3.2.

Also, what version of iTunes? And are @Joe and @Jim running on a Mac as well?

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Pulse: To be fair, this thread started in November 2014.  The issue persists with 3.1.0 as of this weekend.  I did not install the update to 3.2.0 as I had a gig and didn't want any changes I wasn't familiar with.  I will install 3.2.0 tonight and test it out.  My iTunes version is now at current version as of 3/25/2015.

Josh Routin 0 票
コメントアクション Permalink
0
Avatar

@Josh > It's entirely possible your comments came in too close to the release of 3.1 to implement the fix but 3.2 may have addressed it -- and if not, I'd like to report it again to the engineers for investigation. I'll wait to hear back after you've had a chance to update and test.

Pulse 0 票
コメントアクション Permalink
0
Avatar

I am on Rekordbox 3.2.0, Mac OS X Yosemite, iTunes 12.1

Joe Moore 0 票
コメントアクション Permalink
0
Avatar

Confirmed same issue with 3.2.0, itunes 12.1.0.50, osx 10.8.5.

Josh Routin 0 票
コメントアクション Permalink
0
Avatar

Engineers were unable to replicate using their data - could you guys please provide your iTunes XML file which is referenced by the rekordbox settings? Thanks!

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Joe > Could you please post the iTunes Library.itl file from that same folder where you have your XML file?

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Joe > The engineers compared the two files and found that the same playlists and information were present in both locations. Could you please elaborate on what was missing?

@Josh > We're still waiting on receipt of your iTunes XML file, ITL file and rekordbox database if you're still in need of assistance.

Pulse 0 票
コメントアクション Permalink
0
Avatar

I'll upload them today.  Do I need to re-document what is not showing when loading iTunes playlists within Rekordbox, or showcase it in a different way to prevent confusion?

Josh Routin 0 票
コメントアクション Permalink
0
Avatar

Re-reading your original post seems to have clear information. Thanks for asking. :)

Pulse 0 票
コメントアクション Permalink
0
Avatar

I uploaded a screen recording that should illustrate the problem I'm having.

https://www.dropbox.com/s/f97y3lwfluoexqa/rekordbox%20itunes.mp4?dl=0

This issue is also present in Rekordbox 3.2.1 on OS X Yosemite 10.0.3 (iTunes 12.1).

Also - my iTunes Media folder location is not on the same hard drive as the Rekordbox application. I have two hard drives in my laptop, one for the OS and software (including iTunes and Rekordbox), the second drive is for media, where all my music (and the iTunes library file) is stored. Not sure if this is relevant, but I thought I should mention it.

Joe Moore 0 票
コメントアクション Permalink
0
Avatar

Shouldn't be a problem - I operate much in the same way. I'll pass the video along to engineers to see if they have further questions.

Pulse 0 票
コメントアクション Permalink
0
Avatar

Now I understand - playlist subfolders aren't loading. This is a similar issue to what @BriChi has reported and I'm not sure of the status on that case. I'll see if I can link the two issues on the back-end so the engineers know it's similar.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Josh > Thanks, I'll let you know if they need anything else.

@Joe > No worries, hopefully they can figure it out!

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Josh & @Joe > The engineers were unable to replicate the issue on their end using the files provided. They say all of the playlists were shown in rekordbox without issue. They would like to know:

  1. Do you specify the correct iTunes.xml in rekordbox? There are two different xml files which may be created depending on the circumstances; iTunes Music Library.xml and iTunes Library.xml. If you find those two files, please select the one which has been updated most recently (probably iTunes Library.xml).

  2. After rebooting the computer and before running iTunes, would you please see what you find in the iTunes folder from rekordbox preferences?

Pulse 0 票
コメントアクション Permalink
0
Avatar

My computer has only one XML file for the iTunes library, "iTunes Library.xml". The Rekordbox preferences in the Bridge section points to this file.

I tried exporting my iTunes library to a new XML file titled "iTunes Music Library" in the same iTunes folder as the iTunes Library.itl file. Then I set that new XML file in Rekordbox's Bridge preferences. Still no luck loading iTunes playlists inside folders.

Joe Moore 0 票
コメントアクション Permalink
0
Avatar

I'm undergoing a Mac->PC iTunes library transfer, and I'm running into the exact same issue.  It has to do with a library management bug on the side of iTunes.

I copied my entire iTunes folder (with the library, xml, random crap, etc.) over to the new PC on my secondary drive, and shift-opened iTunes and selected the new .itl, and BAM!  my library is back, even Date Added and everything.  Now it looks like iTunes has created the concept of multiple libraries, noted by the "Home" dropdown (under "File" in the toolbar).  I currently have 2 libraries:

"This Computer" - Empty, still has my playlists, but 0 items in them

"" - my restored library, with an "eject" button

My iTunes media folder location is "E:\iTunes\iTunes Music", with the "iTunes Library.xml/itl" files inside E:\iTunes.  Examining the xml, it is only showing the data from my empty "This Computer" library.  iTunes is treating this drive like an external library, and xml apparently isn't supported with these "External Libraries".

As I expected, they only keep the xml around still for legacy purposes (https://support.apple.com/en-ca/HT201610), so it just looks like something got missed on Apple's end.  All functionality for .xml management is tied to the default library, which I can't use because it will overwrite my precious "Date Added" values.

I want this fixed asap so I opened some sort of ticket with Apple: https://discussions.apple.com/message/28095917#28095917

 

ps: I'm not sure if this is just a zendesk thing, but the mouse scroll speed for this "Add a comment" box is too damn high for overly-verbose support ticket ranters like myself.

Ian Romansky 0 票
コメントアクション Permalink
0
Avatar

As per the discussion in the Apple link above, I believe this is an unrelated issue.  Feel free to remove if you want.  Thanks.

Ian Romansky 0 票
コメントアクション Permalink
0
Avatar

@Ian > Please start a new topic so I can support you there - this thread is already over-complicated with several users seeking assistance on different issues.

Pulse 0 票
コメントアクション Permalink
0
Avatar

Any new developments on this issue? I'm still not able to load iTunes playlists that are inside iTunes playlist folders.

Let me know what I can do help.

Joe Moore 0 票
コメントアクション Permalink