Have a feature request or suggestion? Post your idea here!

投稿

3フォロワー フォローする
1
Avatar

Extremely laggy browsing in OS X

I'm running the latest rekordbox dj (4.12) on OS X 10.10.5 and having a lot of trouble browsing. No matter what I do, the program lags a lot when I navigate through tracks. Actually loading and mixing is totally fine, but it's a very difficult to scroll and navigate through the panels.

 

Is this something that could be fixed by upgrading to El Capitan, or is there anything else I should try? 

 

I have a mid 2015 retina macbook pro so my specs should be fine. The program also runs completely fine on my windows PC. 

 

 

Kyle Reese 回答済み

サインインしてコメントを残してください。

8件のコメント

1
Avatar

@Kyle > Three things for you to try:

1) Go into your System Preferences and at the top where it says "Automatic Graphics Switching," un-check that.

Try again -- if you still have problems...

2) Open the rekordbox Preferences and on the View page, change the waveform drawing rate from High to Medium.

If that's STILL a problem...

3) Go back into the rekordbox Preferences and set the audio buffer to a value double what it's currently at.

If things persist in being laggy, please open your Activity Monitor and take a screen shot of the CPU, Memory and Energy pages please.

Pulse 1 票
コメントアクション Permalink
1
Avatar

Turns out I do not have a dedicated gpu on here, so the first thing wasn't an option. Performance did get slightly better when i lowered the resolution though (to 1440 x 900 instead of 1920 x 1200), so maybe I was wrong about being up to spec. 

But the rest of it should be fine, says it has 16GB dd3 memory, 2.8ghz i7, and Intel Iris Pro 1536Mb. I have attached the activity monitor while I had rekordbox open w/ 2 tracks loaded (but not playing) in case i missed something. 




Kyle Reese 1 票
コメントアクション Permalink
1
Avatar

@Kyle > That could be something that was either not available on that model or removed from retina-based machines, I'm not sure, either way - thanks for checking.

Could you take the same screenshots when the audio issues are occurring? That would help trying to track down the culprit.

Also, please check to see how many instances of the driver you may have loaded with your Login Items for your user. Go to System Preferences > Users & Groups, click your username, then click the Login Items tab and see what's listed there.

Pulse 1 票
コメントアクション Permalink
1
Avatar

Actually the audio playback is totally fine, it's just when i try to scroll down my collection of tracks that the browser seems sluggish, same when I scroll through the folders in the left panel. When I use arrow keys to move down there is a small delay before it responds to my commands. 

 

I did not see any drivers listed under Login items, unless its the one reading as Unknown - is this a problem? 

Kyle Reese 1 票
コメントアクション Permalink
1
Avatar

No, but you can remove those items with the <!> alert symbol.

How many tracks are in your collection? And does it still doing it after changing the waveform drawing rate?

Pulse 1 票
コメントアクション Permalink
1
Avatar

Currently about 500 tracks, didn't notice a difference with waveform drawing rate. I will try to upgrade OS X to whatever is the latest and see if that helps later today.

 

Kyle Reese 1 票
コメントアクション Permalink
1
Avatar

unfortunately the issue persists. I'll probably wait for another update or something and hope that makes things better. Lowering my resolution helps a bit but it's still very sluggish while scrolling. 

Kyle Reese 1 票
コメントアクション Permalink