Have a feature request or suggestion? Post your idea here!

投稿

2フォロワー フォローする
0
Avatar

Complete Sound Cutoff whilst mixing/recording

Hi all, 

 

Don't know whether this is a Rekordbox/DDJ/Laptop error so i will post in both threads. Basically i have the DDj RZ & DDJ RX. I recently bought a new laptop which is the Macbook Pro El Capitan 10.11.5. While im mixing generally or recording aswell, the sound completely cuts off, so you cannot hear anything. my rekordbox is still running and doesnt freeze along with the controller but there is literally no sound. when i playback the recording it will be playing fine then when the sound cuts out the recording will just loop like if a CD Skips. I need this sorted as i am dj'ing my event on friday and have a festival next week and can't have the sound cutting out as i will look like a right t**t. I have installed the firmware on the RZ, updated the drivers, uninstalled and reinstalled, updated my lapotop but still no luck. Both my Decks work fine on my windows 10 PC.

 

Thanks

WillZe

Willcattrall 回答済み

ログインしてコメントを残してください。

29件のコメント

0
Avatar

@WillZe > Please don't post the same issue twice; I've deleted the other post so it doesn't get cross-information.

Generally, rekordbox should be functioning just fine with OS X 10.11.5, although you're the first to post about a problem with the performance, please post the info about your CPU / RAM and let me know what your setting is for the buffer for each device.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse, my apologies, as i said, i will be mixing and it completely cuts off sound. The Macbook is around a month old, and my friend who dj's on a older macbook doesn't have problems. Here are my macbook specs:

Macbook Pro (Retina, 13-inch, early 2015)

Processor: 2.7 GHz Intel Core i5

Memory: 8GB 1867 MHz DDR3

Graphics: Intel iris Graphics 6100 1536MB

 

Buffer Size 864 samples: 19.6 ms, SAmple Rate 44100 Hz

 

WillZe

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@WillZe > Thanks for the info. When the sound cut occurs, does the waveform stop or does the mixer level movement stop? How long is the drop-out? Does it happen with both the RX and RZ?

Pulse 0 票
コメントアクション Permalink
0
Avatar

The mixer level is still active and same with the waveform, i think i may of fixed it, i went into settings and sound, and it was set to built in output, i changed it to rekordbox driver and ddj rz when its connected and it seems to be working fine at the moment.

 

thanks 

 

WillZe

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

Sorry, I just want to clarify ... if you had it set to the built-in output, how were you using the RZ? Were you not cueing the audio on the unit?

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse it was on rekordbox the whole time, it has been working fine, i have just installed the update and its just done it again, this time even worse, i really need this sorted as i am perfmorming a festival tomorrow! :(

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@Will > Sorry, I don't expect to have an answer before your performance, so you may need to use your Windows machine, but I've asked our product team to provide additional information.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Pulse I think i have found the problem.... Buffer Size. It stopped all sound output again so i went into settings to see if i can sort it. I increased the buffer size and sound came back again!. This is very strange as my b2b has an older macbook by a good 2/3 years and doesnt have a problem. it seems the newer macs need a bigger buffer size. im going to tweek it now as too high a buffer size maybe worse off when loading another song as i noticed. Definately something to report back though!.

 

Willze

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@Will > The buffer size should always be set to the lowest possible value without any audio dropouts or glitches. In some cases if another application, background or system process took available processing away from the DJ program or memory from the audio drivers, having a larger value available would help. If you're not worried about the performance aspect (in terms of timing between scratching and response of the program), you could set a much larger value than needed.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse  I have checked and i have nothing running in the background, its currently set at 1600 sampes 36.3ms, it was at 26 but when recording a mix it was all fuzzy and really bad quality and was still giving sound cutouts, unless i am missing something here like an installation or deletion of any files in the folder?

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

Is it working at the 1600 sample setting? Or are you still experiencing drop-outs or fuzziness?

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse i am still getting dropouts and fuzziness, it seemed that before the last update i changed the buffer size and it was fixed but since the update it has become worse no matter what buffer size i will get cutoff or fuzziness. is there a way i can downgrade versions, or clearly there is something wrong with my laptop cpu wise if a 2016 macbook el capitan cannot take rekordbox. 

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@pulse   i have skype, if you find it easier to troubleshoot this issue for other potential users aswell, my skype is djwillz231, i would greatly appreciate if we could skype to resolve this issue. i can understand if you may not wish to.

 

willze

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@pulse there isnt an actual how to on that page for my laptop as im usiing el capitan 2016. But i believe this is what you are looking for: Intel Iris Graphics 6100 1536 MB and thats the only one that comes up while rekordbox is open. 

 

willze

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

here is more info under system report: 

Intel Iris Graphics 6100:

 

  Chipset Model: Intel Iris Graphics 6100

  Type: GPU

  Bus: Built-In

  VRAM (Dynamic, Max): 1536 MB

  Vendor: Intel (0x8086)

  Device ID: 0x162b

  Revision ID: 0x0009

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@Will > If you look at the Mavericks instructions at the very top, they apply to El Cap as well; if you open the Activity Monitor, open the High Performance tab and see if rekordbox has a Yes in the Requires High Perf GPU column.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse there is not high performance tab on my macbook, however following the maverick instructions, rekordbox's energy impact is 135.0

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@pulse that was from following the instructions, havent found requires high perf gpu. it seems my macbook is running only 1 intel iris graphics chipset. 

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

Thanks -- can you send me the model identifier of your MBP from the System Profiler?

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse

 

Hardware Overview:

 

  Model Name: MacBook Pro

  Model Identifier: MacBookPro12,1

  Processor Name: Intel Core i5

  Processor Speed: 2.7 GHz

  Number of Processors: 1

  Total Number of Cores: 2

  L2 Cache (per Core): 256 KB

  L3 Cache: 3 MB

  Memory: 8 GB

  Boot ROM Version: MBP121.0167.B16

  SMC Version (system): 2.28f7

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

Thanks Will, I'll pass that along to our engineers.

Pulse 0 票
コメントアクション Permalink
0
Avatar

@Will > The engineers would like to know if the Audio Drop-Out Meter (located below the clock) is near full when the dropout occurs.

Could you check that and also post a screen shot from the CPU and Memory pages of the Activity Monitor if/when it happens?

Pulse 0 票
コメントアクション Permalink
0
Avatar

@pulse The Audio Drop-out meter is always very low, its never high. 

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

Due to size of picture being over 2mb, my memory whilst running rekordbox is 1.07gb. I phoned up Apple care the other day, and have seemed to fixed the audio cutout part, the solution to that was going into Macintosh HD, Applications, system preferences, user and groups, login items. under there i seemed to have 12 copies of the ddj-rz drive running. i removed all and the cutouts have stop. However, now the only problem is whilst recording and running 4 decks at a time for a mashup, the recording will sound fuzzy and hazy. i have tested it on the highest and lowest buffer size and it is still doing it. hope this is all useful information. it seems the problems have been the worst since the update of rekordbox

willze

Willcattrall 0 票
コメントアクション Permalink
0
Avatar

@Will > Good to know about the login items, I'll keep that in mind.

I think I see why you might have "fuzzy found" when running 4 decks - you may be clipping the audio levels:

Try turning your channel gains down just a bit.

Pulse 0 票
コメントアクション Permalink
0
Avatar

RESOLVED******** Thankyou Pulse and your team for your help, its been a nightmare with plenty of swear words in between!. However it seemed the cutouts was to do with the 12 drivers logging in at the same time under users, and correct pulse, fuzzyness due to levels being distorted, so now trims are down low with master on medium. Something with El Capitan and Buffer Size that might have to be looked at im not sure.. but  i hope ive enlightened some issues here, but its all sorted. 

 

Regards

 

WillZe

Willcattrall 0 票
コメントアクション Permalink