Have a feature request or suggestion? Post your idea here!

投稿

2フォロワー フォローする
0
Avatar

DDJ-SZ & RekordBox DJ - Internal/External Mixer switching trouble

Hi!

When audio driver in RekordBox DJ selected on DDJ-SZ then I can't use internal mixer of RekordBox - this function is not available... When I switch audio to built-in driver (MacBook Pro) - internal mixer is available. I need internal mixer of RekordBox DJ and my DDJ-SZ to control this internal mixer. Another words: with RekordBox DJ I don't need external mixer of DDJ-SZ completely but, I can't switch on internal mixer - it doesn't work totally while DDJ-SZ chosen in audio driver section. How can I fix this problem ??? 

Hope anybody can help me. ) Thanks. ) 

Evgeny Melnikov 回答済み

正式なコメント

Avatar

Sorry, that's not available with the SZ due to the audio routing.

Pulse
コメントアクション Permalink

サインインしてコメントを残してください。

9件のコメント

0
Avatar

So I understand, what is it you're trying to accomplish by using the internal mixer when using the DDJ-SZ?

Pulse 0 票
コメントアクション Permalink
0
Avatar

Yes. I need internal mixer in RekordBox DJ when using DDJ-SZ. 

Evgeny Melnikov 0 票
コメントアクション Permalink
0
Avatar

I understand that but you haven't explained why you need to do that?

Pulse 0 票
コメントアクション Permalink
0
Avatar

DDJ-SZ can control EQ and faders of internal mixer of RekordBox DJ... It would be cool if in the next update Pioneer will add this feature. If I remember correctly NI Traktor have this option. Why Pioneer can't do this simple feature?..

Evgeny Melnikov 0 票
コメントアクション Permalink
0
Avatar

The only audio connection option of the DDJ-SZ is external mixer mode, which means each channel is sent discretely to the mixer portion of the SZ.

Yes, you can control the effects of rekordbox with the SZ controls, but those effects are applied to the audio before it is sent from the software to the hardware, meaning if you drop your fader, the audio is being cut out.

Should you use the sound color FX on the SZ itself, those are applied at the hardware level, and the echo would tail out after the fader is dropped.

If you are using Traktor, it may be that you have mapped the SZ's mixer controls to the software mixer within Traktor, but should you have the audio routed to any of the channels you're using to manipulate the software (MIDI mixer control), they would also me manipulating the audio passing through them. For example, you map channels 1 and 2 of the SX mixer to control 1 and 2 within Traktor, the audio config is set to send the master output to channel 1&2 (the first stereo pair), you'd then also need to send the headphone cue to ... 3&4? Those two sets of outputs are now being overridden by the hardware itself because it's still an audio mixer.

TL;DR - see my official post; the hardware isn't configured to do what you're asking, sorry.

Pulse 0 票
コメントアクション Permalink
0
Avatar

OK. I understand you. But I want to tell that it's very bad (not only for me) when the equipment for this price (not a small) have no such a simple option/feature. In the description of this product that specific design flaw was not listed... And I bought it online... Before RZ was released. I'll try to solve this problem using another external soundcard.

Ok, let's leave this. I know that SX, SX2 and RX has this 'FX tails'. What about DDJ-RZ? The same situation as with DDJ-SZ?

Evgeny Melnikov 0 票
コメントアクション Permalink
0
Avatar

No; the RZ is configured for a "master / phones" output setup, so you're able to have post-fader effects.

Pulse 0 票
コメントアクション Permalink