Have a feature request or suggestion? Post your idea here!

投稿

9フォロワー フォローする
0
Avatar

XDJ XZ - Unable to use Performance Mode Rekordbox No soundcard

I'm un able to use my XDJ XZ in Pereformance mode for some reason I've installed the drivers but in the Audio section of Rekordbox DJ i only get the option of Built-in Output....I'm i missing something here?

Gus Gomez

投稿コメントは受け付けていません。

32件のコメント

0
Avatar

Hello,
I had the same problem.
I found a solution that worked for me.
First I turn on my XDJ-XZ and when it is fully started, then I turn on my PC. When the PC is started, I launch Rekordbox and then I select the blue Rekordbox button on the XDJ-XZ and I press the load tracks buttons 1 and 2 to pair the decks of the XDJ with Rekordbox.
It works for me...
Regards,
Pascal.

Prokuniev 0 票
コメントアクション パーマリンク
0
Avatar

I just tried that and nothing....this is a crazy issue to have I can’t believe at this stage they’re having a soundcard drivers issue....and I have gotten no answer from Pioneer even though they saw my msg on Twitter. Smh

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

This sucks they need to fix this ASAP this is a deal breaker for me I submitted a ticket let’s see if they answer soon.

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

First off, Twitter is not a support avenue, so please don't message them - it just ends up overlapping with other support and becomes frustration, ditto making a ticket if you've already posted here and we didn't send you there.

@Gus > The problem you're likely facing is that you didn't allow the drivers through the macOS security; please see this document for additional info (it's linked below the driver download, but many people don't read everything they click on). You'll likely want to uninstall and reinstall the drivers, then authenticate them to get things working.

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

Thanks Pulse, I will give this a shot when I get back home although I looked through the whole privacy/security and didn’t see anything there but I’ll give it another shot.

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

Crazy that I put a ticket in and have yet to get a reply from Pioneer that’s crazy to me

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

@Gus > Because I posted internally on that ticket I'd already replied to you here. Did my solution fix your issue?

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

I will find out today unfortunately I haven’t been home yet to try it but I’ll give it a shot as soon as I get there thanks!

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

Please let us know if that works, if not, I'll get you some additional info via the ticket. :)

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

That definitely did not work at all I tried it 3 different times and had no luck at all

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

This worked perfectly thank you Pulse!...

For those having issue here’s what worked for me:
Please follow these directions to make sure things are cleared out and installed properly:

<SNIP>

File a ticket.

</SNIP>

Gus Gomez 0 票
コメントアクション パーマリンク
0
Avatar

@Gus > I'm glad that worked for you, but we'd rather not leave those instructions for anyone to try as there are other steps prior to that we would attempt first. Thanks.

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

Hello,
I am having the exact same issue my XDJ-XZ came in today I installed both drivers nor rekordbox or my mac recognize them. I am running high Sierra and had no issue allowing through privacy/security. I need some help

Stephen Ramundo 0 票
コメントアクション パーマリンク
0
Avatar

@Stephen > Are you in PERFORMANCE mode within rekordbox? Do you see the XDJ-XZ as the control device at the bottom of the page in the rekordbox Preferences > Audio tab (very bottom)?

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

Yes I’m in performance mode and nothing in control device. I have installed and uninstalled multiple times no luck

Stephen Ramundo 0 票
コメントアクション パーマリンク
0
Avatar

If it's not in the Control Device section, then it's not installed properly. Can you open your System Information app, open Software > Disabled Software and see if there are any Pioneer DJ drivers listed there?

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

Try this anyhow:

  1. Unplug the USB from the XDJ-XZ.
  2. Go to your Applications and open the Utilities folder, launch the Terminal app.
  3. Type (or copy/paste) the following command: 
    sudo kextcache --clear-staging
    That is a space between the first two words, then a space and two hyphens before clear.
  4. You will need to enter your Mac user password (or just hit enter if you don't have a password); it will not show any characters onscreen as you type, press return when you are done and the process will run.
  5. Download the driver if you don't still have the driver package.
  6. Open the driver package and run the uninstaller file.
  7. Reboot your computer.
  8. Open the driver package and run the driver installation file.
  9. After the installation has completed, give the drivers permission; this may not have appeared previously, but as the kext (driver extension) cache has been cleared, the security prompt should now appear - click the button to allow the drivers through the security.
  10. Connect the XDJ-XZ and test it out.
Pulse 0 票
コメントアクション パーマリンク
0
Avatar

No luck went through all steps and tried it again no success doesn’t come up in the audio midi setup either.

Stephen Ramundo 0 票
コメントアクション パーマリンク
0
Avatar

Im experiencing the exact same issue and have followed all troubleshooting permutations possible.

@stephen > did you ever get this resolved?

@pulse > any idea what happened with this?

Kane Nelson 0 票
コメントアクション パーマリンク
0
Avatar

Hello,

I am Having issues installing and using the XDJ-XZ driver into my Alienware high cpu high gpu pc. It keep saying instillation failed and then when it is installed the audio driver in my rekordbox doesnt recognize the XDJ-XZ and i cannot use it on performance mode nor can I link. also nothing comes out out of the audio output when i route it to some voicemeeter apps to stream online.

 

Ivan Contreras 0 票
コメントアクション パーマリンク
0
Avatar

@Ivan > Download the driver here, right-click and select Run as Administrator without the XZ connected via USB. Reboot and then connect the USB and open the XDJ-XZ Driver Version Display app to see if the unit is showing as connected.

Pulse 0 票
コメントアクション パーマリンク
0
Avatar

I also have this problem. I have tried it with my MacBook and PC. The exact same problem, I guess it is a driver problem or a problem inside the machine. Now I can only use a USB flash drive and cannot connect to rekorebox.

凯宏 谢 0 票
コメントアクション パーマリンク