Have a feature request or suggestion? Post your idea here!

投稿

7フォロワー フォローする
1
Avatar

CDJ 3000 Track Filter Issue/Request

Key matching doesn't auto adjust to the master player over time. It works initially after editing the track filter settings but it will not stay locked to the master player unless you manually enter the track filter edit settings again.

This did not happen on the 2000nxs2's. As long as you checked "key" box in the filter edit settings, every time you hit the track filter button it would filter any tracks within one key step of the master player.

Maybe this is by design or I'm missing a setting within the track filter edit.

I can post a video if a better description is needed.

Thanks,

-Jesse

Jesse Sliwinski 回答済み

正式なコメント

Avatar

I'm informed that the fix is coming in an update before the year's end.

Thanks for your patience!

Pulse
コメントアクション Permalink

投稿コメントは受け付けていません。

12件のコメント

0
Avatar

Hmmm... you're right, and what's funny is when you open the filter to edit you can see the key matching options pop over to the new value without having to do anything.

I'll pass this to our product team for review. Thanks for the feedback.

Pulse 0 票
コメントアクション Permalink
0
Avatar

Okay, so after testing and chatting with the engineers, the CDJ-3000 and CDJ-2000NXS2 work the same way...

- Load a track on deck 1, key 7A (for example); assign as master.
- Browse and apply a filter of "Master Deck: Key" on deck 2, load a matched track of key 8A.
- Browse and apply the same filter on deck 3, it will show matches to 7A (6A, 7A, 7B, 8A)
- Set deck 2 as Master, deck 3 will not refresh the filtered list, but the traffic-light matches will update.
- You must either disable / re-enable the filter, or enter the filter edit mode / re-exit filter mode to refresh the list.

 

Pulse 0 票
コメントアクション Permalink
0
Avatar

Huh, I coulda sworn I didn't have to do that extra step on the last gen's. Either way, no big deal as I've gotten used to the way it is.

Thanks for checking into it Pulse.

Jesse Sliwinski 0 票
コメントアクション Permalink
1
Avatar

Jesse, you are absolutely correct. It would automatically follow the master, and allow you to filter the key matches to whatever the master player was showing. You did not have to take the extra step to 're-enable' the filter in the filter edit mode section.

This NEEDS to be fixed - there is simply no way that having to menu dive - even if it is just a long press into the filter/edit page - is the superior option.

Michael Alan 1 票
コメントアクション Permalink
0
Avatar

Switching from NXS 2 TO 3000, I can say the same! The way they worked is different and I find it frustrating that they do not adapt to the change of the master player. No extra step was required! Please FIX it, we just want to be able to press filter once without going into the menu and going back

Luca Stanzani 0 票
コメントアクション Permalink
0
Avatar

The "problem" still occurs on the 3000's. I think it's an absurd to just downgrade a feature from the NXS2. I hope you take some action and the Track Filter option automatically analyses the Key of the MASTER track, without having to press and hold the button so it updates the key of the Master Track.

Eduardo Moreira 0 票
コメントアクション Permalink
0
Avatar

Yes, I opened a support ticket for this months ago which is still open. Hopefully it will get fixed in the next firmware.

But as it was already brought to the attention of the team in 2020, why is it STILL not fixed?

Markus Marquardt 0 票
コメントアクション Permalink
0
Avatar

As of 2.03, the "on / off" workaround no longer works for me and I have to select the key manually so in other words, the issue got even worse and even more annoying.

Pioneer, will you please fix this finally? This issue has been around for 2 years already and you keep ignoring it.

Marek 0 票
コメントアクション Permalink
0
Avatar

@Marek - you must be joking? 

Pioneer, seriously. The biggest kick in the teeth on this is that other, newer, products (XDJRX3) do not suffer from this oversight! They work exactly as they should!

Please fix this.

Michael Alan 0 票
コメントアクション Permalink
0
Avatar

The workaround still working on CDJ 3000 is: LONG press the filter on/off button, so you see the edit filter settings. Then they will be updated with the other player's BPM/Key.

It is very annoying to have to do the long press all the time to update the filter! I don't understand the reason - if there is any - behind this broken logic.

Markus Marquardt 0 票
コメントアクション Permalink