Have a feature request or suggestion? Post your idea here!

Post

11 followers Follow
2
Avatar

Rekordbox 1.5.4

Had a bunch of crashes - two on start up... and the others on exit.

unable to eject my usb hard drive with out spinning beach ball - after transfer has complete.

all a bit odd really!

Matt Jackson

Please sign in to leave a comment.

63 comments

0
Avatar

@ Pulse. I think I have the same problem as Jeroen. Deleted version 4 and reïnstalled version 3. Still the same problem. When I start-up Rekordbox says that the program doesn't work correctly and I need an update on it. After the message I can only close the program. Do I need to do the same thing as Jeroen (copying your database file out and completely wiping out the hidden Pioneer folder then reinstalling). Don't I loose all the date I've put in Rekordbox??. The database is which file name?.

Kris Adriaenssens 0 votes
Comment actions Permalink
0
Avatar

@Jeroen > Just to confirm, you removed your rekordbox database from the hidden Pioneer folder, deleted the Pioneer folder, reinstalled rekordbox (1.5.3?) and you are having a crash after opening the software?

Pulse 0 votes
Comment actions Permalink
0
Avatar

@Kris > It will keep saying you need an update if you're not using 1.5.4.  Did you REMOVE the hidden Pioneer folder prior to reinstalling?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Yeah I know. But I ignore it. After I don't chose to do the update I get the error. Where can I find the hidden folder??

Kris Adriaenssens 0 votes
Comment actions Permalink
0
Avatar

Oh yeah for the Record. I installed version 4 also on an other computer. No data yet in program but it crashed also. Maybe some usefull info.

Kris Adriaenssens 0 votes
Comment actions Permalink
0
Avatar

Pulse - so i re-analysed a few tracks in 1.5.3. The cue points stay where they were and helps me to know how far off things have gone. The beatgrid moves, in every case, but does not fully correct. i.e.. the blue marker and the cue do not align like they did previously. What is interesting the amount is visibly the same in each case. That is, the cue to the blue marker. May be that helps a little, may be not.

music is 4/4 techno/tech house/deep house purchase from beatport. the grids sometimes need to be corrected and i am kind a perfectionist so check each track. to run through what i do when i buy music. I run them through mixed in key, the platinum notes, then into RB then correct the grid, and put in a cue mark. then move to sd card.

 

cjb001 0 votes
Comment actions Permalink
0
Avatar

pulse something also came to mind. i think the reason why i re-analysed everything when i opened my tracks in 1.5.4 was because all the grids had moved without doing anything. odd, i know, but thought this may be helpful to you.

cjb001 0 votes
Comment actions Permalink
0
Avatar

Pulse - i have tried some other things

I tried to recover, via my time machine, the version of 1.5.3 that i know worked. I knew it was fine last Friday a I should add that i have a rugged portable drive that i use for my music. When i used the recovered 1.5.3. All the grids were off as i explained in my previous message.

I backup the rugged 1 with another one, lets call it rugged 2, just in case the first one corrupts. I moved 10 tracks from the rugged 2 into recover 1.5.3 and those tracks are off and do not load any cue's.

I then thought, i don't mind recovering my music from last year when i bought a new macbook pro. it would be easier to sort out music from june to present day rather than 3000 tracks.  i used my "rekordbox_2011y06m10d_datafile.edb" file. Again, the cue's and the blue marks are out. I would just need to move the blue marks to the cue and it would be fine. still, all the tracks would need editing.

So something rather strange has gone on. Personally, i think when i re-analysed all my tracks in 1.5.4 it has done something to my music. i can think of no other reason.

hope this helps? 

cjb001 0 votes
Comment actions Permalink
0
Avatar

@Kris > Was previously linked for you - here it is again.

@cjb001 > I had a thought on this issue -- a previous version of the software also showed the grid being off the markers, have you tried actually playing the songs to see if it was maybe just a display issue rather than the grid being OFF the beats?

Pulse 0 votes
Comment actions Permalink
0
Avatar

ok, so i have 900 tracks on my sd card (that i had cued and everything was fine that). i thought i would move them from my sd card to RB (remember that i have deleted and restarted so will be missing tracks from the middle of last year to present day) most of the tracks on this sd card and, hence, thought would save me time. So i try to move the tracks across. The tracks that are on the sd but not in my RB collection disappear when i move the playlist to sd to computer. Next, the track that are new ones on rekorbox, so with out cue. stay without cues when moved from sd to computer.

so, i assume that if anything goes wrong with the collection in RB, then you are f'd. 

i have tried many things now, but alas, nothing that works. 

Ok, now onto the test. 

I did as you ask and it seems that the display on RB is off, however, the tracks seem fine on the players. I test two tracks, same bpm, looping and playing mixing in and out constantly.  thats seems a relief. perhaps  ryanm6913 needs to test too. however, doesn't resolve some other issues i have mentioned.

cjb001 0 votes
Comment actions Permalink
0
Avatar

@ Pulse. I really can't find the hidden folder. Even if I search with the link you send.

Kris Adriaenssens 0 votes
Comment actions Permalink
0
Avatar

@Kris > It's hidden; if you don't have the hidden folders enabled, you won't see it.

Pulse 0 votes
Comment actions Permalink
0
Avatar

@cjb001 > If you are trying to move tracks from the export device to a collection where they don't already exists, they won't import - sorry.  If you already had the track in your collection you could then update the cuepoints or any memory points you had stored on the CDJ to that track.

Glad to hear the beatgrid issue may only be within the display of the software.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Pulse - haven't been on here for a little while. I wondered why the display is still incorrect despite moving back to 1.5.3 - any ideas. For your information, I purchased some new music and cued them up, lining the blue markers correctly. played the tracks and no problems on the players.

So does RB do something to the music - that we do not see -  and somehow opening in 1.5.4 and now reverting to 1.5.3. there is a problem? Odd don't you think?

 

cjb001 0 votes
Comment actions Permalink
0
Avatar

also, i have tried to update collection from the sd card. a lot of the tracks up-dated with the cue marks. however, a number did not. i wonder why this is?

i tried to see if if would work with one of the problem tracks. I moved the track directly from the sd onto my desktop. then i put it into the RB collection. then updated collection from the sd card. sadly, that didn't work.

So there is a couple of questions there for you sir ;-)

cjb001 0 votes
Comment actions Permalink
0
Avatar

@cjb001 > It's likely that the marker information in the database is off but they are okay on the players.

Pulse 0 votes
Comment actions Permalink
0
Avatar

All of my beatgrids are destroyed! also corrupted my database on my flash drive after exporting.  SERIOUSLY BAD!

Ån†-li√E 0 votes
Comment actions Permalink
0
Avatar

Are you sure? The engineers have pinned down the cause of the moved beat-grids, and it's only within rekordbox; your tracks should be fine on the export, but if your export database is corrupt, it's not likely to be from a fault of 1.5.4.

Pulse 0 votes
Comment actions Permalink
0
Avatar

I jumped back to 1.5.3 and am going through everything now. some stuff that i just set in 1.5.4 is out of wack. and things that have been fine are totally off... reformatting my flash drives and trying everything fresh on them from 1.5.3

doubtfully it was the build that caused a corruption but who knows.  I am very careful with my files.

Ån†-li√E 0 votes
Comment actions Permalink
0
Avatar

All of my hot cues on the tracks with the messed up beat grids are moved too.

Ån†-li√E 0 votes
Comment actions Permalink
0
Avatar

It could have been something as simple as removing it from the player without holding the STOP button first... but get back on 1.5.3 and see how things go.

Are they actually moved when playing them on the CDJs?

Pulse 0 votes
Comment actions Permalink
0
Avatar

Yeah, i am usually pretty careful but remember pulling it without before it happened. Either way, i am going through my entire library checking songs.

Ån†-li√E 0 votes
Comment actions Permalink
0
Avatar

@cjb001 > Engineers found it was simply the display that was off, the marker data was accurate when used on the CDJs.  When the update is available, we'll let you know.

Pulse 0 votes
Comment actions Permalink
0
Avatar

can anybody tell me in simpler terms what the new rekordbox update is all about and if i need it ????

 

thanks

phildw01 0 votes
Comment actions Permalink
0
Avatar

pretty much if you own the new MEP-4000, you need 1.5.4, if you don't own it, stick to 1.5.3

BriChi 0 votes
Comment actions Permalink