Have a feature request or suggestion? Post your idea here!

投稿

1フォロワー フォローする
0
Avatar

"Jump before reaching the next beat" Quantize option doesn't work as expected with hot cue at song start

Hello,

When "Jump before reaching the next beat"  is enabled in the Rekordbox Performance mode's settings (Controller --> Others), and with "Quantize/HotCue" enabled and set to "1", here is what happens, in different scenarii :

1) if the HotCue is set at any other moment of the track than "00:00" (the very start of the track), and the HotCue button is pressed slightly AFTER the beat, then, it does the expected behaviour : it doesn't jump to the next beat, but to the previous beat --> no problem here, the feature does its job

2) if the HotCue is set at any other moment of the track than "00:00", and the HotCue button is pressed slightly BEFORE the beat, then, it does the expected behaviour : it DOES jump to the next beat --> no problem here, this is how quantization works in Rekordbox, whether "Jump before reaching the next beat" is enabled or not

3) if the HotCue is set at exactly "00:00", and the HotCue button is pressed slightly AFTER the beat, then, it does the expected behaviour : it doesn't jump to the next beat, but to the previous beat --> no problem here, the feature does its job

4) if the HotCue is set at exactly "00:00", and the HotCue button is pressed slightly BEFORE the beat, then, it DOES NOT DO the expected behaviour : it jumps directly to the HotCue point without any quantization --> THIS is the problem that I have. Here is a screenshot of the result :

As you can see, it breaks the beatmatching :(.

This is very inconvenient because this means that the behaviour of the "Jump before reaching the next beat" option is not consistent depending on where the HotCue is set in the track.

I'm using a DJM750MK2 with either a DVS setup and midi-mapped Kontrol X1  MK2 or 2 x CDJ2000NXS2 (HID), and the misbehaviour is the same.

Is it possible to fix this issue please ? It prevents me from using the "Jump before reaching the next beat" option, which would be very valuable for my mixing workflow : if I could have it enabled with the "peace of mind" that it is consistent, I wouldn't have to disable it, and in turn to be forced to look at the computer screen to check that I am always "just before a beat" before pressing a HotCue, so as to not break my beatmatching.

Interestingly, I have noticed that there is no problem when SYNC is enabled, but I don't want to use SYNC and prefer to beatmatch manually.

Thanks in advance for your help,

Noxize

Noxize

サインインしてコメントを残してください。

1件のコメント

0
Avatar

Hello again,

 

Anyone from Pioneer DJ to help with this please ?

This is a very annoying bug, and I think, rather easy to fix.

 

TL;DR : when "Jump before reaching the next beat" is enabled and HotCue quantize is set to « 1 », pressing a HotCue snaps to the nearest beat (forward or backward)… but if HotCue is set at 0:00, it acts like there is no quantization at all, and it jumps directly to the HotCue.

 

Other DJs in this forum (and others) already complained about the fact that quantization with Rekordbox HotCues was by default snapping only forward. 

Here are a few threads about this kind of issues :

  1. https://forums.pioneerdj.com/hc/en-us/community/posts/205862126-Quantizing-loops-but-not-hot-cues
  2. https://forums.pioneerdj.com/hc/en-us/community/posts/204291636-Hot-Cue-Delay
  3. https://forums.pioneerdj.com/hc/en-us/community/posts/900001360303-Hot-cue-delay

 

The "Jump before reaching the next beat" option (although its name is misleading IMHO) is meant to allow the quantization to happen also backward if the nearest beat is behind and not ahead, and this could solve issues like the ones described by other DJs in the above forum threads.

This is a very precious option that should work consistently, whatever the time position of the HotCue is.

I am not the only DJ to which this behaviour of the HotCues is affecting the workflow, and users of all the Pionneer DJ products that have pads or HotCues buttons would benefit from having this bug fixed in Rekordbox.

I think this is one of the small-but-important things that push back Traktor or Serato DJs from using Rekordbox.

Thanks in advance for helping out :)

 

Noxize

Noxize 0 票
コメントアクション Permalink