Have a feature request or suggestion? Post your idea here!

投稿

3フォロワー フォローする
0
Avatar

[SOLVED] Rekordbox MAC cdj link error 8309&8302

Hi, I've done everything in these forums to correct this issue. My players link together fine. But when I load tracks onto the players the icon in rekordbox stays grey and doesn't go to the yellow cue icon. On the CDJ 900 it waits a while all the track info comes up except the waveform then the message error 8309 followed by 8302. CDJ FIRMWARE is the latest as of today I downloaded. Rekordbox is the latest version to download. I've completely uninstalled rekordbox numerous times I don't have firewall turned on. I'm on a MacBook pro mod 2012 OS X Yosemite. Changed nothing just all of a sudden I can't drop tracks to my players. Exporting all my tracks to usb works fine with the link and plays the file. Can't get my computer to work individually with Ethernet cables directly to the CDJ players with no router in between. Can't you please help me with this.

Sting

ログインしてコメントを残してください。

39件のコメント

0
Avatar

By the way. Been battling with this for the past month. Just been syncing my music to usb and linking two players with each other. So the files are fine.

Sting 0 票
コメントアクション Permalink
0
Avatar

You should see more information on the screen than just the 8302 or 8309 error, can you provide that info as well please?

Pulse 0 票
コメントアクション Permalink
0
Avatar

Nah I don't see anything else. When I push the link button on the player all my playlist come up and I can scroll through on the player and see it all. But when I go to load a track. Error 8309 comes up and stays for 10sec maybe and then straight over to error 8302. All the track information is there, except for the waveform on the cdj900

Sting 0 票
コメントアクション Permalink
0
Avatar

Have you tried using a different ethernet cable between the computer and a single player (direct connection)? Are you running a USB to Ethernet adapter?

Pulse 0 票
コメントアクション Permalink
0
Avatar

Yes I have tried to link computer directly with just one player. Using Ethernet cables no USB adapter. Same result when I link them individually get all my rekordbox library on the screen can scroll through all my song names but when I load a track get that error. I've been using the same cables the link the players with usb between each other and they work.

Sting 0 票
コメントアクション Permalink
0
Avatar

make sure you disable wireless altogether, then connect and turn everything on. I had similar lading issues when i used ethernet AND had my wifi connected to my home network, RB got confused on what to use pretty much

BriChi 0 票
コメントアクション Permalink
0
Avatar

Yeah I tried that as well. I've been through there forums searching for an answer for a while now. Still can't figure it out. Turning wifi off didn't do anything for me :(

Sting 0 票
コメントアクション Permalink
0
Avatar

Can you please upload your database? If can be found at: OSX: /Users/yourusername/Library/Pioneer/rekordbox/datafile.edb

Thanks.

Pulse 0 票
コメントアクション Permalink
0
Avatar

ok i couldn't find that folder anywhere on my mac. So i opened record box and chose to backup library from the dropdown menu - file > library > backup library. i chose not to backup music files because that wasn't neccesary . It copied everything into a zip folder and thats where i found the datafile.edb. does that folder need to be there in (/users/yourusername/library/pioneer/rekordbox/datafile.edb) to make the link on cdjs work? If so why isn't it there already? i only dj in a club on the weekends so i can't actually test this until that day comes unfortunately but if you know otherwise could you let me know?

Sting 0 票
コメントアクション Permalink
0
Avatar

i can't even find the library folder? am i doing this right. i got to (macintosh hard drive > users > myusername > and i only see standard folders I've attatched a screen shot  

Sting 0 票
コメントアクション Permalink
0
Avatar

You won't see it - you have to go TO it by using the GO TO FOLDER command in the finder (Shift + Command + G), then type ~/Library/Pioneer/rekordbox/ and you should see it.

Pulse 0 票
コメントアクション Permalink
0
Avatar

ok this is the file from there after searching go to 

(Shift + Command + G), then type ~/Library/Pioneer/rekordbox/  

Sting 0 票
コメントアクション Permalink
0
Avatar

Hi I'm stil can't get it working. I've tried other players with completely different cables. Is a computer problem on my end. I have the 4 services available in my nfs server setting. And I try it with my firewall off and on just the OSX built in one no third party software. Still won't work. I've tried previous version of rekordbox 2.2.4. could it be my Ethernet port software I can connect to my internet without a problem at home. Or a library problem. How do I delete all the information rekordbox has and start again re analyze all files and new playlist all information

Sting 0 票
コメントアクション Permalink
0
Avatar

Hi pulse im desperately trying to get this fixed. Ive attached my activity monitor print out. is there anything running that could disrupt rekordbox link 

Sting 0 票
コメントアクション Permalink
0
Avatar

Hey!

I have been struggling with the same problem the past two weeks. I always use rekordbox click and drag to the CDJ, and two weeks ago it suddenly didn't work wen i came the the gig, with exactly the same equipment that worked the week before. The player-icon stays grey, but if i export my musik to a USB and play it from there, the computer can still identify that the CDJ is playing from another device. It just simply won't load from the computer directly.

I would really love to have this solved, since I work with a lot of variation, playing with a USB is annoying and I can't search in the same way that I used to.

Karl Johan Morberg 0 票
コメントアクション Permalink
0
Avatar

@Bill > Are you running an NFS server on your computer?

@Karl > You may need to update the firewall as some changes to applications will require updated firewall rules to match the version change. Please read this guide, and if you need further assistance please start a new topic with the answers from the bottom of that thread, and I'll be happy to help you there.

Pulse 0 票
コメントアクション Permalink
0
Avatar

Not running any servers, I made my home folder on my computer (documents,pictures,music etc ) shared over a network and then added that to the nfs server setting to see if that would do anything. Could that effect it?

Sting 0 票
コメントアクション Permalink
0
Avatar

The engineers note that an open network share (such as the home sharing) can interfere with the rekordbox link as they also use NFS traffic. Try disabling your sharing before starting rekordbox to see if that improves the situation.

Pulse 0 票
コメントアクション Permalink
0
Avatar

hi pulse, i only added that folder to nfs to see if that would make a difference , i deleted it from shared and tried it without and with the firewall off still doesn't work. What kind of services does rekordbox use to create the link with players e.g. java or network preferences i need to have installed or modified 

Sting 0 票
コメントアクション Permalink
0
Avatar

This is getting ridiculous, i went and purchased 2 x XDJ 1000 players for personal home use. I thought that it would be easier to trouble shoot the problem owning a set up of my own at home rather then trying to do it at the club when I'm working. I still cannot get link to work, so i decided to instal rekordbox on my iMac at home my personal computer that does nothing else but bookwork for me never ever had rekordbox installed once nor did it have any mp3 files i had to copy some music over via usb just to get some music in rekordbox. So i connect it up the player hit the link button and BAM it magically works perfectly first go everytime i drag and drop songs onto the players and they work fine. Go back and connect my Macbook computer to them hit link, nothing happens still. I cannot even see my rekordbox library on the player. iMac worked fine with firewall on mine didn't so i turned it off and tried that still nothing. So i turned the firewall off on my macbook pro still doesn't  work. So i deleted the allowed permission in firewall  (edb_streamd, psvlinksysmgr, psvnfsd and rekordbox.app) opened up rekordbox again with firewall on, only 3 of the permission pop up windows appeared to allow in firewall. The (Edb_streamd) didn't pop up so i searched the file and added it manually, still won't work. I went through every single setting between my iMac and Macbook Pro and made sure everyone of them was the same. Then i thought maybe my Macbook Pro needed defualt settings again, so i made a new user account on my macbook pro, nope still doesn't work, than i thought maybe its my ethernet port so i went and purchased a thunderbolt to ethernet adapter (genuine apple brand) nope still won't work. What setting or preference could possibly stop all this SERIOUSLY Can anybody help me with this?? I'm sick of it! 

Sting 0 票
コメントアクション Permalink
0
Avatar

I know BriChi mentioned it earlier, but have you verified that you're doing all this with the wifi turned OFF?

Do you have any other settings enabled on your computer, such as file sharing, or a network service that might be interfering with the communication?

Pulse 0 票
コメントアクション Permalink
0
Avatar

Wifi on doesn't work widi off still nothing, I've turned every file sharing and network sharing off i could think of, the only one i had left was printer sharing so i turned that off as well still nothing. 

Sting 0 票
コメントアクション Permalink
0
Avatar

when i drop tracks onto the player with rekordbox 2.2.4 the xdi 1000 saying loading but then never loads the track with an error 8309 network link access error, when i use the latest 3. whatever nothing comes up the players screen doesn't even flicker?

Sting 0 票
コメントアクション Permalink
0
Avatar

edb_stremed doesn't have a window popping up when i click allow on all the other services through the firewall when i try with it on. Its in there and allowed but everytime i start rekordbox they all still pop up to allow them. There must be something wrong with that, like a protocol not enabled on my computer or some sort of bug stopping it.

Sting 0 票
コメントアクション Permalink
0
Avatar

I downloaded little snitch to see exactly what was going on here is everything that is running. I even disabled every single service except for the rekordbox ones and it still doesn't work. As soon as i click link in rekordbox the player read E-8309 Link Access Error before i even try to drop a track on it? i attached screen shot of snitch

Sting 0 票
コメントアクション Permalink
0
Avatar

Sorry Bill, I'm still waiting to hear back from the engineers.

Can you snap a screenshot of the network preferences panel (like this, with the ethernet selected):

Screen_Shot_2015-04-28_at_9.50.47_AM.png

Pulse 0 票
コメントアクション Permalink