Have a feature request or suggestion? Post your idea here!

Post

9 followers Follow
0
Avatar

Rekordbox 4.0 not working with XDJ-RX via LAN

I've read through most of the threads and tried pretty much everything mentioned... I've disabled my firewall and even turned it back on but allowed everything to pass through that is required. I've updated my firmware etc. but nothing seems to work

Rekordbox seems to recognise my RX, but when i click "link" the players show up Green and won't accept any tracks being loaded into them.

This seems to be since i granted access via the firewall, as prior to that, they showed up like normal but I just got the "Loading" message on my RX when trying to load a track... help!!

Ben Davenport

Please sign in to leave a comment.

34 comments

0
Avatar

Hi Pulse,

Thank you the for the quick response. However, sadly the link you have provided seems to go to a thread that has nothing to do with this issue.. It goes to a "when will... Come out?" Post.

Can you please post the correct link.

In the meantime, I can confirm from reading previous posts that I have allowed the following:

C:\program files\yourusername\rekordbox version-number\edb_streamd.exe - TCP
C:\program files\yourusername\rekordbox version-number\psvnfsd.exe - UDP
C:\program files\yourusername\rekordbox version-number\psvlinksysmgr.exe - TCP
C:\program files\yourusername\rekordbox version-number\rekordbox.exe - TCP

Thanks

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

Please also note, I was getting the same issue (green players etc.) when my firewall was disabled completely!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

Did you try connecting the RX directly to your computer with the network cable?
Did you try also to disable wifi?

Toonz 0 votes
Comment actions Permalink
0
Avatar

hey Toonz... yeh, I only ever connect it directly using the ethernet cable.

I've turned off my Wifi, turned off my firewall and still... it doesn't work.

As I mentioned, I get the link come up immediately! But when i press link I get the 2 players come up but they are green, as if they are the master... but there's no tracks on the player etc.

Reading through these articles, I'm absolutely miffed as to what it could be!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

the only thing I have noticed, if this makes any difference is that the network icon in the bottom left (I'm using windows 8) shows that there is a connection but it shows the "!" icon stating that there is no internet... I assume this is ok, as the system wouldn't be providing internet, but i don't remember seeing that on my old laptop

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

That's the "checklist" I've been using... the only thing I think I may not have covered is disabling sharing on the network... I'll check that after work!

Thanks for all your help Toonz!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

I can't seem to load tracks via my computer into Rekordbox as well (my players are turning up white) but I CAN select the tracks from my computer on my RX. The last option is causing no troubles at all. I would like to select (in some cases) tracks from my computer as I have a large collection Until 10 days it was working fine. Did I change something I should not have done?

Camiel Ekelmans 0 votes
Comment actions Permalink
0
Avatar

@Pulse... Update:

I can confirm that:

  1. My firewall is off
  2. My network sharing is disabled
  3. The firmware is completely up to date (v1.7)
  4. Rekordbox recognises my RX is attached by cable, as such I get the link button
  5. Wifi and all other connections are turned off

But yet still when I press "Link" I get the 2 players, both in green and unresponsive when trying to drag and drop a track into them.

I don't know what else to do!!!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

I checked my configuration:
I allowed TCP and UDP for all of these
C:\program files\yourusername\rekordbox version-number\edb_streamd.exe C:\program files\yourusername\rekordbox version-number\psvnfsd.exe
C:\program files\yourusername\rekordbox version-number\psvlinksysmgr.exe
C:\program files\yourusername\rekordbox version-number\rekordbox.exe

Also, perhaps you have a program or service that uses a port used by rekordbox (especially nfs)?

Toonz 0 votes
Comment actions Permalink
0
Avatar

Really appreciate all you help help Toonz, but sadly outside of checking what goes to what port (mainly because i don't how to do that), I have covered everything and still no luck!

@Pulse can you help at all please, because I even called the Pro DJ support team to be told that they didn't know either as it's software and not hardware!

they then gave me this form to complete:

https://forums.pioneerdj.com/hc/en-us/requests/new?ticket_form_id=72145

Which despite being told will be answered within 48 hours, I'm still waiting 72 hours later!

I currently have an XDJ-RX and a laptop with Rekordbox 4.0 and no way of connecting them! I'm at a complete loss what to do next!!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

@Ben > Oops, sorry, yes - Toonz linked the correct article with the info. Did you check that article for applicable info? You may want to verify that your network group is HOME or WORK (private) and not PUBLIC. If you go into the control panel and open the Network and Sharing Center, open the Advanced Sharing Settings and verify that on Private networks you have enabled network discovery, disabled file and printer sharing, and on All networks, turn off public folder sharing, media streaming, and password protected sharing.

Next, just disable the firewall completely, and run a malware and virus scan.

If you're running any other 3rd party security software, disable it. If you're running any 3rd party overclocking software, disable it.

I found your ticket, but as I'm helping you here, I've linked the agents here as well.

Pulse 0 votes
Comment actions Permalink
0
Avatar

Ok, so this seems to to be an incorrect setting... The network is appearing as "public" but is also appearing as an "identified network" to boost

Ive looked high and low to find out how to change this... Any ideas?

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

Sorry, I meant "unidentified network"... This also for some reasons means that I can't change it per the instructions. I actually found that thread myself... Tried and no luck at all! FYI I used option 3

Because it's unidentified, all the links in option 2 were missing. Any ideas how to fix that first? All the links I found were for unidentified networks trying to access the Internet, which obviously linking the RX isn't trying to do that

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

sorry I haven't been in touch for a while all... been a little manic!

So, to update you all... I tried all the above points... was actually hopeful of the registry file at one point Toonz.

However, nothing has changed. In an attempt to literally try anything, I have now updated to Windows 10, uninstalled McAfee (it was only a trial anyway), uninstalled Rekordbox, reinstalled Rekordbox...

... and yet, I still get the same thing! The link button comes on on cue, but as soon as i press link, it immediately shows both players as green with the little play triangle on them without any tracks etc. loaded!

I'm absolutely miffed now! surely it can't be this hard.

I've check the setting of my old laptop and they are the same... I don't get why they won't link properly!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

@Pulse> do you have a contact number for me to call that might be able to help! I'm desperate to get this working and nothing I try or noted here helps!

I've called the normal tech helpline etc. and they were unable to help as "they don't deal with it" despite calling the Pioneer DJ helpline. I then managed to find someone from Pioneer DJ who said they would be able to send through the case to the people in Japan or wherever it is... but I've been waiting for a response to that for over 2 weeks now.

I'm lost without the pro-dj link... HELP!!!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

connected directly via a LAN cable supplied by Pioneer... the same one that worked perfectly on my old Laptop.

Does anyone know of any operating issues with windows 8.1 and 10? maybe its a compatibility issue?

If that's the case, @Pulse, when is the next update being released to work with newer operating systems?

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

Appreciate the help Alistair, but i think you are moving away from the point. I'm trying to create a network, I have a pioneer XDJ-RX and it is connected directly to my laptop via a LAN cable... the cable is fine, the laptop recognises the RX connected, but when I press link, they don't link properly... I very much doubt it has anything to do with the cable

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

Welcome - and good luck.
(I'll be trying the same direct connection with the supplied cable, the same way you are later on tonight, and see if I get the same results. For what it's worth).

Al Godsmark 0 votes
Comment actions Permalink
0
Avatar

@Ben, I know you have tested a lot of things, but I've seen today on a french forum that someone had the same problem. And he fixed this by replacing the LAN cable supplied by Pioneer with another one.

Toonz 0 votes
Comment actions Permalink
0
Avatar

I thought LAN cables were universal! If that's the case, my sincerest apologies to Alistair!!

I'll check tonight and report back in the morning!

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

All good Ben!
Tried this on my setup a moment ago, and doing it the direct did not work for me. It didn't even show the link function on RekordBox. Only once I'd connected PC to the LAN. My thinking is that, the LAN has the BT router dishing out IP address for both the RX and the PC, and I even tried setting my PC as a DHCP server to no avail, or with a fixed IP...

If you add a switch/hub between the RX and your PC/laptop, this might just work though. Cheapest solution is getting a local tech shop to knock up a cat-5 cross cable for you to try.

Al Godsmark 0 votes
Comment actions Permalink
0
Avatar

Ben,

I've been dealing with the same issue. So far, the solution to mine was to run rekordbox with administrator privileges.

Note - I'm running Win7 and using a USB-Ethernet adaptor to connect my XDJ-RX to my PC.

Hope this helps.

Nick 0 votes
Comment actions Permalink
0
Avatar

I'll test it, but it's nice to know that i'm not on my own!

I meant to come back on here a while ago to let you all know that changing the lead didn't work either and that I've still not got it working!

@Pulse, you seem to have gone dreadfully quiet... do you have any input? Is this a reported issue? is there any new resolutions?

Ben Davenport 0 votes
Comment actions Permalink
0
Avatar

Sorry guys, got flooded with questions re: rekordbox DJ and I'm trying to play catch-up on all these topics and the notifications.

Sadly, 99.9% of these issues are computer related, and there are so many variables on the system end that could be causing these problems. We try to work through the major items (eg. firewall, network type) but trying to manage every potential configuration is virtually impossible. I've had users post that they had to reinstall the operating system to get it working - which tells me their hardware wasn't the problem, but rather a setting or configuration of software.

Let me know if the administrator privs works for you, if not, we continue to dig!

Pulse 0 votes
Comment actions Permalink