Have a feature request or suggestion? Post your idea here!

Publication

20 abonnés S’abonner
4
Avatar

Djm nexus 900 Recording

hey guys

 

i have the cdj 2000s and also the djm nexus 900 with onboard souncard and trcktor scratch pro 2

 

i would like to no if its possible to record thru the mixer diretly to the computer via the onboard soundcard?

Mark corbett

Cette publication n’accepte pas de commentaire.

140 commentaires

0
Avatar

ok it started fuzzing again for me after a while but once again its working fine again. im doing the same thing that u are in terms of start up. I have the first channel set to rec out in settings utility. then i set those inputs to the input of deck a. then i select input deck for mix recorder. i restarted my mixer and traktor when the fuzz started again and i decided to see how long it takes for the fuzz to start its been 6 and a half min with no fuzz. Its reallly strange.

joshomatic 0 votes
Actions pour les commentaires Permalien
0
Avatar

lol it recorded good for about 9min 30 sec then FUZZZZZ!!!! Im at a loss of words and solutions. I may just resort to my trusty Traktor Audio 10 for now.

joshomatic 0 votes
Actions pour les commentaires Permalien
0
Avatar

idk if this happens to you but for me the fuzz will come back when i start either channel 3 or 4

joshomatic 0 votes
Actions pour les commentaires Permalien
0
Avatar

I'm doing crazy tests to find something about fuzzes....The problem is that i haven't done any recording without fuzz....

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

I have a Macbook Pro i7. 8 GB of ram and 750 of HDD.

Just upgraded to 2.03

Updated my nexus and my 900 to the latest firmware

Updated Rekordbox if that helps.

Here is the video that what appears to be working fine until I stop recording it.  http://www.youtube.com/watch?v=FH71gGKv7R0

Note: I left the settings as the video had it.

  1. I recorded a file using the settings as seen in the video and the recorded file had some fuzz in it.

  2. The  fuzz came on all channels viewable in the Input Routing fuzz just like the way the video started.  SImilar to what  like Josh Hashimoto mentioned.

  3. The Fuzz went away after 30 seconds or so.

This issue is still happening to me.

 

Hope this helps.

Painless Wolf 0 votes
Actions pour les commentaires Permalien
0
Avatar

I just read on NI forums that other people were having trouble with the DJM900 soundcard. One user posted that he was using the built-in soundcard in the club and it all of a sudden stopped outputting sound on channel 3 and the only way they could make it work again was cycle power through the mixer again(restart it). Since then, he said they no longer use the built-in soundcard but instead use their Traktor Audio 10 because they dont want to run into the problem again and have no music going while the mixer has to restart.

joshomatic 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi everybody

I write my question here as it's also about recording with the DJM900NXS

The USB soundcard is detected as 16bits soundcard on my computers Windows 7 (i have 32 and 64bits versions)

I have no other choice in windows sound settings, is it normal ?

I got firmware and driver updated to 1.2

Thank you for your support, i join a screenshot :  http://www59.zippyshare.com/v/95990106/file.html

DJM900NXS user 0 votes
Actions pour les commentaires Permalien
0
Avatar

Pulse, can you help us (all mac users) please?

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

I'm having the exact same problem. I can't even connect the 900 to my mac via LAN to update the firmware?!?! 

I recorded a test using audio hijak pro and the fuzz was there even then so clearly it's a fault with the djm 900. 

elastic1 0 votes
Actions pour les commentaires Permalien
0
Avatar

It could well be a problem with the driver; I'll be testing against another Macbook today to try and determine the problem.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Okay, I tested again on two different generation MBP's and had varying results - sometimes it would do it, sometimes it wouldn't ... and across all three sample rates.  The engineers are aware of the issue and are looking into a fix ASAP.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Many thanks Pulse for the support! I'm waiting news about the driver/firmware fix! :)

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

I hope my videos were helpful!

 

PainlessWolf.com

Painless Wolf 0 votes
Actions pour les commentaires Permalien
0
Avatar

I'm getting in touch with Pioneer tomorrow about getting mine replaced. I didn't buy it from a shop, I was given it by Pioneer at a very special Dj/producer rate.

elastic1 0 votes
Actions pour les commentaires Permalien
0
Avatar

@elastic1 > Even a replacement unit would have this problem.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Wow! That's not a good look! I had to record a mix for my radio show the other day, and i had to go out the RCA's from the 900, into my audio interface, then record into logic.  Not ideal. 

elastic1 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Pulse

Hi, when linked to computer, DJM900 USB soundcard is detected as a 16bits soundcard on my computers with Windows 7 OS (i have one 32 and one 64bits)

I have no other choice in windows sound settings, is it normal ?

I got firmware and driver updated to 1.200

Thank you for reading :-)

DJM900NXS user 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi guys, 

To be honest im a roockie compared to you guys. I hope somebody can give some directions.

I've got 2 x a cdj2000 and a nexu-900.And i have a m-audio projectmix i/o soundcard. I would like to record my mixes digitally with software. I'm using adobe audition and protools m-powerd 8 but cant seem to get them  both working. Does somebody know which software i can us?, And i would like to edit it afterwards, but everthing with asio driver? I can rocerod it now with audition (ASIO) but i have to plug my monitors into my nexus to hear my realtime mix, when i'm done i need to plug my monitors back into my m-audio soundcard.

I can not plug my monitors in my soundcard and record a mix at the same time. Does anybody else have this problem?

Soeresh Kanhai 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hey everyone, here is what works flawless so far (fingers crossed) for me when recording:

 

PLEASE READ ALL STEPS AS 1 MAY BE THE SOLUTION FOR YOU!! :)

 

Equipment

Mac Pro 8-Core 12GB ram

Macbook Pro Core 2 Duo 4GB ram

1x DJM-900

2x CDJ-2000's

2x CDJ-900's

 

Software:

rekordbox

Audacity (free recording software online just google it)

Traktor (not used as I prefer rekordbox, but can test my gear with it)

 

Set-up:

All connect through "LINK" and players connect to mixer via "Digital Input" on each channel. Mixer connected via USB to Mac Pro.

Player 1 - CDJ-900

Player 2 - CDJ-2000

Mixer - DJM-900

Player 3 - CDJ-2000

Player 4 - CDJ-900

 

Settings:

DJM-900 Nexus VERSION 1.2.0:

To reach these setting Hold "Utility" on mixer and power up at same time. Hold until "DOUT LV" appears. To change a setting, hit "TAP" button and use < BEAT > to change. Hit "TAP" again to exit. Must power down and back up to use after complete.

DOUT LV "-19 dB", DOUT FS "96kHz", MS ATT "0dB", AUTO STB "ON", MIC BTH "ON", PC UTLY "ON", INITIAL "NO".

 

To reach these settings you must power on first, then press and hold "Utility" button. To exit just hit "Utility" again.

F.S. OFF, MIDI CH 1, MIDI BT TGL, TLK MOD ADV, TLK LVL -18dB, 

 

CDJ-2000's and 900's VERSION 4.04:

To reach these settings, you must power on first, then hold the "Utility" button for a few seconds. To exit, just hit "Utility" again.

QUANTIZE ON, AUTO CUE LEVEL "-60dB", HID SETTING "STANDARD", MIDI CHANNEL "Marked in order from far left player #1 to far right player #4",  ON AIR DISPLAY "ON", DIGITAL OUT "24bit", PLAYER No. "Marked in order from far left player #1 to far right player #4".

 

DJM-900 Nexus Utility on Mac VERSION 1.1.0:

MiIXER INPUTt: All set to "DIGITAL"

I understand this is where Traktor users will have the channels set to USB 1/2 through to 7/8.

A possible solution for you may be to attempt using rekordbox instead of Traktor, as it alone is a great music management software app. If you choose to continue with Traktor, you can also try using the USB functions instead of Timecode. Timecode should result in zero lag, but it is far better and easier "in my opinion" to use the USB function on the CDJ's instead of timecode. Using the USB function works with settings as "DIGITAL" including "CD/LINE" and "LINE". Why is the USB function better than using timecode? Because you can use far more functions on the CDJ's and you can program specific buttons to suit your exact wants and needs! My advice would be at least to use the CDJ's as USB controllers for Traktor and not use timecode. Please continue reading for more info

MIXER OUTPUT: USB1/2 "REC OUT", I am not using the other channels and left them as default settings.

 

If deciding to use CDJ's as USB controllers for Traktor on Mac, please download the "CDJ Aggregator" in the "Firmware, Drivers & Software" section of these forums.

 

CDJ Aggregator VERION 1.0:

Plug in all CDJ's and DJM-900 Nexus via USB cables and power them on. Run CDJ Aggregator. All USB connected CDJ's will appear as a single aggregate device under the name "Pioneer CDJ", click "OK" to close window.

Run Traktor, in Traktor Preferences select "Audio Setup" and choose the "Pioneer CDJ" aggregate device you created as the "Audio Device".

Proceed to "Output Routing" on the left panel, and select "Output Channel A" L: Front Left, R: Front Right, and "Output Channel B" L: Pioneer CDJ Out 2, R: Pioneer CDJ Out 3, if not done so already.

You are now setup to run your CDJ's as USB controllers and do not require any timecode.

 

FINALLY FOR RECORDING!!!!!

In "Spotlight" on Mac (the magnifying glass in the top right corner), search for "Audio MIDI" and select the "Audio MIDI Setup" application. OR without using spotlight, navigate from "Finder", "Applications" folder, "Utilities" folder, "Audio MIDI Setup" application.

In Audio MIDI Setup, select the individual "DJM-900nexus" device. Not the aggregate device you created. Under the "Input" settings, select "96000.0 Hz" and "8ch-24bit". Under "Output" setting, select "96000.0 Hz" and "8ch-24bit" as well. Then "Quit" "Audio MIDI Setup" or press "Apple + Q".

 

Download "Audacity" free from their website. VERSION 1.3.12 is the latest version I have, but there could be a newer version.

 

After installing "Audacity" open the application.

Under the title "Audacity" in the top left corner, navigate to the "Preferences" pane. On the left panel, make sure you are in "Devices"  and set "Playback" to "Headphones" OR "Built-in Line Output" depending on your Mac and connections. Under "Recording" set the "Device" as "DJM-900nexus) and "Channels" as "2 (Stereo)". Then, on the left panel select "Quality" and make sure the "Default Sample Rate" is "96000 Hz", and "Default Sample Format" is "24-bit". Click "OK" to accept.

 

 

After all of these steps, it should not be necessary to restart your Mac, but it might not be a bad idea.

NOTE: Once restarted if you chose to, double check the settings in "Audacity" when you open it, and double check settings in "Traktor". When using CDJ's as controllers in "Traktor" be sure to plug in, power on, and choose to use the CDJ as a USB controller before starting "Traktor".

 

Now you are ready to load your tracks from "Traktor" on your CDJ's via the CDJ selector knob. Prepare "Audacity" to record. You can click the big brown circle thats a button to start the recording, or simply press "R" and the recording will begin. Then play your CDJ and make sure all the levels are set on your mixer. You should actually see "Audacity" creating the Waveform as it records! If you do not see the waveform, you set something up incorrectly and should recheck your settings. If "Audacity" is recording properly and you see the waveform, but still hear the fuzz that everyone is mentioning, then I'm not exactly sure what the issue might be as all of these settings work flawless for myself and the sound card sounds perfect.

 

Sorry for the long process everyone, but that's what works for me. I hope this helps a few people out if they are having some troubles. If not, I'm sorry to waste your time reading all of this and attempting this if you did so.

 

If you need anymore help, just reply and let me know what the problem is and I'll try my best.

 

Also, if you guys have any requests for testing my gear with new things or any problems, please post them here or message me at andy _ froster @ hotmail (dot.) com. I can test any requests with CDJ-2000's, 900's, 400's, and DJM-900, 800, and 400.

 

Take care and let us know if this works for any of you out there!

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

Happy to say I recorded fine with mine. Just set all channels to recording mode and used magix audio cleaning lab to record. Here is a link to the mix if you would like to here the sound quality. It is a house mix and I have used some of the effects on thi mixer. If you want to feedback on the mix good or bad feel free to do so.

http://soundcloud.com/arwel-the-monk-abbott/sounds-of-the-summer

Arwelthemonk 0 votes
Actions pour les commentaires Permalien
0
Avatar

@ Grizzly, have you attempted all of the steps and setting I listed above to see if one of these fixes the issue?

What id your current set-up with equipment, connections, and software?

 

Thanks,

Foster

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

MAcBook Pro

4GB 2,66GHZ Intel Core i7

OS X 10.6.8

Technics 1210 MK2

DJM 900

FW: 1.2 and latest driver update

Traktor Scratch Pro 2.0.3

Just updated the firmeware and the driver.

I double checked my settings against yours everything should be fine....

no matter what kind of audio I route into the mixer it is still recording with fuzz...

fuck!!!

The Strange thing is I did some nice recordings and everything was fine (1 month ago), then suddenly the fuzz came for no reason.

Grizzly Adams 0 votes
Actions pour les commentaires Permalien
0
Avatar

Grizzly - This is exactly the reason you need to send it back.

How can some of the 900 mixers have this problem and some don't?

How can someones mixer be working fine one minute then not working properly the next?

Mines on it's way back. If i had paid £1600 for this mixer i would be very dissapointed. 

elastic1 0 votes
Actions pour les commentaires Permalien
0
Avatar

I think is a firmware problem. Some people doesn't have problem (old firmware/windows users) and some people have problem (new firmware 1.2/osx users) 

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

@ Grizzly

 

Hmm, that's an odd one that it does it now but not a while ago...

Can you roughly estimate when you updated your Mac OS to 10.6.8?

That might be the difference between our computers. I'm using 10.6.8 on my Macbook Pro, but have only tried the recording on my Mac Pro which is still running OS 10.6.7. I've held off on the update on my Mac Pro for now... Maybe I should hold off a bit longer if this is the problem...

I will set everything up with my Macbook Pro and try it on OS 10.6.8 when I get some time later today.

I will let you know how it goes.

 

Thanks,

Foster

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

I have a feeling it has something to with with Mac 10.6.8. I have tried all the same settings as Foster (except on 10.6.8) and I still have issues recording. I think some of you guys need to relax with sending your mixer back cause you're most likely wasting time and will receive another one with the same issue. Once Foster comes back with more tests then we will have more answers.

If his setup works flawlessly on his 10.6.7 Mac Pro but has the fuzzy recording issues on his 10.6.8 MacBook Pro, we can stop blaming our mixers and hopefully Pioneer will have some answers/solutions for us as well.

Tarek Shbib 0 votes
Actions pour les commentaires Permalien
0
Avatar

"Fuzz" Identification Confirmed!

@Tarek - Thanks and your theory was correct. :)

 

The issue with recording is a Mac Software Update problem!

 

My recording works flawless on OS 10.6.7, upgraded my other Mac to 10.6.8 and I can replicate the "fuzz" everyone has been mentioning. 

 

My total update consisted of:

Java for Mac OS X 10.6 Update 5 ................. Version 1.0

Mac OS X Update ............................................. Version 10.6.8

iMovie 9.0.4 ........................................................ Version 9.0.4

GarageBand Update......................................... Version 6.0.4

iPhoto 9.1.5 ........................................................ Version 9.1.5

iWeb Update ...................................................... Version 3.0.4

iDVD 7.1.2 .......................................................... Version 7.1.2

CHECK YOUR UPDATE LOG BY GOING TO "PREFERENCES", then  "SOFTWARE UPDATE", then "INSTALLED SOFTWARE".

I am assuming the problem was the Mac OS X 10.6.8 update, as it is the only update that would change the general settings, or operating system.

 

I have gone through multiple tests and I have managed to get the recordings clear, but it has taken a lot of playing around and changing of setting!

 

This is just the update for everyone to let you know the problem appears to be the Mac OS X 10.6.8 Software Update.

IF YOU HAVE NOT UPDATED YOUR MAC TO 10.6.8, PLEASE HOLD OFF FOR NOW UNLESS NECESSARY!

IF YOU ARE STILL RUNNING MAC OS 10.6.7 , PLEASE FOLLOW MY STEPS POSTED ABOVE AND POST HERE IF YOU ARE NOT ABLE TO RECORD CLEARLY WITH YOUR SOFTWARE.

 

I will post an update in a bit after some more diagnostics on how to get clear recordings (if possible) on Mac OS X 10.6.8.

 

Thanks for your patience,

Foster

 

P.S. - I would also advise others to hold off on sending away your perfectly good DJM-900 Nexus if this remains to be the direct cause.

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

Please Note: It is not guaranteed 100% a Mac OS X 10.6.8 Update issue, as it could possibly be something between the compatibility of the new DJM-900 Nexus firmware update and Mac OS X 10.6.8 software update. So it could be Mac OS X 10.6.8 all by itself, or it could be an issue with both the DJM-900 firmware and Mac software together.

 

Alright, so I've been able to replicate the issue, but with no determining factor or signs.

Once it went fuzzy exactly as I used my "Hot Corner" to "Show All Windows" after being on the Audacity app window for just over 1 minute. I have not been able to replicate this since.

Multiple times I was able to replicate the "fuzz" when pressing record in Audacity and hitting "Play/Pause" or "Cue" on the CDJ at the same time the grid appears on the screen to record. Appeared like it was too quick or something odd. But I have only been able to do that maybe 30% of the time.

I have been able to replicate the "fuzz" recording with and without the "Audio MIDI Setup" Preferences pane up.

I have been able to replicate the "fuzz" after shutting down "Audacity", checking my settings and restarting the software.

I have attempted shutting down recordbox and restarting the software and can still replicate the "fuzz".

 

As of now I do not have a complete solution, only some tips to help you try to get your's working correctly more often.

 

These tips are specifically for Audacity but may apply to other recording software.

 

  1. Make sure all settings are similar to mine posted above first.

  2. You can also set the "Quality" rate in Audacity for "44100 Hz" and keep other audio settings the same. "96000 Hz" is higher quality, but it can record with the settings in either mode on Audacity. (This is not a fix as "fuzz" occurs in both for myself)

  3. In Audacity "Preferences" on the left pane, select "Recording", then select the third checkbox as "Software Playthrough". Then go to "Devices" on the left pane, and select "Built-in Output" or "Built-in Line Output" depending on your Mac. Connect a separate pair of earphones or headphones to your computers "Line Out", or "Headphone Jack". This will allow you to preview the quality of the recording as it occurs. Therefore, if the "fuzz" begins in the recording, you can hear it, stop it, and possibly change some settings or try again.

  4. If you are recording, and the "fuzz" occurs part way through your mix, you can stop it, return to before the track went fuzzy, and begin recording again. It will automatically start recording on a new line, and afterwards, you can use the built in tools to chop and cut your mix then piece it together. (I understand this can be a bunch of b.s. when you expect things to work - but hey, it's a temporary [hopefully] way around this issue.)

  5. When starting a recording, play your first track and record it for half a minute or so, while listening to the preview of the recording as it records. (Tip #3) Once you have confirmed the first 30 seconds or so is clean with no "fuzz", cue your track back to the beginning, but DO NOT STOP THE RECORDING. Let the recording continue for a few seconds of silence, then begin your track again and start your mix. After the recording you can simply cut out this first test by using the built in tools in Audacity. (Again, just a quick check to make sure the recording is clear before you start, and it is not guaranteed it will remain clear for the rest of your mix. So please keep checking back when you can.)

  6. For now, you can record out of the "Rec Out" on your DJM-900 and into your external sound card if applicable, or into the "Line-in Input" on your Mac. ( I understand this is not what you paid all your money to have to do, but it's hopefully a temporary fix for now)

 

Pioneer is looking into these problems for us Mac users. Hopefully we will hear back soon.

 

I hope some of these tips and this troubleshooting has helped some of you so far.

 

Thanks,

Foster

Foster 0 votes
Actions pour les commentaires Permalien