Have a feature request or suggestion? Post your idea here!

Publication

20 abonnés S’abonner
4
Avatar

Djm nexus 900 Recording

hey guys

 

i have the cdj 2000s and also the djm nexus 900 with onboard souncard and trcktor scratch pro 2

 

i would like to no if its possible to record thru the mixer diretly to the computer via the onboard soundcard?

Mark corbett

Cette publication n’accepte pas de commentaire.

140 commentaires

0
Avatar

@Foster>Thanx for the help and advice i will have a look and try 1 of your solutions now... not being able to record is no good!!! Thanx again!!!!!!

Gilly_gilchrist 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Gilly > No problem. ;)

The simplest solution is to actually go out to a store and buy a dual RCA to stereo 1/8" cable, plug out of the Nexus RCA Master or Record and into the input on your Mac. lol That's a sure fix and it will definitely work. You could probably find the cable at a dollar store that will work fine until the fix it out. It's a handy cable to have for situations like this. ;)

Foster

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Foster> i have a couple of them cables... i could use garage band to record mixes or is there another program? We dont have dollor stores in UK. Pound shops we call them!! haha!! I think i will try that because that seems the simplest way as i am not very technical. Good job for explaining. Solutions not problems!! that is how we roll!!!

Gilly_gilchrist 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Gilly > lol sorry I didn't know you're in the U.K. Yeah that's probably the easiest way and only guaranteed way it will work properly at the moment unfortunately.

Yes, you can record with GarageBand, and you can also download "Audacity". Audacity is a free app for Mac and Windows and it's pretty amazing if you ask me. Lots of great features and it's simple to use and follow. Good control over audio, and you can chop up, edit, add effects, cut eq's, use vst's.... almost anything is capable with it. I think it would be a great program to use. And just in case you download Audacity, you will have to download the "LAME 3.98.2" which is also free and can be located through the Audacity website. The "LAME 3.98.2" is used to export your recordings as .mp3 files.

Let me know if you need a hand with anything else, we might have to discuss off this forum as it's 3rd party.

Take care,

Foster 

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

what´s up pioneer, where is our update?

 

btw:

the problem for me exists only on my Macbook (10.6.8) and DJM (1.2)...

on my W7 it´s all fine, no fuzzes, no distortion... nothing -.-''

 

the problem is known since late june/early july - much time for a fix?

would be happy to see anything very soon ...

 

 

greetz

van NoXx 0 votes
Actions pour les commentaires Permalien
0
Avatar

@ van NoXx > thanks but we have already diagnosed the problem to be Mac 10.6.8 only. Windows is fine and previous Mac OS X updates are flawless.

A fix is coming soon. Please be patient as the engineers are working hard to fix this and other minor updates.

Thanks,
Foster

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

It's september...............any news about Pioneer DJM900 driver / firmware that fix recording / timecode issue?!?!

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

Another week has passed and the problem is not solved yet

no news?

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

This is really taking very very long. As I am now also on a Mac system  this issue becomes very annoying. Should record a set but how, just sold my Ecler EVO 5.

Bubla 0 votes
Actions pour les commentaires Permalien
0
Avatar

It's very annoying. I just bought the mixer and i can't record my sets proper way.

The way i am recording sets on my macbook pro is connecting djm 900  rec out with my laptop sound card audio input. 

Please fix this bug quickly!

 

medialook

medialook 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi everyone, I have found a temporary solution to fix this issue. I have spent a few days looking for a way to record with DJM-900 and Traktor and keep seeing this post through Google so thought I would help everyone out.

The issue is with the latest Snow Leopard 10.6.8 and the latest DJM-900 driver. For some reason they are not working together. What you need to do is backdate/reinstall your Snow Leopard back to 10.6.3. I think 10.6.5 will also be fine.

Make sure you don't update to the latest 10.6.8 after reinstalling. I have recorded with Snow Leopard 10.6.3 and I am getting crystal clear sound on the recordings.

I set Traktor Sample rate to 44100 Hz and made sure the DJM-900 in the Utilities/Audio MIDI Setup matches the 44100 Hz. I cranked the audio latency right up 4096. This is the maximum and a multiple of 256. I am not getting any kind of lagging and excellent sound quality.

I downloaded the latest Pioneer DJM-900 Nexus driver 1.1 for Mac from the Pioneer website. In the setting utility of the DJM-900 driver I set channels 1, 2 and 4 to REC OUT.

In Traktor I am using Channels 1 and 2 to record a mix. In the Traktor preferences Mix Recorder tab I set to Source - External, External Input - Input Deck D and the file size to 2048 MB.

I hope this helps anyone who is looking to record a mix. It could be some time until the driver is released.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

Or just wait as the update is just around the corner.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

fuzz fuzz fuzz glad too see this post though since i was thinking it was me doing some wrong sound routing waiting for the fix:)

I've just used my internal soundcard to record sets but hopefuly with a fix this mixer will do everything it's intended to do

Amine Jouirou 0 votes
Actions pour les commentaires Permalien
0
Avatar

Still having same fuzz after updating lastest driver on os x:(

music kids 0 votes
Actions pour les commentaires Permalien
0
Avatar

I waited 4 months and still the driver does not work! 

I think that Pioneer should answer the quesiton as soon as possible because it is becoming ridiculous.

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

Just follow the instructions above and backdate your Snow Leopard. You will be able to record. I was tired of waiting. 4 months is too long. I am happy just keeping my Snow Leopard at 10.6.3 for now. It's already been a week since I wrote my last message. I can see this update taking a while yet.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

I would not advise back dating your OSX because some of the latest updates for Mac OSX Snow Leopard have been for security updates. 

I do not see why 'WE' should have to change our operating system to an old version to get the product to work. 

I bet Allen & Heath are laughing their heads off. 

elastic1 0 votes
Actions pour les commentaires Permalien
0
Avatar

I only use my Mac for DJing so I am not online with this laptop and there is no information stored that would cause any security issues. I think it is best to turn off wireless, bluetooth etc when using Traktor and recording. I need to record mixes and this is a fix for now. It is up to you if you wish to try it out but it works perfectly. Just thought I would try and help everyone out as there seems to be a lot you out there wanting to record. When the driver comes out you can then update to 10.6.8 or Lion.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

Just to follow from my last message you could just create a partition on your mac drive and install the older 10.6.3 separately. You could just boot and use this partition when you want to record and keep your main Mac OS X partition for everything else. Just a thought.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

If people would read this entire post they would probably find a lot of the comments they are making have already been made...

We diagnosed the issue when it first occurred, and we stated multiple solutions to the problem until a fix is released.

@ JonnyLawless > If people do this, they would need Rekordbox installed on both patitions and it would save 2 collections of Rekordbox on their hard drive, not convenient for me personally, but for others, make sure you leave enough space if you even have enough space to re-load Snow Leopard to begin with.

More pratical solutions for the time being are to try some of the things people posted in the beginning.

Thanks for your help everyone.

Foster

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

"I waited 4 months and still the driver does not work! 

I think that Pioneer should answer the quesiton as soon as possible because it is becoming ridiculous."

/sign THIS!

I´m not about to do anything on my MPB, not even a partition with a downgraded OS X.

When it´s a clear issue of a 10.x.x version, there must be a change log what happend in this update.

Don´t know, but, why the hell announce and bring out a new driver which don´t fix the retarded problem?

van NoXx 0 votes
Actions pour les commentaires Permalien
0
Avatar

No need to use Rekordbox if you are using Traktor. You can also have a separate Snow Leopard on a USB drive or external hard drive if you are worried about space - its not really that difficult. You can just use the separate Snow Leopard for recording. Just copy across the tracks you want for your mix - no need to have your full collection twice. Personally I have just backdated my whole Mac and I not using a partition. It's works great and have been playing out and recording my mixes. It's up to you but not very difficult to do.

Nothing in the earlier posts worked on my Mac - that's why I took the time to find another solution and to share it with you. I hunted all over the internet and nothing worked. The current driver seems to be not designed for 10.6.8. If anyone has any other solutions then please feel free to share but this is the only way I have found.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

we need a OFFICIAL solution, not only a workaround! Pioneer, are you alive?!?!?!

Mattia 0 votes
Actions pour les commentaires Permalien
0
Avatar

I just downgraded my system to 10.06.3 and everything works fine...

the problem is apple so get at apple!!!!

waiting for the next osx update

Grizzly Adams 0 votes
Actions pour les commentaires Permalien
0
Avatar

Guys, we already diagnosed the problem was the Mac OS X 10.6.8 update, and there are no more Mac OS X updates after the 10.6.8 supplement update. Therefore there will be no fix from Apple and it is left up to Pioneer to release the fix.

 

@ JonnyLawless > Some of the previous posts will fix the issue as I tested them myself and posted the results. As well as your methods were also posted before you re-posted them just in more detail.

Simply enough, the easiest fix is to use a RCA to 1/8" connector and go from the record out RCA on the DJM-900 to the input on your Mac which ever model it is. That is hands down the quickest fix to be able to record. Unless you need to download third party software to record and all that jazz, then it would take a bit longer.

If anyone is going to use this method, I would recommend using Audacity as your recording software as it's free and easy to use. 

 

@ Mattia > Agreed mate, a fix is coming soon. The Engineers are working hard on the fix.

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

Some of you guys must be delusional if you think it's Apple's responsibility to program their code around a Pioneer product. This recording/firmware issue is no ones fault, but only Pioneer has the responsibility of getting this to work as intended. All we are asking is to be able to use the mixer as was intended and advertised. These temporary fixes might be OK for you guys who just recently bought your 900 but me and a lot of other people have been waiting over 4 months for a fix. At least they could keep us up to date with their progress. Keeping your customers in the dark about these kind of things is old school. Welcome to the 21st century.

Also, while we appreciate these workarounds you guys are offering, they are completely useless in a professional setting. A practical fix is due. I mean, why would they even release a firmware update that didn't address this issue? They don't even mention it. I'm starting to worry if anything can be done to fix it.

Tarek Shbib 0 votes
Actions pour les commentaires Permalien
0
Avatar

Foster I am glad you fixed your recording by using a RCA cable. I did try this and recorded with Audacity and it did not work. This was one of the first things I tried. Did you get this work? Did you manage to record for hours at a time with perfect quality?

I have not heard of anyone having any success with this yet. The sound quality was awful. If you can simply use a cable that would be great but I found whatever I used to record whether it was Traktor, Audacity, Cool Edit whatever all had the same result when connected from the Mac. I even recorded using a separate computer and the sound quality was still the same. It did not matter which output on the DJM 900 I used it was the same bad quality.

I found reinstalling Snow Leopard to 10.6.3 worked with amazing sound quality. I have not seen any other methods work and I have read through every post on this forum many times. If there had been a fix I would not have needed to create an account and try and help out.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

@ Tarek > Agreed, this is not Apple's problem to fix, and it it no ones fault. I've had my 900 from the first of it's release and I am lucky enough to be able to keep my DJ'ing computer and casual computers separate, and keeping my DJ computer offline. Therefore I do not do software upgrades very often, and check results and performance before upgrading. In a nut shell, I play it safe, so my 900 records flawlessly with my DJ'ing computer. And I do understand, the temporary fixes are starting to feel permanent, but hopefully we won't be waiting too much longer. And if you want to get technical, for use in a professional setting, they do not use built in sound cards like on the 900 to record with. They usually use separate individual devices to record live sets, and sometimes external systems to record a mix, or mostly just do the entire mix within a software app like Ableton.

 

@ JonnyLawless > I do not use the RCA to 1/8" adapter to record as my 900 works flawlessly. However, I'm unsure why the audio recording would sound "awful" as you mentioned. Could you record a small sample with this method and upload it for us to hear? I believe the quality should be decent enough to use... if it's not, then I'm not sure whats wrong. Post a clip if you can and we can try to help you out mate.

Foster 0 votes
Actions pour les commentaires Permalien
0
Avatar

Foster are you using Windows? If you have not even tested a cable then how do you know if it works or not? Believe me it does not work. The drivers for the mixer and Snow Leopard cause the output sound to be terrible when recording. I do not need to record a sample as anyone will tell you the same and I do not have the time for it. Also I am not going to update my Snow Leopard just so I can send a sample as I will need to reinstall again. If you read the start of this forum you will many others have already tried a cable and posted the sound quality samples on here. You will see they are awful quality,

If you do not have a better solution that you have tested yourself it would be easier not to confuse people on this forum. The only way is to back date your Snow Leopard for now. Simply recording from a cable does not work. This was the most obvious thing to try first.

JonnyLawless 0 votes
Actions pour les commentaires Permalien
0
Avatar

I used a cable. Worked fine for me. From the Rec out of the 900 to an input pair on my interface, then I record in logic 9.
Would be a lot better & easier though if the digital record worked though lol

I have faith in the Pioneer guys! We'll get a fix/update soon enough I'm sure.

elastic1 0 votes
Actions pour les commentaires Permalien