Have a feature request or suggestion? Post your idea here!

Publication

15 abonnés S’abonner
5
Avatar

[OPEN] Rekordbox 3.0.3 and the 3.1 crashing

Hello,

Since I've updated my mac to Yosemite my Rekordbox is crashing only when I play songs. if I am analysing or exporting nothing happens, only I play songs it crashes after 7 to 10 min.

please help me with suggestions.

 <SNIP>

Bachir Salloum

Vous devez vous connecter pour laisser un commentaire.

104 commentaires

0
Avatar

exact same problem, any update on this?

Nima Tahmasebi 0 votes
Actions pour les commentaires Permalien
0
Avatar

Having used Rekordbox for years this version (3.1.0) is still constantly crashing on OSX Yosemite. It's unstable as hell! I get loads of bugs and quite often it just quits. I am trying to analyse a bunch of tracks today and it just crashes. I spent hours manually amending my library earlier - it then crashed and told me it lost the library. All my changes had been lost.

Pioneer this is the workbench for nearly all of your flagship products and it really needs to be less buggy! Please tell me a new version is on it's way because we can't work with this at all..

Richie Barthez 0 votes
Actions pour les commentaires Permalien
0
Avatar

This has been brought to the engineers attention and once I have a solid answer, I will post it here.  I always keep multiple copies of sw when I update just incase there is an issue initially.  In this case it may be a problem because of Yosemite (not pointing back to Apple) so I will see where we are with this...

Jay 0 votes
Actions pour les commentaires Permalien
0
Avatar

Version 3.2.0 is out today guys! Downloading now and feeling hopeful! 

Richie Barthez 0 votes
Actions pour les commentaires Permalien
0
Avatar

V3.2 has the same problem. Crashed about 7 minutes after I started playing music. I do like the visible cue points in the preview waveforms though.

Matt Donatello 0 votes
Actions pour les commentaires Permalien
0
Avatar

Just loaded Rocordbox crashes 8 to 10 minutes every time any song . OSX Yosemite 10.10.2 I want this to work .what do I do .,Thanks

Rick Auletta 0 votes
Actions pour les commentaires Permalien
0
Avatar

About to buy a XDJRX but not until I get the Recordbox to work . I Have a Stanton SCS4DJ I use for on the fly fun. Can be operated any were . Analyze's on the fly never crash's . I have been waiting for years  to have a pro model all in one unit From Pioneer lets get this software figured out . Crashes every 6 or seven minutes wile playing music ... Thanks Rick 208-290-1296 how about some help

Rick Auletta 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hey guys, the engineers want to confirm that the instructions previously provided were followed properly as they note:

Because of the "smart quotes" function of Mac, when a user changes the text 0 to 1, the double quotation text is changed so that the value can be read as 0 instead of 1 even after changing the value. 

  1. From the “Go” menu in the Finder of Mac, select "Go to Folder...". 
  2. In the popup window, please type in “~/Library/Application Support/Pioneer/rekordbox” to open the folder and find “rekordbox3.settings”. 
  3. Control-click or right-click “rekordbox3.settings” then select “Open with” -> “Other...” and use TextEdit to open the file. 
  4. Find the following line in the settings file. 
    <VALUE name="DisableOpenGL" val="0"/> 

Screen_Shot_2015-02-15_at_8.52.27_PM.png

  1. Then, change the value from “0” to “1” as shown below. 
    <VALUE name="DisableOpenGL" val="1"/> 
    Please note: Be sure to copy the text "1" including the quotation mark " " in for example, 
     <VALUE name="nexusServerIsActivated" val="1"/> in the TextEdit and paste them instead of directly typing the value 1.

Close the file and restart rekordbox. 

Please try this process to solve the crash problem. 

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

SAME HERE. I am currently running rekordbox 3.2.0 and it just periodically crashes. I have followed the instruction on this forum and nothing helps. I'm running top of the line mac book pro and I have 16gigs of memory. Help!? or should I sell this $10,000 worth of Pioneer DJ gear!

Jim Slaton 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hi I have followed the cut and paste advise above after suffering the same problem and it's all working fine now don't type the "1" copy the full text line with the "1" in it and then delete the original line with the "0" and paste the full line with the "1"

Hope you can understand, it's all working fine after I did this:)

I am Boardy 0 votes
Actions pour les commentaires Permalien
0
Avatar

Copy this:

Follow the instructions above which will take you to the blue highlighted line, delete it, then paste the new line.

It will work!!!

I am Boardy 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Jim > I understand your frustration, but asking if you should sell your $10,000 worth of gear is a bit of a silly question when the likely solution is already provided. If you have followed the instructions, and as @I_am_Boardy has noted -- actually copy-and-pasting the value rather than typing it, you should have a solution, but if you did and it is still failing I would like to help you out, but would prefer you start a new thread if that is truly the case.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

By the way thanks pulse for finding a solution, I'm once again very happy with my setup:)

I am Boardy 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Boardy > The engineers know this is a temporary work-around and will be trying to implement a better fix for the software to ensure the best performance on all machines, but at least this gets users away from crashes for the time being!

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Well, I must say that it took several attempts at changing the value (<VALUE name="DisableOpenGL" val="1"/>) but it seems to be working for the moment. However, I'm getting all sorts of glitches. Just take a look at the attached screenshot. FYI- I'm on a pretty strong computer with 16gigs of RAM. See the link for screenshots... http://bit.ly/1FfFLBi

 

 

Jim Slaton 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Jim looking at those pics, that's what was happening to me before I changed the value. It has since stopped. It looks like you're getting the white flashes across the wave form.

Richie Barthez 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Richie Thanks for your help. I made the change to the value once again so I'm hoping they go away. Wish me luck!

Jim Slaton 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Jim did you paste the "1" or type it? For some reason typing it doesn't work at all.

Richie Barthez 0 votes
Actions pour les commentaires Permalien
0
Avatar

@Richie Yes, I copied the "1" a few times and it finally stopped RekordBox from crashing but I still get the software glitching like in the screenshots. Pioneer needs to release a updated version to fix these problems. Thanks!

Jim Slaton 0 votes
Actions pour les commentaires Permalien
0
Avatar

Same problem on my laptop with WIN8.1 X64, already since version 3.01. I will try the fix by disableing the OpenGL setting and hopefully Pioneer will fix this issue in a next update.

Edwin Collins 0 votes
Actions pour les commentaires Permalien
0
Avatar

@DJ Energy_NL > You won't find that OpenGL setting on the PC; that is a Mac-only setting. If you are experiencing crashes, it could be due to your database. ** Please read through this thread first and try the fixes.** If you are still experiencing problems, please post to a new topic rather than replying here -- too many users with different issues in the same thread causes difficulty in providing proper support.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Actually i do have a OpenGL setting in de rekordbox3.settings file in Windows and i changed the value from 0 to 1. I will do some serious Rekordboxing tonight and keep you informed about the results.

Edwin Collins 0 votes
Actions pour les commentaires Permalien
0
Avatar

Hey guys, please check out the newest release of rekordbox 3.2.1! Let us know if the fixes address your concerns.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

Another version update and still no fix for this problem... any news on this issue? it's not so bad that the main functions of the software are working, but the crashes are making things really difficult. If I turn opengl off I get too much lag and it's even more difficult to work with so I've just had to leave it on.

would be nice to know something is in the pipeline?

 

Mike Barty 0 votes
Actions pour les commentaires Permalien
0
Avatar

Think of this as a "workaround" to at least get users running without having to edit the config file. Note that this is a minor version update, not a major version or whole number.

Pulse 0 votes
Actions pour les commentaires Permalien
0
Avatar

yeah no worries it's not a huge problem I was just curious as it's been a while now with no solution.

 

to answer your question I had a crash as per usual after installing the new version so if it was supposed to stop the crashing it hasn't worked

Mike Barty 0 votes
Actions pour les commentaires Permalien